×
Kunena 5.1.13 Released (21 Jul 2019)

The Kunena team has announce the arrival of Kunena 5.1.13 [K 5.1.13] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Merged [Merged topic] Fakepath error with attachments

More
9 years 53 minutes ago - 7 years 3 months ago #1 by tonlabee
When a user want to upload a file in IE8 he gets C:\fakepath\sample.jpg in the attachement field.
In Firefox it seems to be ok.
This forum has te same error.



Wat can be wrong?
Attachments:
Last edit: 7 years 3 months ago by sozzled. Reason: Change topic icon

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago - 8 years 11 months ago #2 by sozzled
G'day, tonlabee, and welcome to the forum.

I don't understand the "C:\fakepath\..." issue - which seems to involve something on your PC.

tonlabee wrote: This forum has the same error.

I am using IE8 to compose this post and to attach an image.

I don't see that issue here at this site, sorry. I see other issues with IE8 ... but not that one.
Attachments:
Last edit: 8 years 11 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago #3 by Cerberus
fakepath is a deliberate part of K1.6 it is designed to protect your site files and is a security measure.

im personaly more worried that you are saying that this is not happening under FF than the fact it is working under IE8.

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago #4 by tonlabee
I've tested it now in IE8/FF and Chrome on PC and Notebook at my site and this Kunena site. (see attachements)
It is only visible, as I mentioned before, in IE8 :blush:







Is it a security issue, or something else?

A visitor on my site had the same problem so he said.
Attachments:

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago #5 by fxstein
I think there are a couple things mixed together.

1.) Preview of images/attachments that have not yet been submitted is not supported
2.) fakepath or not is a measure Microsoft built into IE8 to obscure the location of the file being picked up. I think it is a config setting in IE8 whether to show it or not. It should not matter. This path is not used for anything but to identify the initial file name of what is being uploaded.

Other than the display of fakepath, what is he real issue? Are you saying uploads are not working? Can you attach a file in IE8 and upload it when you hit submit?

We love stars on the Joomla Extension Directory . :-)

Please Log in or Create an account to join the conversation.

More
8 years 9 months ago - 8 years 9 months ago #6 by billco
The "C:\fakepath\" append to file upload paths is an HTML5 recommendation and so far has been implemented on IE8 (but can be switched off) and chrome (cannot be switched off).

And YES it does break the upload function on any kunena installation.

Eventually all browsers will be implementing the fakepath thing, so kunena's upload function will be disfunctional across the board (no pun intended).

Is there anything that kunena can offer as a workaround?
Last edit: 8 years 9 months ago by billco.

Please Log in or Create an account to join the conversation.

More
8 years 7 months ago - 8 years 7 months ago #7 by ktruhan
I am getting a problem with the fakepath every time I attempt to upload an attachment. I have read this has been troublesome in the past and apparently there is no way around it???

What can be done with this? Has there been any update since the last query regarding this matter???

It is very troublesome, because my users are senior citizens and have a very, very basic knowledge of using the forum (in other words, getting them to use a specific browser for our site alone is not feasible).

Here is my report:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 32M | Max file upload: 10M

This message contains confidential information

Joomla default template details : ja_purity | author: JoomlArt.com | version: 1.2.0 | creationdate: 12/26/07

Kunena version detailled: Installed version: 1.6.1 | Build: 3858 | Version name: Timu | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Installed (Version : 1.2.3) | Jomsocial: Disabled or not installed | UddeIm: Disabled or not installed

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Disabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Disabled or not installed | My Kunena Forum Menu: Disabled or not installed | My Kunena Forum Posts: Disabled or not installed

Modules: Kunena Latest: Enabled (Version : 1.6.0-RC2) | Kunena Stats: Disabled or not installed | Kunena Login: Disabled or not installed

Last edit: 8 years 7 months ago by ktruhan.

Please Log in or Create an account to join the conversation.

More
8 years 6 months ago - 8 years 6 months ago #8 by jeffredz
Chrome latest update makes Kunena upload unusable (any file I pick gives me C:\Fakepath\myFileName). Looking forward to see a fix on either Chrome side or Kunena.
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Enabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Enabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 128M | Max file upload: 30M

This message contains confidential information

Joomla default template details : CZUL2011 | author: Jean-Frederik Dion | version: 1.0 | creationdate: 2010-11-18

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.6.3 | creationdate: 2011-01-31

Kunena version detailled: Installed version: 1.6.3 | Build: 4344 | Version name: Parlare | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Installed (Version : 1.3) | Jomsocial: Disabled or not installed | UddeIm: Installed (Version : 2.1)

Third-party SEF components: sh404sef: Disabled or not installed | ARTIO JoomSEF: Disabled or not installed | AceSEF: Disabled or not installed

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Disabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Disabled or not installed | My Kunena Forum Menu: Disabled or not installed | My Kunena Forum Posts: Disabled or not installed

Modules: Kunena Latest: Enabled (Version : 1.6.0-RC2) | Kunena Stats: Disabled or not installed | Kunena Login: Disabled or not installed

Last edit: 8 years 6 months ago by jeffredz.

Please Log in or Create an account to join the conversation.

More
8 years 6 months ago #9 by Troneas
im getting the same problem with chrome.

Please Log in or Create an account to join the conversation.

More
8 years 5 months ago #10 by jstfr.fn
Not sure why the problem is but yes it is with IE8.

Quick workaround:

Create folder fakepath in C: and copy files u want to upload in this folder. Then try

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.187 seconds