×
Kunena 5.2 Beta 1 Released (Yesterday)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved High CPU usage on J2.5 site

More
8 years 3 months ago #1 by dex2
Hi

I have unacceptably high CPU usage on joomla.org.au . Please see forum page joomla.org.au/forum with page loads around 1 second.

e.g.
Jun 11 2012:
joomla.org.au
Top Process %CPU 164 ../index.php
Top Process %CPU 133 ../index.php
Top Process %CPU 127 ../index.php

Last week I upgraded the site to J2.5.4, installed an ultralite template and switched off almost all the other extensions. It's still using Kunena, obviously, but when i turned Kunena off, CPU uasge plummeted.

I have around 6,500 posts in there, from memory.

Do you know what I should be doing to diagnose and fix this issue? Will pruning help much?

Thanks v much
Dex


Here's my config:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 20M

Kunena menu details:
Warning: Spoiler!

Joomla default template details : fastnetbootstrap | author: Fastnet | version: 1.1.0 | creationdate: 2012-05-16

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.2 | creationdate: 2012-01-31

Kunena version detailled: Installed version: 1.7.2 | Build: 5215 | Version name: Omega | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled | Kunena Search 1.7.2

Modules: Kunena Latest 1.7.2 | Kunena Stats 1.7.2 | Kunena Login 1.7.2

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #2 by sozzled
Replied by sozzled on topic High CPU usage on J2.5 site
Thanks, Dex, and welcome to Kunena.

There are a couple of issues here (one of which involving the menu) - you might find the topic How do I restore my Kunena menu? useful in that regard.

I would like to point this topic to my colleagues who may also have some ideas as to what is going on.

I think we should talk sometime soon, too. Please PM me if real-time online chat is an option for you (Skype only, in my case) and we'll tee-up a time to discuss, evaluate and try out a few idea.

From what I see in your config. report, there is no real indication of what it is that is impacting on CPU utilisation to the extent that is manifest at the site. As I said, I hope that my colleagues will be able to bring the benefit of their years of experience to bear in this case. We definitely want this site - your site - to be a winner!
The following user(s) said Thank You: dex2

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #3 by Matias
Replied by Matias on topic High CPU usage on J2.5 site
In Joomla 2.5 you always need to have caching turned on -- otherwise it makes way too many MySQL calls, which slow down especially virtual servers (you have one, because of process CPU usage cannot go over 100% in real CPU).

On Apache processes, they probably looked the same before switching to J! 2.5, as there's almost no difference between J!1.5 and J!2.5 performance according to many benchmarks I've done (except that one thing without caching).
The following user(s) said Thank You: dex2

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #4 by coder4life
Do you have a lot of plugins in your installations. Plugins get loaded every time a page gets loaded in Joomla. Your template may not be optimized, find a way to minify and combine your files (css and js). Kunena 1.7 has some performance inhibitors as well, should not be a significant factor considering your post count. K2.0 will see improvements. These three factors can create a significant spike on the CPU when it prepares a page.
The following user(s) said Thank You: dex2

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #5 by dex2
Replied by dex2 on topic High CPU usage on J2.5 site
Thanks Matias.
Yes I have both standard Joomla caches turned on (config/plugin)

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #6 by dex2
Replied by dex2 on topic High CPU usage on J2.5 site
Thanks coder4life.

Yes I have put in a miniscule template to eradicate template bloat.
The old template had minification, but this one does not - jquery and mootools-more are both loading (slowly). I'll pack them down.

When I turn off Kunena I get CPU usage as follows:

Jun 17 2012 (partial stats, 06 hours into the day):
joomla.org.au 0.42 1.03 0.0
Top Process %CPU 27.0 [php]
Top Process %CPU 0.3 httpd [joomla.org.au] [/administrator/templates/bluestork/images/menu/icon-16-mess]
Top Process %CPU 0.1 httpd [joomla.org.au] [/templates/system/css/error.css]

So as you can see, much much better. Its hard for me to think that anything other than Kunena is causing the issue.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #7 by dex2
Replied by dex2 on topic High CPU usage on J2.5 site
I also BTW optimised the MySQL DB, just in case it was lagging.

Hands up who thinks I should just cull my old forum posts?
They go back to 2007. I can eradicate half of them, bringing it down to 3k, without too much loss.

Frankly it's the only thing i can think of that might help

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #8 by sozzled
Replied by sozzled on topic High CPU usage on J2.5 site
It's not Kunena (at least I'm 95% certain of it). If you would like to send me a PM, I would be happy to sit down and talk with you about the issue.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #9 by dex2
Replied by dex2 on topic High CPU usage on J2.5 site
Altho I did also temporarily block Google and all its bot chums. They seem to visit with a truckoad of needs about every 5 mins.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago - 8 years 2 months ago #10 by sozzled
Replied by sozzled on topic High CPU usage on J2.5 site
Something on your site is hoarding the CPU and, as a by-product, is affecting Kunena. I am available to sit down with you, put our heads together, and talk the issues through. If you would like to contact me via Skype or even by telephone, please let me know by PM. I can call you, if you like. I would be happy to.
Last edit: 8 years 2 months ago by sozzled. Reason: Change topic icon to "solved"

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.130 seconds