×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Bug [Problem assumed resolved - no response from user] Incorrect time display - one hour behind.

More
8 years 1 month ago #1 by joopyjoops
The time displayed on my kunena forum is one hour behind what it should be... so if people post at 7am, it displays 6am.

I don't know why this is happening, as in my 'Global Configuration' for joomla, i have it correctly set as:
(UTC +10:00) Eastern Australia.

I am in Sydney.

Is there anywhere else in Kunena that i can correct it?

Please Log in or Create an account to join the conversation.

More
8 years 1 month ago #2 by sozzled
Yeah, I know, I have a similar case. It's a bit of a problem with J! 1.5.x, isn't it? I still haven't figured out a way of fixing it myself (e.g. I tried playing with the Global Settings but that didn't help).

Please Log in or Create an account to join the conversation.

More
8 years 4 weeks ago #3 by sozzled
I found the cause (and a workaround) for the problem. The problem is caused by J! 1.5 which does not know anything about DST; I understand that this has been addressed in J! 1.7.

When a message is posted on the Kunena forum, the timestamp (i.e. the time when the message was created) is stored in UTC time. This isn't a problem if you set the Forum Configuration » Front End » Look and Feel » Message Time Format = 22 hours 13 minutes ago

I call this the "relative time format".

However, if you use an "absolute time format" (e.g. "Today 10:00" or "10 Nov 2011 10:00") then you have a problem.

The fix is not change the Joomla Global Settings (as I thought it might be), but you can workaround the problem by changing your Kunena user profile (under the User Account » Global Settings part) and change the Time Zone there (add an extra hour). When DST ends, you have to change the setting back again. It's a bit clumsy but it works. Like I wrote, this is mainly a weakness of J! 1.5 and, in part, exacerbated by Kunena relying on Joomla to take care of these things.

There's another issue, too. If you don't adjust the Kunena user profile settings like I've described and if you use the Kunena Latest module (which displays dates/times in their "absolute format") the times displayed by that module are also off by one hour. The remedy is to either change your Kunena user profile or to remove the time display in the Kunena Latest module.

This may not be very convenient but, at least, I hope it explains what's going on behind the scenes. The important thing is that the actual [UTC] timestamp is correct and is not compromised at the point when the message is posted.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #4 by sozzled

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.124 seconds