×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Bug [Problem assumed resolved - no response from user] 200 OK error when deleting posts

More
8 years 9 months ago #1 by MisterAegir
Hey all,

I was wondering if you could help me in regards to a niggling problem I have with the apache mod_rewrite when it comes to Kunena.

Specifically, everything loads fine, I can post threads, move them, sticky etc all the normal features yet when I come to delete something on Kunena I get the following error:

OK
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
HTTP/1.1 200 OK Date: Thu, 06 Oct 2011 22:24:47 GMT Server: Apache/2.2.17 (Unix) FrontPage/5.0.2.2635 X-Powered-By: PHP/5.2.17 P3P: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM" Expires: Mon, 1 Jan 2001 00:00:00 GMT Cache-Control: post-check=0, pre-check=0 Pragma: no-cache Last-Modified: Thu, 06 Oct 2011 22:24:48 GMT Keep-Alive: timeout=5, max=199 Connection: Keep-Alive Transfer-Encoding: chunked Content-Type: text/html; charset=utf-8 11ed8




As it stands, my .htaccess file is as follows
Options +FollowSymLinks
 
#
#mod_rewrite in use
 
RewriteEngine On
 
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
RewriteRule . /index.php [F]
 
RewriteBase /
 
RewriteRule ^/index\.php$ - [L]
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteCond %{REQUEST_URI} !^/index\.php
RewriteCond %{REQUEST_URI} (/[^.]*|\.(php|html?|feed|pdf|raw))$ [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]


Is there something additional or something I need to remove/change to what I have to make this work correctly?

Please Log in or Create an account to join the conversation.

More
8 years 9 months ago #2 by MisterAegir
Upon investigation, it appears to be something specific to how Network Solutions (web host) handles the apache mod_rewrite. Has anyone had any experience with this? If so, what's the way to resolve this either in the .htaccess file or with editing another file?

Please Log in or Create an account to join the conversation.

More
8 years 9 months ago #3 by Matias
Apache error logs could tell you more.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago - 8 years 3 months ago #4 by sozzled
Last edit: 8 years 3 months ago by sozzled.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.095 seconds