×
Kunena 5.2.6 released and Blue eagle 1.6.6 released (25 Jul 2021)

The Kunena team has announce the arrival of Kunena 5.2.6 [K 5.2.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.6

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Question menu bar not showing

More
10 years 1 month ago #1 by inbal
menu bar not showing was created by inbal
HI,
I just upgraded to Joomla 1.7 and to Kunena 1.7 and have a problem:
I have a menu of Kunena in the back-end that does not show on the front end, either when you are login or not.
I have cleared the cache of the site and the browser and still...

it was working at the begining after the upgrade but now it is not and im not sure what have changed...
will appreciate your help,

thanks :)

inbelet.co.il/%D7%A4%D7%95%D7%A8%D7%95%D...%90%D7%A9%D7%99.html

Inbal

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago - 10 years 1 month ago #2 by xillibit
Replied by xillibit on topic Re: menu bar not showing
Hello,

Do you have checked that the menu items has a matchless alias ?
Do you have tried to recreate the kunena menu with the function in Kunena configuration panel ?

I don't provide support by PM, because this can be useful for someone else.
Last edit: 10 years 1 month ago by xillibit.

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #3 by Matias
Replied by Matias on topic Re: menu bar not showing
Enable debug mode and check the message that Kunena gives you on the menu.

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago - 10 years 1 month ago #4 by inbal
Replied by inbal on topic Re: menu bar not showing
sorry- apperantly I wasn't subscribed and didn't see you answered, sorry

1. what do you mean by matchless alias ?
2. I have 2 menus: a menu for "Forum" in the "main menu" and a menu for Kunena in the back end .
this is where the problem lies: I am trying to have both menus appear differently.

this is the url (now working) for the forum in my site:
inbelet.co.il/%D7%A4%D7%95%D7%A8%D7%95%D7%9E%D7%99%D7%9D

even though it's in Hebrew you can see 3 grey tabs. those 3 tabs are the same content as the drop down menu for the forum but in fact, in the back end I have 8 tabs! and the only way I can show the other 5 is if I will make them drop down also.

hope I being clear enough...
thanks for answering me :)
Inbal
Last edit: 10 years 1 month ago by inbal.

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #5 by xillibit
Replied by xillibit on topic Re: menu bar not showing
By matchless, i mean that each alias of menu items need to unique

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago - 10 years 1 month ago #6 by inbal
Replied by inbal on topic Re: menu bar not showing
I changed the 3 that are the same in the menu and the tabs but it didn't change anything, because those I can see..
the problem is the 5 that I don't see..

I found another interesting thing: the menu with the tabs is a module, right? and it is called "menu" and I defined that it will show the Kunena menu in it.
the position of the module is "kunena_menu".

when I change positions, I CAN see the 8 tabs I want shown! the only problem is they are vertical and not really "tabs" like in this forum.

I don't know what to do next.. is there another kunena position I can try play with?
Last edit: 10 years 1 month ago by inbal.

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #7 by inbal
Replied by inbal on topic Re: menu bar not showing
It is fixed: the problem I made a wrong kind of menu: instead of "menu aliases" I made a kunena menu ...once it was fixed everything worked

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #8 by GrantH
Replied by GrantH on topic Re: menu bar not showing
Hi,
I have also struggled with this, both on my test XAMP localhost, and on my ISP's IIS/ MySql setup. Both 1.7.0 on 1.5.23 (since the rest of the joomla stuff is still catching up to 1.7!!) Using Rhuk_milkyway, slightly moded (images only!) Clean install (not an upgrade. COnfig details attached)

Install goes perfectly, every time, menu appears on the backend, but nothing rendered on the frontend. Tried enabling, moving around, etc, etc. Most frustrating. Eventual, this is what I did, to make it work:
1. Delete the Kunena menu module
2. Recreate it in the Kunena config
3. Go to the module, and change the postion to "left" - my template doesn't seem to know about the Kunena-menu position
4. Change the layout to Legacy-vertical
Then it works.

As a joomla/ kunena noob, it was a bit disconcerting! The tool itself looks great! Thanks for all the effort!

Hope this helps others and with resolving the reason why it doesn't work "out the box"

Grant H





This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Enabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 360 seconds | Max execution memory: 64M | Max file upload: 32M

This message contains confidential information

Joomla default template details : rhuk_milkyway-isiJingi | author: Andy Miller | version: 1.0.2 | creationdate: 11/20/06

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.0 | creationdate: 2011-08-29

Kunena version detailled: Installed version: 1.7.0 | Build: 5135 | Version name: Tale | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: None

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #9 by Matias
Replied by Matias on topic Re: menu bar not showing
@GrantH: You have "Discussion Fora" in your top menu. You need change it to be type "Menu item alias" and point it into Kunena Menu. In Kunena menu you need to rename forum and other items to what you want them to be.

Or you can just copy contents of Kunena menu into your top menu. I would use the first option, though..

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #10 by inbal
Replied by inbal on topic Re: menu bar not showing
Thanks. the Israeli forum manager: Amir Malikum, helped me and made everything ok.
appreciate your help :)

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.212 seconds