×
Kunena 5.2 RC3 Released (29 Nov 2020)

The Kunena team is thrilled to announce the third public release candidate of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 RC3 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Question Unable to edit user profile, insert emoticons and access the video toolbar

More
9 years 3 months ago #1 by kenyonjohnston
I know this issue has been discussed before but I'm seeking additional assistance. I am using Kunena 1.6.4 and I am not able to insert emoticons, access the video toolbar or edit profile information. In the past this issue was caused by the "moo tools plugin" being enabled. When this occurred in the past I would simple disable the mootools plug-in and everything would function properly; but recently this is not the case. Enabling mootoos plug-in caused issues with my mega menu and a few submenus, so enabling the plugin seems to be a bad option.

Is this problem common? If so is there any recommendations to fix it?

Thanks

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #2 by Matias
Your mega menu is using 3 years old version of Mootools and it really should be updated (doesn't work well with the latest browsers).. Another possibility is not to use it in the same page as Kunena as one of them will break when Kunena is displayed.

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #3 by kenyonjohnston
Gotcha! But currently the moo-tools plugin is "disabled" which "used" to enable all of the functions I previously mentioned to perform properly, so how does this effect my kunena forum?

I understand your theory concerning separating my forums pages from the rest of my site, but I was not the original designer and the design is for the mega menu to be placed on every page in the site.

What else could cause these functions to not work? What javascript/moo-tools functions does editing profiles, and inserting and options from the video tool bar (above B to "?") rely on? Why is those particular functions effected and not the rest of kunena?

Thanks

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #4 by Matias
Yes.. I was waiting for this question but I was a bit busy on K1.7.0 release when I replied to you.

The reason why this happens is that Kunena 1.6/1.7 really needs Mootools upgrade plugin and it is manually enabled by Kunena. This feature was actually added because of users requested it as we were among the first ones who built JavaScript on top of the new Mootools library. There was one year transition time, but nobody used that time to upgrade their JavaScript to be J1.6 compliant.

I find it odd if Mega Menu hasn't been updated to Joomla 1.6+. If it hasn't, you really need to find better options as you will need to replace it anyway just after 6 months.

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #5 by kenyonjohnston
Well upgrading to Joomla 1.6 or the latest version of the mega menu is currently not an option, so what about upgrading to mootools 1.3.2? Is it compatible joomla 1.5.22?

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #6 by Matias
I have no idea if Joomla 1.5.23 (you should use this) is fully compatible with Mootools 1.3.. There are some minor incompatibilities in Mootools 1.3, but I really don't know if Joomla uses those features. You can always test it..

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago - 9 years 3 months ago #7 by kenyonjohnston
Thanks, I attempted to upgrade the mootools 1.3.2 plugin but failed because the zip file doesn't have an xml file for the installation of joomla. Before that I upgraded all Kunena products to 1.7 HOPING this would solve the problems, but no dice!
Last edit: 9 years 3 months ago by kenyonjohnston.

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #8 by Matias
You just cannot update Mootools like that. Maybe you should pay a visit in JA support site:

www.joomlart.com/forums/showthread.php?4...iewfull=1#post257299
www.joomlart.com/forums/search.php?searchid=2071413 (if the link still works)

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #9 by kenyonjohnston
Thanks but before I attempt to adjust the code, I need to assess if that's even the issue. Everything works fine except for video toolbar and profile editing. It may not be an issue of upgrading mootools. I'm hoping someone else in the forum is going through the EXACT same problems.

Recently upgraded to kunena forum 1.7

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #10 by Matias
It's probably the issue as many others have had the same symptoms with JA.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.098 seconds