×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved K 1.7: user-written forum "rules" and "help" menu items

More
7 years 2 months ago #1 by Andria
You know, this is really no help at all -- all it says on that page is "To be written" for both the rules and the help page -- so there is no instruction given anywhere, for how to do it? I have tabs on the Kunena menu, but when you click them, they're both blank. So how do you get stuff on them?

Andria

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago - 7 years 2 months ago #2 by Voice4Vision
Hi Andria,
Here we go.

1) Write your Help Page and Rules Page via your Joomla Article Manager. Remember the Article ID for each.

2) Enter Admin/Menu's/Kunena Menu's

3) Click "New" Button, to create new menu item.

4) Select "Menu Item Type" & Kunena Forum's "Custom Content"

5) Fill in necessary details

6) In Content Text Area field on the right hand side enter
[article=full]ARTICLE ID[/article]

7) Publish and Save

I believe Kunena comes with one of the menu's already setup...except it is not pointing to an article, but instead has simple non-formatted text.

Hope this helps, good luck!
Voice4Vision
Last edit: 7 years 2 months ago by Voice4Vision.

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago - 7 years 2 months ago #3 by Andria
Hmm. When I try to do as you described, I find that there is no Kunena "Custom Content" -- what I see for choices are the following: Entry Page, Help Page, Recent Topics, Category Index, New Topic, Profile, Rules Page, Search, Category. If I select either "Help Page" or "rules Page", it then shows, over on the right, the top of the accordion is entitled "Required Settings" -- but there is nothing in the box associated with it -- no entry blanks at all, nothing; it does this no matter what admin template I use -- VTEM, AdminPraise, or BlueStork. There is no place at all to enter the
"[article=full]ARTICLE ID[/article]"
.

So, now what?
Andria
Last edit: 7 years 2 months ago by Andria. Reason: to show the code

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago #4 by Andria
Ok, I see the problem -- I thought I was using a version of Kunena post-2.0 -- but it turns out that it's version 1.7.something, so I found the instructions for the pre-2.0 versions -- sorry for the confusion! :silly:

Thanks!
Andria
(BTW -- you share a b-day with my son, though his is 1988 -- so I can deduce that you are clever, funny, and kind -- your reply certainly demonstrates the latter!)
The following user(s) said Thank You: Voice4Vision

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.085 seconds