×
Blue Eagle 5 v1.6.2 has been Released for Kunena 5.2 (20 Jan 2021)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.6.2 which is now available for download. This version addresses most of the issues that were discovered in development.

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Bug Users cannot see all forum categories while they are granted to

More
8 years 10 months ago #1 by sebnunes
Hi all,

I'm having troubles for a few weeks now and I cannot find any fix for this.

I'm running Joomla 1.5.25 & Kunena 1.7.2.

We have defined permisions for registered users to see only the Presentation category and as soon as their account is validated by the Administrator we change the account to Author and they should have access to many other categories.

It works like this for more than two years now, but since a couple of weeks all new users are having the same problem, despite the user account is added to the Author group, they can't see any other categories than the presentation one.

If I delete the account and recreate it myself, and add the account to the Author role, it works.

This is a nightmare as I'm having more and more users siging up for an account on the web site.

Any idea to fix this ?

Below the configuration report.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Enabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Enabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 90 seconds | Max execution memory: 384M | Max file upload: 100M

Kunena menu details:
Warning: Spoiler!

Joomla default template details : dsb2011 | author: Sébastien Nunes | version: 1.0.0 | creationdate: 31/12/2010

Kunena default template details : Aphotic II | author: snilloconator | version: 1.6.2 | creationdate: 2010-12-30

Kunena version detailled: Installed version: 1.7.2 | Build: 5215 | Version name: Omega | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: UddeIm 2.1

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Enabled | System - Mootools12: Disabled

Modules: None

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago - 8 years 10 months ago #2 by sozzled
Please read Legacy mode in the Wiki. We do not provide support for J! 1.5 sites that have the System - Legacy plugin enabled.

You are using a third-party template that was designed for an older version of Kunena that is no longer supported. Please contact the author of that template for information about an update or, if you do not want to do that, please use the standard Blue Eagle template.

You have a highly customised menu structure. Please ensure that your menu conforms to the recommendations made in Customised menus .

sebnunes wrote: ... despite the user account is added to the Author group, they can't see any other categories ...

How is the user account "added" to the Author group? Is this done at registration time or is this done later, by you? I think this is really the key to resolving the problem. I also think we can solve this problem in less than one minute, too! Can you please tell us how users are "added" to the Author group on your site?
Last edit: 8 years 10 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #3 by sebnunes
Hi,

Thanks for your reply.

We actually have a custom module where the admin can select users and click a "validate" button which adds the user to the Author group.

When I check in Joomla Admin module I can see that the users are effectively in the Author group.

Is there something wrong about doing it this way ?

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #4 by sozzled
No problem really, in doing things this way, but you need to keep in mind that Kunena category access is only checked once, per session. Therefore, if a user is till logged-in when their access is changed, they won't see any different categories until they're logged out again or unless you purge the session cache. You purge the session cache by invoking the Synchronize Users function in the backend.
If your custom module could automatically invoke this Synchronize Users function then you would not have any problems. Alternatively, invite your users to logout then login again and they should see the categories they're entitled to. Or, manually, run Synchronize Users yourself.

Problems like these are fairly uncommon in J! 2.5.

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #5 by sebnunes
Yeah but I already asks the users to logoff/logon again but they still can't see all categories.

I don't understand why. The only workaround I've found, is to manually delete the account and recreate it and add it to the Author group.

And it works like this for more than two years and suddenly it stopped working.

I know I should move to J2.5 and we are working on this, but in the meantime I still have new users coming and complaining about this... :(

Thanks for your help.

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago - 8 years 10 months ago #6 by Matias
Are the topics visible after they have slept overnight? How long is your Kunena session time? It should be less than 8 hours.

PS. this issue has been fixed in K2.0.
Last edit: 8 years 10 months ago by Matias.

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #7 by sebnunes
The Session is 30min.

No the topics are not visible overnight. Even days after, it's still not visible for them...

:(

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #8 by sozzled
See Problem with Kunena Session for information about session settings.

Can we see your K 1.7 configuration report again, please? I would like to check a couple of things. Thanks.

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #9 by sebnunes
OK, thanks I'll check the session information.

here is the configuration:
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Enabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Enabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 90 seconds | Max execution memory: 384M | Max file upload: 100M

Kunena menu details:
Warning: Spoiler!

Joomla default template details : dsb2011 | author: Sébastien Nunes | version: 1.0.0 | creationdate: 31/12/2010

Kunena default template details : Aphotic II | author: snilloconator | version: 1.6.2 | creationdate: 2010-12-30

Kunena version detailled: Installed version: 1.7.2 | Build: 5215 | Version name: Omega | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: UddeIm 2.1

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Enabled | System - Mootools12: Disabled

Modules: None

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #10 by sozzled
We advised you before to disable legacy mode and not to use a third party-developed template that is unproven and untested with K 1.7.2.

We also advised you to delete your existing Joomla menu items that refer to Kunena and to restore the Kunena menu.

We gave you this advice in our first reply to you.

You have chosen to ignore that advice. I'm sorry, there is nothing more that we can do to help you.
The following user(s) said Thank You: sebnunes

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.310 seconds