×
Kunena 5.1.12.1 Released - Security release (22 Apr 2019)

The Kunena team has announce the arrival of Kunena 5.1.12.1 [K 5.1.12.1] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a security release.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Merged K 1.7 How to setup CAPTCHA for registered users

More
7 years 6 months ago - 7 years 6 months ago #1 by WeedRoy
Hi, can any one tell me How to setup CAPTCHA for registered users ?
Tnx
Last edit: 7 years 6 months ago by sozzled. Reason: Changed subject to improve relevance for search purposes

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #2 by Matias
If you already know how to setup it for guests, you just need to enter a number into "CAPTCHA Challenge for Users". If the number is 3, all users who have less than 3 approved posts will get captcha challenge.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #3 by WeedRoy
uhh..i dont understand :/
sry....
can u tell give me any tut or....idk....when any one register on my forum, and when hi write fist post i like be capcha available

p.s. sry for my bad english

tnx

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago - 7 years 6 months ago #4 by sozzled
Thank you for your very good question, WeedRoy. Let me explain, clearly, what you need to do.

The instructions to use CAPTCHA for K 1.7.1 are in Using CAPTCHA spam protection in Kunena . In order to enable CAPTCHA so that, for the first message posted by a registered user, registered users must answer a CAPTCHA challenge. This is what you need to do:

Forum Configuration » Security » Security Settings » Allow Guests to Post/Write = Yes / No (does not matter)
Forum Configuration » Security » Security Settings » Registered Users Only = Yes / No (does not matter)
Forum Configuration » Security » CAPTCHA Configuration » CAPTCHA Challenge for Guests = Yes / No (does not matter)
Forum Configuration » Security » CAPTCHA Configuration » CAPTCHA Challenge for Users = 1
Forum Configuration » Security » CAPTCHA Configuration » reCAPTCHA Public Key = (obtained from www.google.com/recaptcha/admin/create )
Forum Configuration » Security » CAPTCHA Configuration » reCAPTCHA Private Key = (obtained from www.google.com/recaptcha/admin/create )

I hope that this explains how to enable CAPTCHA so that, for the first message posted by a registered user, registered users will have to pass the CAPTCHA challenge in order to post a message on your forum. If you want to increase this to, say, the first three messages posted by a registered user (the example given by Matias) then this is what you have to set:

Forum Configuration » Security » CAPTCHA Configuration » CAPTCHA Challenge for Users = 3

If you allow enforce CAPTCHA for guests then that's a different question and a different topic.

There's you tutorial! ;)
Last edit: 7 years 6 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #5 by WeedRoy
Because i was test this with other acc, it's work....

but i have last question....
because i am super administrator (administrator) on my forum, i cant see captcha?
tnx

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago - 7 years 6 months ago #6 by sozzled
If you read Using CAPTCHA spam protection in Kunena you will see that the CAPTCHA challenge does not apply to administrators or moderators of your forum. This is because [it is reasonable to assume that] administrators and moderators appointed by you can be trusted to post whatever they want to without having to go through these "security" processes. Does this help you to understand?
Last edit: 7 years 6 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #7 by WeedRoy
sure :D
now u can lock this...
tnx

Please Log in or Create an account to join the conversation.

More
7 years 5 months ago #8 by fauzi26
helllo,,iam new work with this extensions. I need some help, in my forum if i make a new topic or post there are not captcha there. Actually i was configure captcha setting in forum configuration,,
iam sorry for my bad english,,

Please Log in or Create an account to join the conversation.

More
7 years 5 months ago - 7 years 5 months ago #9 by sozzled
G'day, fauzi26, and welcome to Kunena.

See msg #4 in this topic. Site administrators/forum moderators do not see CAPTCHA.
Last edit: 7 years 5 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
7 years 5 months ago #10 by jhuynh
Please help. I am using Joomla 1.5.23, Kunena 1.7.1, Artisteer template, Windows 7 Home edition. I have set up CAPTCHA chnaleenge for Guests to Yes and challenge for users to zero, and I have public key and private key, but I do not see the CAPTCHA box when I create an account.


This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 45 seconds | Max execution memory: 96M | Max file upload: 24M

This message contains confidential information

Joomla default template details : phanrang1 | author: Jim Huynh | version: 2.3.0 | creationdate: 2011-09-20

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.1 | creationdate: 2011-11-16

Kunena version detailled: Installed version: 1.7.1 | Build: 5162 | Version name: UnderUret | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: None

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.180 seconds