×
Kunena 5.2.6 released and Blue eagle 1.6.6 released (25 Jul 2021)

The Kunena team has announce the arrival of Kunena 5.2.6 [K 5.2.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.6

Question High CPU and memory used caused by Kunena Forum

More
9 years 11 months ago - 9 years 11 months ago #1 by brenden
Hi all,

Long time user of Kunena and love it but a relative noob in terms of extreme techy detail. Recently over the last week we've had performance issues where our server CPU and memory use has spiked dramatically.

According to our host their server is OK and they pointed to Kunena forum causing the issue. They suggested something might be keeping data in cache.

Attached are screen shots of cpanel showing CPU and memory use.






Anyone seen / experienced this? Is there a way to disable cache for forum?

Any insight is greatly appreciated!
Attachments:
Last edit: 9 years 11 months ago by brenden.

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #2 by xillibit
Hello,

Can-you put here your Kunena report configuration settings ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago - 9 years 11 months ago #3 by PJFonseca
We at androidPT.com have the same problem.

The configs:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 60 seconds | Max execution memory: 128M | Max file upload: 100M

This message contains confidential information

Joomla default template details : ja_purity | author: JoomlArt.com | version: 1.2.0pt | creationdate: 12/26/07

Kunena default template details : Example Template | author: Kunena Team | version: 1.6.4 | creationdate: 2011-05-07

Kunena version detailled: Installed version: 1.7.0 | Build: 5135 | Version name: Tale | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: UddeIm 2.0

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Enabled | System - Mootools12: Disabled

Modules: Kunena Latest 1.0.47

Last edit: 9 years 11 months ago by PJFonseca.

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago - 9 years 11 months ago #4 by brenden
Hi,

Report below - Apologies for not including originally:


This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 4M

This message contains confidential information

Joomla default template details : stormlab | author: LineLab.org | version: 1.0.0 | creationdate: 29.4.2011

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.0 | creationdate: 2011-08-29

Kunena version detailled: Installed version: 1.7.0 | Build: 5135 | Version name: Tale | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: None

Last edit: 9 years 11 months ago by brenden.

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #5 by PJFonseca
Any thoughts on this?

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #6 by Matias
Memory usage probably comes mostly from apache processes -- the more users you have, the more memory it takes. Disabling (or having at most 3 seconds) keepalive setting in Apache usually helps to keep memory usage lower.

CPU usage may be caused by anything and you really need to know which processes are taking the time.

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #7 by brenden
Some more info: Our host claims it could be cache building up.

We did a complete upgrade to Joomla 1.7 and latest Kunena. First few days it was fine, then after 2 days back to high memory and CPU use again.

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #8 by Matias
Kunena 1.7 doesn't cache anything, so it's not Kunena cache.

We are now preparing Kunena 2.0 beta release. Kunena 2.0 has been optimized so, that it works with less resources, especially in huge forums.

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #9 by PJFonseca
Nice... lets wait for it.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.328 seconds