×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Question users can Only login in via IE browser after conversion?

More
8 years 11 months ago #1 by baijianpeng
Today I converted my former SMF2 forum to Kunena 1.6 (latest SVN) with com_kunenaimporter.

After this conversion, everything seems OK except that users can NOT login in on browsers other than IE.

For example, when trying to login in on Chrome 8.0 browser, after input username and password and click "login" button, the page refreshed but user still NOT logged in.

I used mod_kunenalogin as the login module (from the latest SVN).

My Joomla version is v1.5.22, and the plugin "System - Mootools Upgrade" was not enabled.

The site template is rt_versatility4_j15 by RocketTheme.

And the live URL is: https://www.joomlagate.com/forum/

I also tried to repair the jos_kunena_sessions table, but the problem still not solved.

Now, no one user can login in my website (forum) except they use IE browser. Though com_kunenaimporter had reported that my conversion was successful.

What is the cause of this strange issue?

What should I do to solve this problem?

Thanks.

www.joomlagate.com/

Chinese Joomla Users' Portal

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago #2 by @quila
Hello,

can you users login with Joomla Login Module and can you users login with login form at top of Kunena?

Post here also Konfiguration Report from backend of Kunena.

Thank You
Regards

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago - 8 years 11 months ago #3 by baijianpeng
I had tried the Joomla mod_login but also has problem.

Update: The problem is clear now, if the user check "remember me", he can login in; if not checked, can not login in.

My configuration is:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Enabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 16M

This message contains confidential information

Joomla default template details : rt_versatility4_j15 | author: RocketTheme | version: 1.5.2 | creationdate: 10/30/08

Kunena version detailled: Installed version: 1.6.2-DEV | Build: 3864 | Version name: Timu | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Disabled or not installed | Jomsocial: Disabled or not installed | UddeIm: Disabled or not installed

Third-party SEF components: sh404sef: Disabled or not installed | ARTIO JoomSEF: Installed (Version : 3.7.5) | AceSEF: Disabled or not installed

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Enabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Enabled (Version : 1.6.0-RC2) | My Kunena Forum Menu: Disabled or not installed | My Kunena Forum Posts: Disabled or not installed

Modules: Kunena Latest: Enabled (Version : 1.6.0-RC3) | Kunena Stats: Disabled or not installed | Kunena Login: Enabled (Version : 1.6.0-RC2)

Maybe this is a session bug of Kunena SVN3967?

Thanks.

www.joomlagate.com/

Chinese Joomla Users' Portal
Last edit: 8 years 11 months ago by 810. Reason: delete code

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago #4 by @quila
Hi,

try to change back "Session Lifetime" to 1800 in Kunena Configuration then try again if problem persist.

Regards

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago #5 by baijianpeng
I changed that value to 1800 (the default value), but users still need to check "Remember me" otherwise they can't login in at frontend.

Since I am using Kunena v1.6.2 SVN version, I can understand this is a bug.

Thanks.

www.joomlagate.com/

Chinese Joomla Users' Portal

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago #6 by sozzled
baijianpeng: I notice that you are running Joomla 1.5.22 in legacy mode. Please read the very important information about Legacy mode and take action to remove your dependence on this feature. Kunena 1.6 has not been tested for J! 1.5 legacy mode. Running with legacy mode will mean that you will have problems later.

What is the Joomla session lifetime on your website?

This login issue should not have emerged as a defect simply because you are using a version obtained from the SVN. We should not be getting these kinds of regression issues introduced in this area. As you also know, there is no support for development versions of Kunena. If you use a development version of Kunena then you do so at your own risk. I am moving this topic to the Test Reports category.

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago #7 by baijianpeng
Ok, I turned off the legacy mode after read your last post.

Then I cleared cache and went to frontend, tried to login in (use the Kunena forum login form) without checking the "Remember me" option, but I still can't login in. Then I checked that option, this time I logged in.

The session time in Joomla configuration is 10 times longer than the Kunena session setting. I need a longer session in Joomla settings because I oftenn need do some operation in Joomla Admin side, I don't like to login in backend again and again.

Now I think this is not a Legacy mode problem. Someone suspect that maybe this SVN version has cookie problem. I don't know these things, hope you will find out the cause.

Thanks.

www.joomlagate.com/

Chinese Joomla Users' Portal

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago #8 by sozzled
Kunena session lifetime should be set the same as Joomla session lifetime.

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago #9 by baijianpeng
If these two session time MUST be the same, why bother to design such an extra parameter in Kunena? I think Kunena can just read the session setting from Joomla configuration. When the user has ONLY one field to input his session time, he has no chance to make a mistake buy setting two different session time.

Thanks.

www.joomlagate.com/

Chinese Joomla Users' Portal

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.123 seconds