×
Kunena 5.1.12.1 Released - Security release (22 Apr 2019)

The Kunena team has announce the arrival of Kunena 5.1.12.1 [K 5.1.12.1] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a security release.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question Unable to make the forum appear in a separate joomla template - it always uses the default template!

More
7 years 10 months ago - 7 years 10 months ago #1 by chgeiselmann
Dear all,

I have installed Kunena 1.6 in a Joomla 1.5.23 environment.
The forum opens in the main "content" area of the website (where usually articles are displayed).

I want the forum to appear in a separate window, and using a basically empty template (without all the stuff that comes with my main website template (default template)). To this end I have
a) set the menu link to "open in a separate window with browser navigation" and
b) have assigned an alternative joomla template (stripped of all the unnecessary stuff) to this menu item.

On testing with ofther contents (for example an article) the alternative template is used.
However, as soon as the menu calls the Kunena forum, it appears using the complete main website template (default template).

I have tried if assigning alternative templates to the menu item calling Kunena works better in a different environment: I installed it on a different website (with an even technically quite different default template by the way), but the result is the same: Kunena forum always appears using the default template, without respect to the differing menu assignment in the joomla template manager.

Who can help solve this problem?

Thank you, kind regards,

Christian Geiselmann

Here is the Kunena config report, from the first of the two sites

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 16M

This message contains confidential information

Joomla default template details : zeleniteizbori | author: Christian Geiselmann | version: 1.0 | creationdate: 14.2.2011

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.6.4 | creationdate: 2011-05-07

Kunena version detailled: Installed version: 1.6.4 | Build: 4832 | Version name: Kerkrade | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: None

Last edit: 7 years 10 months ago by chgeiselmann. Reason: Kunena config report added

Please Log in or Create an account to join the conversation.

More
7 years 10 months ago - 7 years 10 months ago #2 by chgeiselmann
This issue is solved now.

The solution is very simple:

When assigning an alternative joomla template to Kunena forum, you must not forget the genuine Kunena menu (automatically created on Kunena installation).

Step by step:
- Create your second (alternative) joomla template
- In "Extensions --> Template manager" click on the alternative template
- Assign the template to the menu item which will call the Kunena forum (e.g. a menu item in your main menu called "forum"
- Assign the template to the complete Kunena menu (including all its items!).

My mistake was that I forgot the last step. As a result, the Kunena menu continued calling the default template, even when the "forum" menu item in the main menu a second prior to this had called the alternative template.

Thanks to Mr. Sozzled (who moderates the forum), since I hit on this simple issue just after reading one of his answers to my posts.
Last edit: 7 years 10 months ago by chgeiselmann. Reason: grammar improved
The following user(s) said Thank You: sozzled

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.110 seconds