×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question Error 500 if Image size greater 2 Mb

More
9 years 2 weeks ago - 9 years 2 weeks ago #1 by Gough
If I try to upload an image that is greater that 2GB I get this error.

500 Internal Server ErrorFatal Error was detected!
Fatal Error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 19008 bytes) in components/com_kunena/lib/kunena.image.class.php on line 357

The error was detected in the Kunena Component.

If you use the back arrow button to go back the image has been uploaded but the link hasn't changed from "c drive path".. You can delete that link and reselect the insert button and all is well.

Thanks for any help.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 64M

This message contains confidential information

Joomla default template details : jsn_epic_pro | author: JoomlaShine.com | version: 4.1.3 | creationdate: 05/03/2011

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.6.4 | creationdate: 2011-05-07

Kunena version detailled: Installed version: 1.6.4 | Build: 4832 | Version name: Kerkrade | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: CommunityBuilder: The file doesn't exist comprofilej.xml !

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: None

Last edit: 9 years 2 weeks ago by sozzled. Reason: Corrected error in subject made by user

Please Log in or Create an account to join the conversation.

More
9 years 2 weeks ago - 9 years 2 weeks ago #2 by Mortti
It has nothing to do with Kunena. You should to raise that upload limit from your server php.ini file or if you don't have permissions to do that, then ask that from your server service provider... I haven't permission to see that are you in public site or local site.
Last edit: 9 years 2 weeks ago by Mortti.

Please Log in or Create an account to join the conversation.

More
9 years 2 weeks ago #3 by Gough
I'm pretty sure that my upload limits are ok, they show to be set at 64M. Also the file ends up uploading (it's there when you go back and look). It just throws that 505 error. It does'nt matter if you link or just attach it.

Please Log in or Create an account to join the conversation.

More
9 years 2 weeks ago - 9 years 2 weeks ago #4 by Mortti
64M vs 2GB ??? I just looked the topic subject : Error 500 if Image size greater 2GB

I think there is some bug too:

Fatal Error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 19008 bytes) in components/com_kunena/lib/kunena.image.class.php on line 357


I have to try reproduce this issue in tomorrow... I just come home from little vacation trip, sorry. Maybe some other mods, global mods will look this before tomorrow.
Last edit: 9 years 2 weeks ago by Mortti.

Please Log in or Create an account to join the conversation.

More
9 years 2 weeks ago #5 by sozzled
I do not understand how this is a Kunena support issue. This is a capacity issue involving your webhosting environment. Regardless of the maximum upload size defined in your Kunena configuration parameters (and, in your case, you have defined a maximum size of 10 Mb) the maximum upload size is limited by the PHP settings (PHP.ini) for your site. There may be other limitations imposed by your hosting provider.

Please Log in or Create an account to join the conversation.

More
9 years 2 weeks ago #6 by Gough
Sorry, I mis-typed it. The Subject should read 2MB not 2GB. I am trying to upload a 4MB file. I'm not sure if this is a Kunena problem or not.. I am just trying to get some help. Also it does complete the upload. If you edit the post it will show as an attachment and you can link to it at that point. I would be glad to set up a test login if that would help to diagnose this problem.

Thanks for everyones help.

Please Log in or Create an account to join the conversation.

More
9 years 2 weeks ago - 9 years 2 weeks ago #7 by sozzled
I suggest that you look at your PHP.ini settings to see what is the absolute filesize upload limit; your use of Kunena is constrained by that limit. You cannot exceed the PHP upload limit of post_max_size and upload_max_filesize (whatever are those values). To change the PHP upload limit, check your php.ini (/usr/local/lib/php.ini) settings but, like I wrote, these may also be controlled by your webhosting provider no matter what arbitrary values you may try to change them to.
Last edit: 9 years 2 weeks ago by sozzled.

Please Log in or Create an account to join the conversation.

More
9 years 2 weeks ago #8 by Gough
This is straight out of the Joola Admin. Are these two lines what you are talking about? Also in the Kunena Report Configuration Settings it also shows to be set at 64M. I am really not trying to be thick here. I guess I don't see how php.ini could be wrong if all of the reports show everything to be set at 64M already. Could my website provider be changing these values even though the reports show otherwise?

Thanks again

PHP Core
Directive Local Value Master Value
allow_call_time_pass_reference On On
allow_url_fopen On On
allow_url_include On On
always_populate_raw_post_data Off Off
arg_separator.input & &
arg_separator.output & &
asp_tags Off Off
auto_append_file no value no value
auto_globals_jit On On
auto_prepend_file no value no value
browscap no value no value
default_charset no value no value
default_mimetype text/html text/html
define_syslog_variables Off Off
disable_classes no value no value
disable_functions no value no value
display_errors On On
display_startup_errors Off Off
doc_root no value no value
docref_ext no value no value
docref_root no value no value
enable_dl On On
error_append_string no value no value
error_log error_log error_log
error_prepend_string no value no value
error_reporting 6135 6135
expose_php On On
extension_dir /usr/lib64/php/modules /usr/lib64/php/modules
file_uploads On On
highlight.bg #FFFFFF #FFFFFF
highlight.comment #FF8000 #FF8000
highlight.default #0000BB #0000BB
highlight.html #000000 #000000
highlight.keyword #007700 #007700
highlight.string #DD0000 #DD0000
html_errors On On
ignore_repeated_errors Off Off
ignore_repeated_source Off Off
ignore_user_abort Off Off
implicit_flush Off Off
include_path .:/usr/lib64/php:/usr/lib/php .:/usr/lib64/php:/usr/lib/php
log_errors On On
log_errors_max_len 1024 1024
magic_quotes_gpc On On
magic_quotes_runtime Off Off
magic_quotes_sybase Off Off
mail.force_extra_parameters no value no value
max_execution_time 30 30
max_file_uploads 20 20
max_input_nesting_level 64 64
max_input_time 60 60
memory_limit 64M 64M
open_basedir no value no value
output_buffering no value no value
output_handler no value no value
post_max_size 64M 64M precision 12 12
realpath_cache_size 16K 16K
realpath_cache_ttl 120 120
register_argc_argv On On
register_globals Off Off
register_long_arrays Off Off
report_memleaks On On
report_zend_debug On On
safe_mode Off Off
safe_mode_exec_dir no value no value
safe_mode_gid Off Off
safe_mode_include_dir no value no value
sendmail_from no value no value
sendmail_path /usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i
serialize_precision 100 100
short_open_tag On On
SMTP localhost localhost
smtp_port 25 25
sql.safe_mode Off Off
suhosin.log.phpscript 0 0
suhosin.log.phpscript.is_safe Off Off
suhosin.log.phpscript.name no value no value
suhosin.log.sapi no value no value
suhosin.log.script no value no value
suhosin.log.script.name no value no value
suhosin.log.syslog no value no value
suhosin.log.syslog.facility no value no value
suhosin.log.syslog.priority no value no value
suhosin.log.use-x-forwarded-for Off Off
track_errors Off Off
unserialize_callback_func no value no value
upload_max_filesize 64M 64M
upload_tmp_dir no value no value
user_dir no value no value
variables_order EGPCS EGPCS
xmlrpc_error_number 0 0
xmlrpc_errors Off Off
y2k_compliance On On
zend.ze1_compatibility_mode Off Off

Please Log in or Create an account to join the conversation.

More
9 years 2 weeks ago #9 by Mortti
You still should change that if you want more???

Kunena is not anything doing with this.

Please Log in or Create an account to join the conversation.

More
9 years 2 weeks ago #10 by Gough
Well I finally found the problem. It had absolutly nothing to do with max upload size. It was in the php.ini file but had nothing todo with max upload or max post size. It was the memory_limit setting. I increased it up from 64M to 128M and Kunena will accept as large an image as I would like to send.

Thanks for the help. Sometimes the wrong answer forces one to find the right answer.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.248 seconds