×
Blue Eagle 1.5.2 Released (Yesterday)

The Kunena team has announce the arrival of Kunena Blue Eagle 1.5.2 which is now available for download as a native Joomla extension for Kunena 5.1. This version addresses most of the issues that were discovered in K 1.5.1 and issues discovered during the development stages of K 1.5.2.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question Kunena not showing in custom Joomla template

More
7 years 6 months ago #1 by Crazy
Hey guys,

I'm new to using Joomla and Kunena, this is my first run through with both so please bear with me if this seems a little obvious.

My custom template converted and worked out nicely (After a bit of trial and error). I installed Kunena and it went on flawlessly but only for the standard Joomla templates. Using the same menu link in both standard and custom templates, Kunena shows and operates fine in the first but wont even show in the content section of my custom template.

Is there a module I need to point to my content position of my template? It seems to have done it all automatically in the standard templates. If not, is it possible my template is conflicting (I've not given Kunena enough space or something)?

Unfortunately it's not online yet for me to show, it's easy enough to describe though, it's a completely empty space, even the browser debug tools show nothing at all where the content should be. The content div hasn't even been loaded, which makes me think the php if statement has counted 0 modules requested at that position and moved on (I think that's how it works?).

Below is my settings config report:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 2M

This message contains confidential information

Joomla default template details : 24th | author: Crazy | version: 0.1 | creationdate: 06/06/12

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.6.4 | creationdate: 2011-05-07

Kunena version detailled: Installed version: 1.6.4 | Build: 4832 | Version name: Kerkrade | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: None


Any help at all would be greatly appreciated, been racking my brains over this the past few nights.

Cheers.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 6 months ago #2 by sozzled
Replied by sozzled on topic Kunena not showing in custom Joomla template
G'day, Crazy, and welcome to Kunena.

There's not a lot that we can do to assist you with your webdesign issues when we cannot see the work that you've done (or how you've gone about it) and this is the point that we've tried to make in Support for PC-hosted websites (e.g. WAMP, XAMPP) .

You've given us a next-to-impossible assignment here.

Many of the problems that you now experience on your localised, offline, site won't be apparent when you produce a site that is based on a real webhost. Having said that, I don't see anything evindent from your K 1.6 configuration report but I suggest you seek further information about how to construct J! 1.6 templates from the Joomla support forum . Maybe they have a few tips for you.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #3 by Crazy
Thanks for the suggestions Sozzled. I posted in the Joomla template forums and got some really good help, the problems now fixed. I hadn't put <jdoc:include type="component" /> into my template.

It's all working brilliantly now, looking forward to using Kunena and templating that now :)

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.088 seconds