×
Kunena 5.1.6.1 Released - Security Release (09 Nov 2018)

The Kunena team has announce the arrival of Kunena 5.1.6 [K 5.1.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

K5.1.6.1 is a install update.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question why 404?

More
7 years 5 months ago #1 by clairence
why 404? was created by clairence
I'm confused about why I am frequently getting 404 errors when I spend some time away from my forum (minutes to hours). I can be logged in, step away for a period of time, and then when I return I get a 404 error regardless of the link I click in the forum.
I had assumed my problem was a session timeout (set at 3600seconds) so I upped it to 36000 seconds, and still found a 404 error...

My most recent result,after about ~90 minutes away and then clicking on "New Topic", was the following:

An error has occurred.
The requested page cannot be found.

Home Page
If difficulties persist, please contact the System Administrator of this site and report the error below.
#404 Kunena function "newtopic" not found


Even if I've been timed out, that's a terrible way to resolve to the home page.
Please help understand what's happening. THANKS.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 120 seconds | Max execution memory: 200M | Max file upload: 20M

This message contains confidential information

Joomla default template details : beez_20 | author: Angie Radtke | version: 1.6.0 | creationdate: 25 November 2009

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.6.4 | creationdate: 2011-05-07

Kunena version detailled: Installed version: 1.6.4 | Build: 4832 | Version name: Kerkrade | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: None

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 5 months ago - 7 years 5 months ago #2 by sozzled
Replied by sozzled on topic why 404?
I don't know if session limits are related to 404 errors. Our recommendation is to make the Joomla session limit the same value as the Kunena session limit.
  • Global Configuration » Session Settings » Session Lifetime

  • Kunena Forum » Forum Configuration » General » Basic Settings » Session Lifetime
    • should be set to the same length of time as the Joomla session lifetime
I hope that helps
Last edit: 7 years 5 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
7 years 5 months ago #3 by clairence
Replied by clairence on topic why 404?
ok. i can (and did) do that.

any thoughts on why I'm getting 404's?

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 5 months ago - 7 years 5 months ago #4 by sozzled
Replied by sozzled on topic why 404?
404 errors are typically associated (in Joomla, at least) with outdated or non-resolvable menu items. In many cases these issues arise because of not properly setting up Joomla SEO (see Search Engine Optimisation (SEO) in the Wiki for a guide on how to do this).

In general terms, this is more a Joomla configuration issue than it is a problem with Kunena and it is your Joomla configuration (in particular the links you have in the Joomla Menu Manager) where you need to look first.

We may be able to better assist if we could see your K 1.6 configuration report. This is why we ask people to read the posting guidelines (printed at the top of this page) when they submit questions to the K 1.6 Support category. The K 1.6 configuration report helps you to help us to help you quicker. It saves us time asking you for the information if you include it when you submit your question to the K 1.6 Support category.

It is, however, quite unusual to receive reports of HTTP 404 errors occurring randomly or not as the result of clicking a link (as you wrote):

I am frequently getting 404 errors when I spend some time away from my forum (minutes to hours). I can be logged in, step away for a period of time, and then when I return I get a 404 error regardless of the link I click in the forum.

And so I find this situation, as you described it, somewhat puzzling.

404 errors are reproducible, not because of some "timing issue" but because of clicking certain links. They occur or they do not occur consistently depending on those links. Some links will always produce these errors and others will never produce those errors. Again, the issue comes down to SEO and whether you use the standard Joomla SEO feature or if you use a third-party SEO/SEF product.
Last edit: 7 years 5 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
7 years 5 months ago #5 by clairence
Replied by clairence on topic why 404?
I did include my configuration report in my original query post.

In the time since my last reply to you, I have done css work on my forum and although I've been refreshing pages to view css changes. I'm logged in on both Firefox and Chrome, and after spending (most likely over) half an hour on Chrome, I switched to Firefox and was greeted with another 404.

I immediately logged back on, and have been posting new topics back and forth through both browsers. So it's not (as I thought perhaps) some sort of permissions error for being logged in at two places at once.

I will wait half an hour or so, and not use one of my browsers (Chrome this time), and see if I don't get a 404 with the next click. [that didn't happen... I had some css to finish]

I do understand that 404's are link-related, but since I'm seeing what is clearly a "confusing" example of links working sometimes and not others, I have made the assumption that it's related to sessions. I don't mind being wrong about that. But I would love to figure out what's going on.

What is supposed to happen when someone's session times out
? I assume they are redirected to a login page?

I'm looking at the SEO stuff, and will consider the final paragraph, although I've not made any previous adjustments to the default SEO settings.

Menus... I'll look at them. I've only two: Main Menu and Kunena Menu.

...and, one more time it happens.

I'll work on my menus, modules, and redirects. And ask back if this continues.

Thanks for your time thus far.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 5 months ago - 7 years 5 months ago #6 by sozzled
Replied by sozzled on topic why 404?

clairence wrote: I did include my configuration report in my original query post.

I'm sorry. I must have had a moment's blindness because it's there. I'm sorry for my mistake. :blush:

I looked at your website. I'm sorry but I cannot find the forum component. Am I looking in the wrong place? Maybe this is the reason you are getting HTTP 404 errors?

Would you like to post the URL of your Kunena forum that is giving you trouble? You can use the "
This message contains confidential information
Last edit: 7 years 5 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
7 years 5 months ago #7 by clairence
Replied by clairence on topic why 404?
I think you were right about it being a menu issue. I haven't had the original problem since my last posting here.

Yesterday I changed the "Logout Redirection Page" in the Basic Settings of my Login Form Module to a location that wasn't there, and got a 404. Changing that back removed it. So I'm pretty sure that was my original problem as well.

Thank you for pointing me in the right direction.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 5 months ago #8 by sozzled
Replied by sozzled on topic why 404?
Yes, well, again, please accept my apologies for what you could have interpreted as me trying to make you perform like a trained animal.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.109 seconds