×
Kunena 5.1.5 Released - Security Release (14 Oct 2018)

The Kunena team has announce the arrival of Kunena 5.1.5 [K 5.1.5] which is now available for download as a native Joomla extension for J! 3.8.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question Error in Joomla when not logged in Kunea

More
7 years 4 months ago - 7 years 4 months ago #1 by Df3nZ187
Hi, I installed Kunea a while ago and at the start everything seems to work fine.
But recently I got a notice that there was an Error when visitng our Site ( www.ki-shin-kan.de ) with the Internet Explorer (9).
I didnt notice this befor (I only use Firefox and Chrome), but tested it afterwards and the Error only seems to appear in Internet Explorer (testet FF, Opera, Chrome & Safari too) and only when you are not logged into the Kunea-Board.

I linked the Board with the User-Accounts in Joomla and it is only visible for registered Members, so sorrywhen you not can see/test it.

I'm kinda clueless what may cause this Error, for it only Appears in Internet Explorer, since it disseapers as soon as you logged in it must have to do something with it.

Does any one have an idea what to look for?

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 32M | Max file upload: 8M

This message contains confidential information

Joomla default template details : rhuk_milkyway | author: Andy Miller | version: 1.0.2 | creationdate: 11/20/06

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.6.3 | creationdate: 2011-01-31

Kunena version detailled: Installed version: 1.6.3 | Build: 4344 | Version name: Parlare | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Disabled or not installed | Jomsocial: Disabled or not installed | UddeIm: Disabled or not installed

Third-party SEF components: sh404sef: Disabled or not installed | ARTIO JoomSEF: Disabled or not installed | AceSEF: Disabled or not installed

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Enabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Disabled or not installed | My Kunena Forum Menu: Disabled or not installed | My Kunena Forum Posts: Disabled or not installed

Modules: Kunena Latest: Disabled or not installed | Kunena Stats: Disabled or not installed | Kunena Login: Disabled or not installed

Last edit: 7 years 4 months ago by sozzled. Reason: Reveal K 1.6 configuration report in message

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 4 months ago #2 by sozzled
Replied by sozzled on topic Error in Joomla when not logged in Kunea
Please upgrade to K 1.6.4; K 1.6.3 is not supported.

Please check the Joomla support forum ( forum.joomla.org ) for special advice about how to set up .htaccess files for Debian systems.

Please Log in or Create an account to join the conversation.

More
7 years 4 months ago - 7 years 4 months ago #3 by Df3nZ187
Okay, I updated to 1.6.4, but no change.

But someone else pointed to me that its about new Browser-Updates, and so I looked and indeed their where Updates to Firefox (4.0 -> 4.0.1) and Opera (11.10 -> 11.11) the last days and after installing them they both now show the same Error as the Internet Explorer. Chrome is still fine. (no Update till now)

So it seems as it has something to do with how the Browser handels some of the Scripts.


This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 128M

This message contains confidential information

Joomla default template details : rhuk_milkyway | author: Andy Miller | version: 1.0.2 | creationdate: 11/20/06

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.6.4 | creationdate: 2011-05-07

Kunena version detailled: Installed version: 1.6.4 | Build: 4832 | Version name: Kerkrade | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Enabled | System - Mootools12: Disabled

Modules: None

Last edit: 7 years 4 months ago by Df3nZ187.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 4 months ago - 7 years 4 months ago #4 by sozzled
Replied by sozzled on topic Error in Joomla when not logged in Kunea
The last config report you posted is for a different site, with different PHP and MySQL.

Are you testing Kunena on a website hosted on your own PC? The PHP and MySQL versions could be what is giving you the problems. See also Support for PC-hosted websites (e.g. WAMP, XAMPP)
Last edit: 7 years 4 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
7 years 4 months ago - 7 years 4 months ago #5 by Df3nZ187
Sorry, yes for Error-Searching im testing it on Xampp local.
Heres the Report from the real Webspace.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 32M | Max file upload: 8M

This message contains confidential information

Joomla default template details : rhuk_milkyway | author: Andy Miller | version: 1.0.2 | creationdate: 11/20/06

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.6.4 | creationdate: 2011-05-07

Kunena version detailled: Installed version: 1.6.4 | Build: 4832 | Version name: Kerkrade | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Enabled | System - Mootools12: Disabled

Modules: None



I already tested putting Safe-Mode ON in xampp too (cause Error mentioned smoething about Safe-mode), but it did not make any difference.
Last edit: 7 years 4 months ago by Df3nZ187.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 4 months ago - 7 years 4 months ago #6 by sozzled
Replied by sozzled on topic Error in Joomla when not logged in Kunea
Thank you. So what is the specific error that we you get when are not logged in to your site? I did not see any errors in IE 9 or FF 4.

Do you have a test account that we can use?

(You can post your test account details using the same
This message contains confidential information
Last edit: 7 years 4 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
7 years 4 months ago - 7 years 4 months ago #7 by Df3nZ187
The Errors are:

Warning: fopen(/var/www/web587/html/logs/error.php) [function.fopen]: failed to open stream: Permission denied in /var/www/web587/html/libraries/joomla/error/log.php on line 202

Warning: Cannot modify header information - headers already sent by (output started at /var/www/web587/html/libraries/joomla/error/log.php:202) in /var/www/web587/html/plugins/system/remember.php on line 72

And further he seems not able to get the right Encoding for the Page, always encoding it in latin and not in utf-8. I guess this have something to do with the second error.




After testing a little more, here what happens in detail.

You will see the Site right, when you never have logged in to it.
If you are logged in, you see it right too.
If you have been logged in in the past, but currently are not, you get the error.
The Error will dissappear as soon as you log in again, or delet the cookies from the site in your Browser.
This will happen in IE, FF and Opera, but not in Chrome or Safari.

For the Test-Account I'm sorry, but as you can see it is not an private Homepage, so I cant give you an access to the Intern-Section.
I know this sure would be helpful, but it's just not possible.

EDIT: A little more explanation. Like said before, I used the Option to merge the Login of Joomla & Kunena, so User Accounts from Joomla will be used by Kunena too.
Attachments:
Last edit: 7 years 4 months ago by Df3nZ187.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 4 months ago - 7 years 4 months ago #8 by sozzled
Replied by sozzled on topic Error in Joomla when not logged in Kunea
Thanks for the extra information (which explains why I and no-one else would ever be able to see the error because we don't have a way of logging in to your site) but what has this got to do with Kunena?

I suppose I should explain that a little more. The error message actually is from the "rememberme" plugin. There is no rememberme plugin in Kunena. Could be a server caching or session issue. We'd need to see your Global Configuration to know what's going on there. Have you asked your questions at the Joomla support forum ( forum.joomla.org )?
Last edit: 7 years 4 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
7 years 4 months ago - 7 years 4 months ago #9 by Df3nZ187
AS far as I understand, the remember.php deals with setting up the cookies for the joomla registration.

But I never used the joomla registration, I just activated it when I installed kunena, cause for the Intern-Section I use a mix of kunena as board and joomla for publishing news. Since I dont want two seperate log-ins I used the Option that Kunena will use the Joomla-Log-in for itself too.

I dont know how this exactly works, but it looks like kunena makes a copy of the joomla-profil as soon as someone first enters the board?

My guess is that the Error lies somewhere in this merging of the profils or so, as for now I tried it with a clean Joomla with activated User-Registration and there no Errors appear.

But I'm also not sure if this is an Error in the CMS or indeed something in the Server Configuration.
Does Kunena need something that joomla alone dont need to handle its User-Accounts?
But since it is rented Webspace theres no chance of playing around with the Server, so I'm stick with finding a solution within the CMS/Board.
Last edit: 7 years 4 months ago by Df3nZ187.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 4 months ago #10 by sozzled
Replied by sozzled on topic Error in Joomla when not logged in Kunea
As we have written before, on hundreds of occasions, Kunena is not responsible for user registration. Kunena uses whatever you have installed for user registration. Kunena can integrate with a login form from another module, if you have one installed on your site, but you also have the choice to disable logins altogether from the Kunena pages. Does this help?

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.264 seconds