×
Kunena 5.1.5 Released - Security Release (14 Oct 2018)

The Kunena team has announce the arrival of Kunena 5.1.5 [K 5.1.5] which is now available for download as a native Joomla extension for J! 3.8.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question I want to get rid of Joomla legacy mode

More
7 years 6 months ago - 7 years 6 months ago #1 by zeisse
Moderator's note: topic split from Joomla legacy mode and Kunena


Hi All,
In my case forum has been updated from 1.6 to 1.63. With 1.6 I used legacy mode because I had some old modules on my Joomla. Now all old modules are removed but I can not turn of legacy mode if Kunena is on. If I turn off Kunena in install -> components Joomla works with out legacy mode, but with Kunena switch on I get message "Direct Access to this location is not allowed."
I've try switch off all my components and only with out Kunena Jommla works fine.
All components/modules/plugins on installer page are green.
What else I have to check?

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Enabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 64M | Max file upload: 64M

This message contains confidential information

Joomla default template details : yoo_corona | author: YOOtheme | version: 5.5.2 | creationdate: March 2011

Kunena default template details : Euro-BRed | author: Mizunga | version: 1.6.1 | creationdate: 2010-12-20

Kunena version detailled: Installed version: 1.6.3 | Build: 4344 | Version name: Parlare | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Installed (Version : 1.2.3) | Jomsocial: Disabled or not installed | UddeIm: The file doesn't exist uddeim.j15.xml !

Third-party SEF components: sh404sef: Disabled or not installed | ARTIO JoomSEF: Disabled or not installed | AceSEF: Disabled or not installed

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Enabled | JFirePHP: Disabled or not installed | Kunena Discuss: Enabled (Version : 1.6.2) | Kunena Search: Enabled (Version : 1.6.2) | My Kunena Forum Menu: Disabled or not installed | My Kunena Forum Posts: Disabled or not installed

Modules: Kunena Latest: Enabled (Version : 1.6.2) | Kunena Stats: Enabled (Version : 1.6.2) | Kunena Login: Disabled or not installed

Last edit: 7 years 6 months ago by zeisse.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #2 by xillibit
Hello,

try with default kunena template

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 6 months ago - 7 years 6 months ago #3 by sozzled
Replied by sozzled on topic I want to get rid of Joomla legacy mode
Let's look at what is being written in this topic:

zeisse wrote:

If I turn off Kunena in install -> components Joomla works with out legacy mode, but with Kunena switch on I get message "Direct Access to this location is not allowed."
I've try switch off all my components and only without Kunena Joomla works fine.

I'm sorry but I find this very difficult to accept on the face of it.

K 1.0 needed legacy mode to run. K 1.5 was the first version to run, natively, in J! 1.5 without legacy mode. K 1.6 has not been tested with legacy mode but, like K 1.5 before it, K 1.6 does not need legacy mode. Some other Joomla extensions may need legacy mode, not K 1.6.

If we wrote (in Joomla legacy mode and Kunena and in the Wiki article Legacy mode ) that Kunena does not need "legacy mode" then that's a fact: Kunena does not need legacy mode. If Kunena needs "legacy mode" then there this website ( www.kunena.org ) would not work and there will be hundreds of thousands of websites throughout the world that will not work.

The point that I am trying to make is that it's not Kunena that you have that's causing the "Direct Access to this location is not allowed" message ... it's something else. Your K 1.6 configuration report refers to some issue with uddeIM; it looks like you may have experimented with uddeIM (or J! 1.6) but decided to remove some files manually from your site.

Unfortunately you have edited your K 1.6 configuration report by removing certain details and there's no easy way for me to survey or suggest what other feature you have on your site that may be the culprit.

I say again, firmly but politely, this is not a Kunena issue; this is a Joomla issue. However we will continue to work with you to help you resolve the issue as best we can. Your co-operation (but providing full and frank details) will help us to help you better.
Last edit: 7 years 6 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago - 7 years 6 months ago #4 by zeisse
Hi,
thanks for your great support and quick replay.
Based on your suggestions I've changed Kunena template to default. I've also completely removed UddeIM to be sure that this is not root cause. After this my problem is still present.

Is it possible that I have problem because Kunena has been installed with legacy mode switched on?
If yes, how to check it or how to fix it?
Is there any information in code or sql about legacy mode during installation?

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Enabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 64M | Max file upload: 64M

This message contains confidential information

Joomla default template details : yoo_corona | author: YOOtheme | version: 5.5.2 | creationdate: March 2011

Kunena default template details : Example Template | author: Kunena Team | version: 1.6.3 | creationdate: 2011-01-31

Kunena version detailled: Installed version: 1.6.3 | Build: 4344 | Version name: Parlare | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Installed (Version : 1.2.3) | Jomsocial: Disabled or not installed | UddeIm: Disabled or not installed

Third-party SEF components: sh404sef: Disabled or not installed | ARTIO JoomSEF: Disabled or not installed | AceSEF: Disabled or not installed

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Enabled | JFirePHP: Disabled or not installed | Kunena Discuss: Enabled (Version : 1.6.2) | Kunena Search: Enabled (Version : 1.6.2) | My Kunena Forum Menu: Disabled or not installed | My Kunena Forum Posts: Disabled or not installed

Modules: Kunena Latest: Enabled (Version : 1.6.2) | Kunena Stats: Enabled (Version : 1.6.2) | Kunena Login: Disabled or not installed

Last edit: 7 years 6 months ago by zeisse.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #5 by xillibit
I mean Kunena default template but not the example template. Do you have upgraded from k1.5.x ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #6 by zeisse

I mean Kunena default template but not the example template. Do you have upgraded from k1.5.x ?

No, I've updated from 1.6 to 1.63.
With default template (blue eagel) nothing is changed.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 6 months ago #7 by sozzled
Replied by sozzled on topic I want to get rid of Joomla legacy mode

zeisse wrote: Is it possible that I have problem because Kunena has been installed with legacy mode switched on?

Consider what you are asking. In a way you are still saying that the problem is caused by Kunena. If you want to prove that legacy mode is not involved the why don't you uninistall Kunena (don't worry, you won't lose your forum data, categories, etc.) turn off legacy mode and then re-install Kunena. I'm willing to bet that you'll have the same problems,.

I had hoped to have cleared any possible likelihood that Kunena 1.6 was causing your inability to run your site without "legacy" mode. The issue is not with Kunena; the issue is that there is something else on the pages that display Kunena on your site. I don't know what that something else is but it would be good to be able to access your website to see what's going on.

We cannot access your site. You have your site locked out. Can you post a user account for us to look at your site, please? You can use the
This message contains confidential information

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #8 by zeisse
Thank you for your help and trying find what is wrong.
As you wrote my site is locked out because I do not want show to members web before finish it, but I can give you temporary administrator password if you would check where is the problem.
Just let me know if I should send you this login and password.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 6 months ago #9 by sozzled
Replied by sozzled on topic I want to get rid of Joomla legacy mode
You can post a test account (it does not have to be an administrator's account) here on the forum if you wrap the details within
This message contains confidential information

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago - 7 years 6 months ago #10 by zeisse
Please find below temporary administrator password.
This message contains confidential information
Last edit: 7 years 6 months ago by zeisse.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.172 seconds