×
Blue Eagle 1.5.2 Released (11 Dec 2018)

The Kunena team has announce the arrival of Kunena Blue Eagle 1.5.2 which is now available for download as a native Joomla extension for Kunena 5.1. This version addresses most of the issues that were discovered in K 1.5.1 and issues discovered during the development stages of K 1.5.2.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question Fatal error on com_search on backend

More
7 years 9 months ago - 7 years 9 months ago #1 by likemandrake
Hello,

I'm using Jooomla 1.5.22, Kunena 1.6.3 on Linux

On page /administrator/index.php?option=com_search&search_results=1 on Backend PHP triggers Fatal Error
Call to undefined method JSite::getActive() in [...]/administrator/components/com_kunena/libraries/route.php on line 143

Best Regards
Piotr Minkina
Last edit: 7 years 9 months ago by likemandrake.

Please Log in or Create an account to join the conversation.

More
7 years 9 months ago #2 by xillibit
Hello,

Search component isn't Kunena, so look at Joomla! support forum

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
7 years 9 months ago #3 by likemandrake
I'm not stupid... but the problem exists in the Kunena file

/administrator/components/com_kunena/libraries/route.php on line 143

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 9 months ago #4 by sozzled
Replied by sozzled on topic Fatal error on com_search on backend
No-one was trying to suggest that you were stupid, but com_search is a Joomla component. This should not have anything to do with Kunena ... but we could be wrong.

When do you get this error (on what page(s) do you get this error)? Can you help us to understand how we can also get the same error on one of our test sites, please? Thank you.

Can you show us your K 1.6 configuration report, please?

Please Log in or Create an account to join the conversation.

More
7 years 9 months ago #5 by Mukesh Jain
i have no idea

Please Log in or Create an account to join the conversation.

More
7 years 9 months ago - 7 years 9 months ago #6 by likemandrake
Hello and sorry that was rude...

I'm testing it also on my local machine, where XDebug is installed. I put the results in attachment.

This is Kunena report:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 512M | Max file upload: 10M

This message contains confidential information

Joomla default template details : polskamanga.pl | author: Piotr Minkina | version: 0.3.12 | creationdate: 2011-01-24

Kunena default template details : A1 - Kunena 1.6 Template | author: TemplateKunena Team | version: 1.6.1 | creationdate: 2010-10-03

Kunena version detailled: Installed version: 1.6.3 | Build: 4344 | Version name: Parlare | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Disabled or not installed | Jomsocial: Installed (Version : 2.0.4) | UddeIm: Disabled or not installed

Third-party SEF components: sh404sef: Disabled or not installed | ARTIO JoomSEF: Disabled or not installed | AceSEF: Installed (Version : 1.5.15)

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Enabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Enabled (Version : 1.6.2) | My Kunena Forum Menu: Disabled or not installed | My Kunena Forum Posts: Enabled (Version : 1.6.3-DEV)

Modules: Kunena Latest: Enabled (Version : 1.6.2) | Kunena Stats: Disabled or not installed | Kunena Login: Disabled or not installed


Best Regards
Piotr Minkina
Attachments:
Last edit: 7 years 9 months ago by likemandrake.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 9 months ago #7 by sozzled
Replied by sozzled on topic Fatal error on com_search on backend
I'm sorry. I can't read the attachment. Can you show us with a picture, perhaps, what you were doing when you encountered that error? If we know what you were doing, maybe we could try the same thing ourselves to see if we get the same issues.

Please Log in or Create an account to join the conversation.

More
7 years 9 months ago #8 by likemandrake
Try to download this attachment. To cause an error go to Backend > Components > Search, on the right side You can see link "Show results". Of course, You must have some words in the list below, so You should have to tracking search enabled and from the Frontend find a few words to supplement this list.

Best Regards
Piotr Minkina
Attachments:

Please Log in or Create an account to join the conversation.

More
7 years 5 months ago #9 by haribo
Hello everbody,

i have the same problem. how is the state of this bug?
if you click on "Show results" in Backend>Components>Search Joomla call all registered search-plugins to count the "results" for every word in the column "Search Phrase". if i set the kunena search plugin to disabled then everything is fine, otherwise "enabled" cause the problem and error message described below.

Regards
Harald

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.124 seconds