×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Idea memory setting

More
9 years 7 months ago #1 by winstart
memory setting was created by winstart
changed the setting to 32M in the index file by entering the code:ini_set('memory_limit','48M');

the forum works now, but i cant work on the users because of to short memory

what to do, who to tell

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #2 by fxstein
Replied by fxstein on topic Re: memory setting
You must have WAY too much installed that is eating up your memory. Kunena will run in under 10MB together with JomSocial integration activated. On a perfectly tuned server, it can run in under 5MB.

I would assume that you are running something else that is consuming a ton of memory. If you have 3rd party SEF, turn it off, also try turning off other plugins and modules.

Best tu turn on Joomla debug mode and records the memory usage on any Kunena page.

As we have no way of telling what is installed on your server and in Joomla, I recommend to turn off anything that is not coming with Joomla - at least for testing - so you can find the root cause of the memory consumption.

Hope this helps!

We love stars on the Joomla Extension Directory . :-)

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #3 by winstart
Replied by winstart on topic Re: memory setting
doesn't look too much does it?

Profielinformatie

Application afterLoad: 0.003 seconds, 0.37 MB
Application afterInitialise: 0.078 seconds, 4.72 MB
Application afterRoute: 0.078 seconds, 4.72 MB
Application afterDispatch: 0.256 seconds, 8.24 MB
Application afterRender: 0.321 seconds, 8.99 MB
Geheugengebruik

9465820

but when i want to work on my users i get
Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 60 bytes) in /home/winstart.nl/public_html/HJ/libraries/joomla/language/language.php on line 353

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #4 by winstart
Replied by winstart on topic Re: memory setting
changed to native mode
now i get this when i want to work with the usersettings
Profielinformatie

Application afterLoad: 0.003 seconds, 0.37 MB
Application afterInitialise: 0.053 seconds, 3.21 MB
Application afterRoute: 0.053 seconds, 3.21 MB
Application afterDispatch: 0.249 seconds, 14.67 MB
Application afterRender: 0.314 seconds, 15.43 MB
Geheugengebruik

16228512
Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 77824 bytes) in /home/winstart.nl/public_html/HJ/libraries/geshi/geshi.php on line 2106

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #5 by winstart
Replied by winstart on topic Re: memory setting
and another thing, changed in my index.php the memory settings to 32M
but looking in joomla the memory still is on 16....

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #6 by fxstein
Replied by fxstein on topic Re: memory setting
Ok - so your runtime setting is not being accepted. 16MB can get too little depending on other plugins you have.

At first look I thought you had set it to 48MB (see code fragment of first post).

You will have to check with your hosting provider to raise the limit from 16MB to 32MB.

Not sure I understand the difference between the first and second debug list. What do you mean by native mode?

You should also provide a config report from the Kunena backend. That shows us a lot more details about your setup.

Hope this helps!

We love stars on the Joomla Extension Directory . :-)

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #7 by fxstein
Replied by fxstein on topic Re: memory setting
One more thing: uploading and processing larger images can take multiple MB per picture. Not sure what you mean by "work on my users".

We love stars on the Joomla Extension Directory . :-)

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #8 by winstart
Replied by winstart on topic Re: memory setting
send a mail to my host
i'll keep you informed

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #9 by winstart
Replied by winstart on topic Re: memory setting
can't open the user panel in the main kunena backend settings

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #10 by winstart
Replied by winstart on topic Re: memory setting
in my .htaccess i placed php_value memory_limit 128M
now it works

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.118 seconds