×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question Editing profile - autofiled password

More
9 years 11 months ago - 9 years 11 months ago #1 by devwiz
The problem appear when you have settings in your browser to remember auto fill the form fields or remember passwords automatique.

So when you EDIT your account you may be see that the first field from your passwords pre-filed (1) ********* . But if you do not fill the password confirmation field as well then ANY change (2) for ex. upload new avatar ) in the profille is not saved, and also there is no indication of error.




The solution could be changing the name of the form field password so it is not auto filled or at least generate error "Password doesn't match"



This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 1800 seconds | Max execution memory: 128M | Max file upload: 30M

Kunena version detailled: Installed version: 1.6.0 | Build: 3620 | Version name: Spika | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Disabled or not installed | Jomsocial: Disabled or not installed | UddeIm: Installed (Version : 2.1)

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Disabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Disabled or not installed | My Kunena Forum Menu: Disabled or not installed

Modules: Kunena Latest: Enabled (Version : 1.6.0-RC2) | Kunena Stats: Enabled (Version : 1.6.0-RC2) | Kunena Login: Enabled (Version : 1.6.0-RC2)

Attachments:
Last edit: 9 years 11 months ago by devwiz. Reason: config

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #2 by xillibit
Hello,

This is a known issue in k1.6.0 and this will be fixed in k1.6.1

I don't provide support by PM, because this can be useful for someone else.
The following user(s) said Thank You: devwiz

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #3 by devwiz
I found very elegant solution of the mentioned problem:

You have to edit your 'edituser.php' file usually located at
\components\com_kunena\template\default\profile\edituser.php

Find the line of code (about line 53) that handles the input fields for password:
<input class="inputbox validate-password" type="password" id="password" name="password" value="" size="40" />

and change it to :
<input class="inputbox validate-password" type="password" id="password" name="password" value="" size="40" autocomplete="off" />

i.e. you have to add autocomplete="off" as parameter.

That's all! (optionally you may wish to add it to the password2 input field as well)
This will save you a lot of complains like "Why my profile doesn't save when I update it?"

Hope this helps :woohoo:

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #4 by xillibit
Thanks for that

So, the issue still happen with K1.6.1 ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago - 9 years 10 months ago #5 by devwiz
Hi xillibit,

I just finished testing

I confirm that the problem persist with K1.6.1 after upgrade from K1.6.0 :

without the fix autocomplete="off" :



After applying the fix it is OK :



Also - there is still no error message if password doesn't match.


Hope this helps
Thank you
Attachments:
Last edit: 9 years 10 months ago by devwiz.

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #6 by xillibit
the autocompleter="off" is working on Google Chrome ?

The autocompleter="off" is not valid in W3C, so you need to set autocompleter="off" with javascript

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #7 by devwiz
Yes I know it is not valid in W3C but it solves the problem for me for now ... :dry:

It works with latest Firefox 3.6.12 Chrome 7.0.517.44 Safari 5.0.2 ie 8.0.7600

Again, even it is durty fix it works for me because you could imagine what happenes when you urge your members to update their profiles and they come back not with very happy language :lol:

I guess you are goin to fix this in the next releases. Most of the people don't get it that the tabs are updated all together on save... or at least an error message is neccesary to popup

Thank you so much for the help and the great support !!!

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.787 seconds