×
Blue Eagle 1.5.2 Released (11 Dec 2018)

The Kunena team has announce the arrival of Kunena Blue Eagle 1.5.2 which is now available for download as a native Joomla extension for Kunena 5.1. This version addresses most of the issues that were discovered in K 1.5.1 and issues discovered during the development stages of K 1.5.2.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Solved Strict standards writings on top of the page

More
4 years 4 months ago - 4 years 4 months ago #1 by Ishtar
Hi

after updating Kunena I am getting lots of errors on the of the page

The templates ( here is number 2 ) I'm running suports J 2.5 there is as well a J. 3 version but I haven't migrated yet.

I get it, that I can get those texts in the backend global settings -> server -> log errors "none".

But is there as well another way without having to change the templates? I am planning on using the same ones when migrating to J3 but I didn't want to migrate right now.

Plus, when wanting to write something and clicking on "new topic" in Kunena front end it redirects to the index page of the homepage......

Greetings - Ishtar

_________________________
J 2.5.24
Kunena 3.0.5
CB 1.9.1
Last edit: 4 years 4 months ago by Ishtar.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
4 years 4 months ago - 4 years 4 months ago #2 by sozzled
Replied by sozzled on topic Strict standards writings on top of the page
I think I understand the problem. Part of the problem is because you still have old "FB" tables from an really old installation of Kunena and there's a bug in the K 3.0 upgrade procedure that does not properly handle such cases.

The developers have been aware of this problem for a long time; it is unfortunate that this issue has not received the highest priority but, you should also remember, the issue only occurs in rare circumstances where people still have old "FB" tables in their databases. It is hoped that the new K 3.0.6 release will address this issue.

The first three messages on the page have nothing to do with Kunena.

Ishtar wrote: Plus, when wanting to write something and clicking on "new topic" in Kunena front end it redirects to the index page of the homepage......

This is a separate issue and it is related to how you have implemented your Joomla menu.
Last edit: 4 years 4 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #3 by Ishtar
Hi sozzled

If I understand you correctly I have 3 problems.
1. not related to Kunena - is related to what?

2. FB tables:
Looking at Php my admin I have kind of three databanks....... one has J25 and as well Jos-fb- so that could be the one I'm using.
I did start with the forerunner of Kunena, I think it was Fireboard?
Do I understand correctly that the new version with the bugfix is released this weekend? Or am I supposed to use the fix now, or delete all the -fb- data?

3. The new topic redirecting.........
I implemented Kunena changing the topmenue I had before using: menuetype--> Kunena Forum --> Homepage
What I did not understand was the default menue item. I put in: Kunenamenue--> Forum--> index.
(or should I open a new topic for that?).

Greetings - Ishtar

_________________________
J 2.5.24
Kunena 3.0.5
CB 1.9.1

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
4 years 4 months ago - 4 years 4 months ago #4 by sozzled
Replied by sozzled on topic Strict standards writings on top of the page

Ishtar wrote: 2. FB tables:
Looking at Php my admin I have kind of three databanks....... one has J25 and as well Jos-fb- so that could be the one I'm using.
I did start with the forerunner of Kunena, I think it was Fireboard?
Do I understand correctly that the new version with the bugfix is released this weekend? Or am I supposed to use the fix now, or delete all the -fb- data?

I really cannot say when K 3.0.6 (the new version that may address these issues) will be released. It could be a couple of days or it could be a week or more. The new version is still being tested and it is not known if the new version will address other known, unresolved problems that are outstanding at the moment. This is something that the team is still discussing. If K 3.0.6 is released soon, I cannot tell you when the other unresolved issues will be addressed (or whether they will be addressed) as part of K 3.0. It depends on whether the team will attempt to fix other problems in K 3.0 or wait (for several months) and try to fix those things as part of K 3.1.
Last edit: 4 years 4 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #5 by rich
Is your facebook plugin up to date? Disable the plugin fb_tw_plus1 and test your page.
The following user(s) said Thank You: Ishtar

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #6 by Ishtar
:pinch: I didn't check the modules or plugins! I only updated the components!

Yes, disabling fb_tw_plus 1 makes two out of five errors away (only strict standard) stay. I will asap look for the update of the plugin!

Greetings - Ishtar

_________________________
J 2.5.24
Kunena 3.0.5
CB 1.9.1

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
4 years 4 months ago #7 by sozzled
Replied by sozzled on topic Strict standards writings on top of the page

sozzled wrote: I think I understand the problem.

I was wrong before and I am happy to admit I was wrong. The "FB" in the error message refers to Facebook, not Fireboard.

None of the "strict standards" errors have anything to do with Kunena.

*** To moderator: please move this topic to the Miscellaneous, off-topic and general Joomla category ***

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #8 by Ishtar
When using the default Joomla template the strict standards errors disappear on the Kunena site (didn't check the others, but assume it's the same)The author of the template told me to change the error view to simple and they would disappear. I think I will do that, but leave them on until Kunena works fine again (just in case there is a connection).

I made a new topic for the redirect and 404 .

Thank you :)

Greetings - Ishtar

_________________________
J 2.5.24
Kunena 3.0.5
CB 1.9.1

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #9 by rich
*** Topic moved ***

sozzled is right. These errors have nothing to do with Kunena.

The author of the template told me to change the error view to simple and they would disappear.

Is also a possibility, but not the best. The errors are only hidden, but not eliminated.
The following user(s) said Thank You: sozzled

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #10 by Ishtar
Well, do you have another suggestion?

Greetings - Ishtar

_________________________
J 2.5.24
Kunena 3.0.5
CB 1.9.1

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.088 seconds