×
Kunena 5.1.5 Released - Security Release (14 Oct 2018)

The Kunena team has announce the arrival of Kunena 5.1.5 [K 5.1.5] which is now available for download as a native Joomla extension for J! 3.8.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Important Multilanguage problem : "/link" created at the end of the url

More
4 years 9 months ago #1 by vcourbiere
Hello,

It seems that I have a major issue with Kunena: since I have my site and Kunena set in two languages (spanish and english), when I am set to spanish, I cannot access the posts in the forum, as for each post, the URL is changed automatically with a "/list" at the end... Instead in english, it all works fine.
Maybe it is because I have clicked on "mark all posts as read", but I am not sure.

When I go to Site -> Global Configuration and disable the "Search Engine Friendly URLs" everything works fine.

After some investigation on the net, I found that a plugin called "Xmap" may be the cause of the trouble, but I don;t have any plugin or module with that name.

My version of Kunena: 3.0.3
Houston, I need help ! :)

Thank you very much,
Vincent

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
4 years 9 months ago - 4 years 9 months ago #2 by sozzled
"Apollo 13, this is Houston" :lol:

K 3.0.3 is out of date and you should update it. I don't know how to fix problems with multilingual forums - I have no experience I such matters. You should also watch the video vimeo.com/69818669 - we might all learn something from it.

Sounds like you have a problem with implementing Joomla SEO. Have you read how to setup Joomla SEO properly?
Last edit: 4 years 9 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
4 years 9 months ago #3 by vcourbiere
Thanks for your answer. :) Indeed, I don't think I did something wrong in the Joomla SEO, as I am carefully fulfilling it trying not to implement anything wrong or conflictual... But maybe I passed over something.

Anyway, here is the Kunena code:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 180 seconds | Max execution memory: 128M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : DiabloFX | author: JoomFX.com | version: 1.6.0 | creationdate: Unknown

Kunena default template details : DiabloFX | author: JoomFX | version: 1.0 | creationdate: 2012-09-21

Kunena version detailed: Kunena 3.0.3 | 2013-10-20 [ Bifrost ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: AlphaUserPoints 1.8.4

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
4 years 9 months ago #4 by sozzled
Update to K 3.0.4. K 3.0.3 is out of date and many problems have been fixed with K 3.0.4.

See Search Engine Optimisation (SEO) in the Wiki.

Also, you should change your forum integration plugin settings as show in red below:

Kunena - AlphaUserPoints Enabled: activity=1 avatar=0 profile=0 activity_points_limit=0
Kunena - Community Builder Disabled
Kunena - Gravatar Disabled
Kunena - JomSocial Disabled
Kunena - Joomla Enabled: access=1 login=1
Kunena - Kunena Enabled: avatar=1 profile=1
Kunena - UddeIM Disabled

Have you tried using the K 3.0.4 Blue Eagle template? Does that make a difference?

Please Log in or Create an account to join the conversation.

More
4 years 9 months ago #5 by vcourbiere
Hello Houston, this is still Apollo 13... In perdition !!!

Well, first of all thanks for your advices in your previous post, but nothing worked... That's what I did:

1. Updated to Kunena 3.0.4. Installation worked fine, and everything seems to be ok.
2. I changed all the forum integration plugins as per the values you mentioned
3. I followed the SEO article, changed my htaccess.txt to .htaccess, and have activated the "use url rewriting" in the global configuration of Joomla.

And it still not works... I still have the "/list" added at the end my url when I am set to spanish.

Any new option please ? I am really lost with that problem...
Thanks a lot !

Vincent

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
4 years 8 months ago #6 by sozzled

vcourbiere wrote: I followed the SEO article, changed my htaccess.txt to .htaccess, and have activated the "use url rewriting" in the global configuration of Joomla.

It would help to see your Kunena configuration report after you have made those changes.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.103 seconds