×
Kunena 5.2 RC 1 Released (25 Oct 2020)

The Kunena team is thrilled to announce the first public release candidate of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 RC1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Solved Nothing happens when I click on some of the links (.htaccess file issues)

More
6 years 11 months ago #1 by picht
Hi

I have a problem...
When i (administrator with admin rights) click on e.g. Lock thread og delete thread, the page reloads but nothing has happened. I can click on it 5 times and nothing happens.

If i then go to another page on the site and back to the Kunena forum, then i get the message that the thread has been deleted (and i get the message 5 times)

I have caching off on both Joomla and Kunena.

Regards
Picht

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago #2 by sozzled

picht wrote: I have a problem...

I don't know how to help you. I suggest you look at the advice posted many times around this forum (and at thte top of this page) that looks like this:

If you are using the forum to discuss your problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help. If you do not post your configuration report we will not ask you for it but you may not receive a solution to your problem, either.

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago #3 by picht
My apologies.

Her it is:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 3000 seconds | Max execution memory: 256M | Max file upload: 100M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : GossipFX | author: JoomFX.com | version: 1.0.0 | creationdate: Unknown

Kunena default template details : GossipFX | author: JoomFX | version: 2.0.4 | creationdate: 2013-02-06

Kunena version detailed: Kunena 3.0.3 | 2013-10-20 [ Bifrost ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 1.9.1

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 3.0.1

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago #4 by sozzled
You should ask the developer of the Kunena template you are using why it is not working with K 3.0.3 or if they have an updated version that works with K 3.0.3.

Also, you might try simplifying your Kunena menu - try the standard menu - to see if it helps. The FAQs page (see the menu item/tab at the top of the forum here) has information about how to use the standard Kunena menu.

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago #5 by picht
Well that was very quick to blame the template...

Actually the template works fine, same problem with the defauilt one. And the menu is the same as the default but translated to Danish. There are some other menuitems, but they are unpublished (old test ones)

I have found that the problem lies in the .htaccess file.

It looks like this:
<IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteCond %{HTTP_HOST} !^www\.
  RewriteRule ^(.*)$ https://www.%{HTTP_HOST}/$1 [R=301,L,E=Cache-Control:no-cache]
</IfModule>

It makes www. in front of the URL to avoid problems with people logging in using URL without www, and then it disables the cache.

If i remove the URL rewrite and leave it like this:
<IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteRule (.*) - [L,E=Cache-Control:no-cache] 
</IfModule>

then everything works fine. No problems anymore.

But does anyone know why thi is so and how i combine both things and get i to work properly ?

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago #6 by Matias
I think you can make two rules out of it. First for just redirect and the second to disable the cache?

But why do you want to disable cache as Joomla does that already?

If you don't want to have redirects as permament (cached), use 303 instead.

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago #7 by picht
If i removed the no-cache part, then i have problems with my site regarding to caching.

I don't understand what you mean by 303 ?

Making 2 rules, isn't that what is shown in the first example ?

I'm quite new to .htaccess file tweaking...

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago - 6 years 11 months ago #8 by Matias
The rule only makes redirects as non-caching, which basically is the same as using
RewriteCond %{HTTP_HOST} !^www\.
RewriteRule ^(.*)$ https://www.%{HTTP_HOST}/$1 [R=303,L]
 
RewriteRule (.*) - [E=Cache-Control:no-cache]

I added the second rule to the last line just to show how you can do it, it has nothing to do with the first question -- note that I also removed L (=load).
Last edit: 6 years 11 months ago by Matias.

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago - 6 years 11 months ago #9 by picht
OK, so i could use the 3 line you have written in a .htaccess file and that might work ?
Last edit: 6 years 11 months ago by picht.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.135 seconds