×
Kunena 5.1.6.1 Released - Security Release (09 Nov 2018)

The Kunena team has announce the arrival of Kunena 5.1.6 [K 5.1.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

K5.1.6.1 is a install update.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question Attachments upload not working... sometimes.

More
5 years 11 months ago #1 by sgabo
Hi Kunena fans,

I have a little problem with my forum. Before I installed Kunena 2.xxx doesn't worked the attachments upload. Said: can't write xy.jpg into kunena/media/.... directory.
I installed the Kunena 2.x and the problem is the same.

But! Some people can upload! There is some users who can upload pictures and other files without any problems. I tried to make categorys (system, explorers, etc.) but soemone have MAC OS other have Win7, some have Google Chrome some Firefox and by the virus scanner too (works under Win Defender and AVG too).

Have somebody any idea what the problem is? Some Java upgrade, or what?

Thank You very much!

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
5 years 11 months ago #2 by sozzled
Replied by sozzled on topic Attachments upload not working... sometimes.
If you get the message that you're getting, see Securing Kunena in the Wiki and make sure that all your folders have the correct permission settings.

Please Log in or Create an account to join the conversation.

More
5 years 11 months ago #3 by sgabo
Thanks for this info, but I think this isn't my solution.

Some users can upload. They have no problems. They are not administrators, they are simply users and the upload function works excellent on their computers.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
5 years 11 months ago #4 by sozzled
Replied by sozzled on topic Attachments upload not working... sometimes.
There must be hundreds topics on this forum going back over the past 4 years that relate to "some (or all) users not being able to upload attachments". The problems fall into several categories:

(1) People who have a bad Joomla setup or faulty Kunena installation
(2) People who have wrongly configured folder permissions or ownership
(3) People tinkering with Joomla ACL (and getting it wrong)
(4) People who added extra "goodies" that actually wreck Kunena and ultimately wreck their sites
(5) Peoples who use "cheap" and nasty web hosting services
(6) People who have changed the Kunena configuration settings without knowing what they're doing
(7) People who are attempting to upload a attachments with certain MIME types that they've told their site not to use.
(8) A software issue problem with Kunena (less than 1% of all cases fall into this category)

As you can see, most of these problems were caused by and were resolved by the people who ask these questions. We could ask you a few questions and to see which category your particular problem falls into but you could save yourself a lot of time if you read When all else fails, try this .

What we need to know are the answers to the following questions:

(1) Versions of Kunena, Joomla, PHP, Apache
(2) Folder permissions that you are using on all folders in your website
(3) Allowable file types (Global Configuration settings and Kunena settings)
(4) A complete inventory of all extra Joomla extensions on your website
(5) What changes you have made to Joomla ACL settings
(6) Can you reproduce your problem on a vanilla-flavoured Joomla site hosted on the same platform as your current (problem) site?
(7) Your Kunena configuration report
(8) The exact text of the error message that you are getting.

... or ...
... you could save yourself all this trouble and create a test site, as I recommended, and see if you have the same problems on that test site. If you do not have problems on your test site then compare what you did on your live site with what you've got on your test site. You will solve your problem a lot quicker that way. ;)

Please Log in or Create an account to join the conversation.

More
5 years 11 months ago #5 by sgabo
I found a houndred topics on the forum, but I don't find any solution for my problem. Before I opened this topic i read a lot of same problems, but really nothing.

1 - I don't installed anything. Only the new Kunena version of this website.
2 - folder permissions are ok. We tryed a lot of versions but nothing.
3 - I'm a normal user, I'm very contented with the funktions of this forum program so I don' tinkered it. The only one changes is: I disabled the new topic button in the css file.
4 - no
5 - no, this is a really good webhosting company and we had only this problem on the complete website.
6 - no. I wrote: I only disabled the "new topic" button.
7 - no
8 - I think no, but I don't found any problems... And help too...


My config:
Kunena version: 2.0.3
allowable filetiypes: jpg, jpeg, gif, png and at documents: zip,txt,doc,pdf,xl

Kunena - AlphaUserPoints Integration, Kunena - JomSocial Integration, Kunena - CommunityBuilder Integration, Kunena - Gravatar Integration, Kunena - UddeIM Integration, Kunena - Kunena Integration, Kunena - Joomla Integration, System - Kunena, System - Forum Protection Light

I don't made any changes. Really nothing because I1m a simple user and I'm very contented with the basic functions of Kunena

MY report: Kunena is up to date, My version is 2.0.3 The newest version is: 2.0.3 Date: 2012-11-24 (of courese this report is in hungarian language as the completly Forum)

In a red row: The copy was unsuccesfull
In awellow row: myphoto.jpg upload was unsuccesfull: the file transfer to this folder was not possible: /var/www/clients/client1/web12/web/media/kunena/attachments/64/myphoto.jpg
In a blue row: You comment is posted succesfull

And nothing else. By some peoples works this uploading fine, without any problems. In thel last two weeks we tra to find any problems, but nothing.

Thank you for your help.

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago #6 by Matias
Red message comes from Joomla, yellow one from Kunena. So it looks like Joomla fails to copy the file to the destination folder -- unfortunately it doesn't give the reason why it was so. In most cases the reason is wrong directory permissions, so you should do and check the above directory to see if the permissions are wrong (web server should be able to write).

Many people have this kind of issues after changing the server.
The following user(s) said Thank You: sgabo

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago #7 by sgabo
We checked the permissions again, they are okay.

If there are permissions problems, how can upload some peoples? There are some users who can upload and there are a lot who can't...

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago #8 by Matias
Unfortunately the error messages aren't always the best ones, but the key is in that error message. For some reason copying a file fails. File copy can only fail for a limited number of reasons, like permission issues or when directory or file doesn't exist.

Now we need to track down when the issue happens. Does it only happen for images or are other allowed extensions (zip, pdf etc) also affected? Does it only happen for some users and always those users? Finding the pattern probably gives a hint where to look into.

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago #9 by sgabo
If somebody can upload one time, he can upload always. The "can't" people are always the same.

I'm the admin, but I can't too upload. I tried to upload images or data files, the result is the same: no picture, no files in attachments. Who can upload, those people can upload anytime and without limit (the sizecorrections works excellent, etc.).

Thank You very much, that You try to help me. :) MY english is terrible, I hope You understand me. :) :cheer:

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.091 seconds