×
Kunena 5.1.5 Released - Security Release (Yesterday)

The Kunena team has announce the arrival of Kunena 5.1.5 [K 5.1.5] which is now available for download as a native Joomla extension for J! 3.8.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Solved 500 error when trying to upload image.

More
6 years 2 months ago - 6 years 2 months ago #1 by rsi
Hi, I am getting this error (Fatal Error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 14008 bytes) in components/com_kunena/lib/kunena.image.class.php on line 357).

I am using Kunena 2.0.1 on Joomla! 2.5.6.

I was trying to upload an image of 3166kB. I have 'Maximum Image File Size' set to 4000kB, which appears to be lower that what Kunena Config is telling me I can set it to (Maximum image file size allowed for upload. You cannot exceed the PHP upload limit of post_max_size: 8M & upload_max_filesize: 10M .)

I noticed this error also appering in the 1.7 support forum. In that forum there is mention of using ImageMagick instead of GD. Is this in the config somewhere, I can't find an opion that would choose between the two?
Last edit: 6 years 2 months ago by rsi. Reason: Updated to include image size when error appeared.

Please Log in or Create an account to join the conversation.

More
6 years 2 months ago - 6 years 2 months ago #2 by Jiminimonka
Hi rsi, thanks for your post.

Without a configuration report (see the posting guide at the top of this page) it is hard to work out what the problem is, but usually this error is because you have other Joomla modules and plugins that are using up your allocated memory. Increasing the memory limit on your server via the hosts, or disabling other Joomla modules might be the solution.

Please read the FAQ.
Only one question per topic.
Search before you ask a question.
Last edit: 6 years 2 months ago by Jiminimonka.

Please Log in or Create an account to join the conversation.

More
6 years 2 months ago #3 by rsi
Hi thanks for taking a look at this, please see my configuration report below. I have very few if any extra Joomla modules loaded. This is a fresh Joomla installation & the only addition to Joomla is Kunena.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 40 seconds | Max execution memory: 32M | Max file upload: 10M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : whyallanudists7 | author: RSI Computing | version: 1.0 | creationdate: 2012-06-27

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 2.0.1 | creationdate: 2012-07-07

Kunena version detailed: Kunena 2.0.1 | 2012-07-07 [ Balozi ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
6 years 2 months ago #4 by 810
Hi,
Please increase Max execution memory: to 64m


regards 810
The following user(s) said Thank You: rsi

Please Log in or Create an account to join the conversation.

More
6 years 2 months ago #5 by rsi
Hi, increasing the Max execution memory: to 64m (as requested) has resolved the problem.

Thank you very much for your help.

Regards, rsi.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.142 seconds