×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question Site getting duplicate page warnings in Google webmastertools - XMAP-related

More
8 years 3 months ago - 8 years 3 months ago #1 by yaksushi
Google webmaster tools is seeing duplicate pages on my site.

Example url:

www.yakangler.com/forum/16-fresh-water-k...11?limit=10&start=10

www.yakangler.com/forum/index/16-fresh-w...11?limit=10&start=10

I think it has to do with my xmap sitemap, which displays both the urls with "index" and without it. Anyone know how I can solve this issue? I didn't see any parameters in the xmap component itself that would allow a filter.

Here is my site map: www.yakangler.com/sitemap.xml
Last edit: 8 years 3 months ago by yaksushi.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #2 by Matias
XMap shouldn't display topics with index, only without it.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago - 8 years 3 months ago #3 by yaksushi

Matias wrote: XMap shouldn't display topics with index, only without it.


Yes I figured as much as I've never had this issue, until I had to upgrade the site to Joomla 2.5. Who makes the xmap plugin? The component itself doesn't display all the posts in kunena without the plugin.

Anyone else seeing this?

I'm using Joomla 2.5.4, Kunena 1.7.2, Xmap 2.2.1, Xmap Kunena plugin 2.2.1

also I reported my post because I mistakenly created it in the wrong forum.
Last edit: 8 years 3 months ago by yaksushi.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #4 by Matias
Hmm.. I fixed XMap plugin for Joomla! 1.5 a while ago, but didn't touch J!2.5 version (just asked them to check my changes and apply those into J!2.5 version). Maybe the fixes never got in?

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago - 8 years 3 months ago #5 by yaksushi
is it a simple change? maybe i can update the plugin myself? what did you do?
Last edit: 8 years 3 months ago by yaksushi.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #6 by Matias
I basically rewrote most of the plugin. :) The Kunena specific code should be almost identical in both versions, though.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago - 8 years 3 months ago #7 by yaksushi
I just used beyond compare on both com_kunena.php files and there is a lot different! I can see there is a bunch of what looks like the new acl stuff in the new version... lol This is well above my head. :blink:

what does kunena.org use for their sitemap?
Last edit: 8 years 3 months ago by yaksushi.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #8 by sozzled
*** Off-topic ***

yaksushi wrote: What does kunena.org use for their sitemap?

Nothing special here ... just standard Joomla core. B)

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #9 by yaksushi
Matias any chance you will update the plugin? I've posted in the xmap forums and used the contact forums without success. :(

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #10 by Matias
I'm a bit overwhelmed of all the work I need to do. Cannot promise anything as I'm not able to deliver everything what I've promised this far.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.116 seconds