×
Blue Eagle 1.5.2 Released (11 Dec 2018)

The Kunena team has announce the arrival of Kunena Blue Eagle 1.5.2 which is now available for download as a native Joomla extension for Kunena 5.1. This version addresses most of the issues that were discovered in K 1.5.1 and issues discovered during the development stages of K 1.5.2.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Solved error create table agora_posts

More
6 years 6 months ago - 6 years 6 months ago #1 by KleinMeyl
I want to reinstall a backup made with Ackeeba backup, but I get the following error when I try to import the database


Fout in regel 21: CREATE TABLE `#__agora_posts` ( `id` int(10) unsigned NOT NULL auto_increment, `poster` varchar(200) default NULL, `poster_id` int(10) unsigned default '1', `poster_ip` varchar(15) default NUL ... MySQL: MySQL query failed with error 1214 (The used table type doesn't support FULLTEXT indexes). The query was:CREATE TABLE `jos_agora_posts` ( `id` int(10) unsigned NOT NULL auto_increment, `poster` varchar(200) default NULL, `poster_id` int(10) unsigned default '1', `poster_ip` varchar(15) default NULL, `poster_email` varchar(50) default NULL, `message` text, `hide_smilies` tinyint(1) default '0', `posted` int(10) unsigned default '0', `edited` int(10) unsigned default NULL, `edited_by` varchar(200) default NULL, `topic_id` int(10) unsigned default '0', `userimage` varchar(144) NOT NULL, PRIMARY KEY (`id`), KEY `jos_agora_posts_topic_id_idx` (`topic_id`), KEY `jos_agora_posts_multi_idx` (`poster_id`,`topic_id`), FULLTEXT KEY `message_fulltext_search` (`message`) ) AUTO_INCREMENT=3 DEFAULT CHARSET=utf8


Does anyone know what this means and how it can be solved ?
Thanks
Isabel



Configuration settings copied from Kunena in back-end of thes site:


This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Enabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 2M

This message contains confidential information

Joomla default template details : isabeldesmet_reetzweters | author: Isabel De Smet | version: 1.0.0 | creationdate: 22/02/2010

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.6.3 | creationdate: 2011-01-31

Kunena version detailled: Installed version: 1.6.3 | Build: 4344 | Version name: Parlare | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Disabled or not installed | Jomsocial: Disabled or not installed | UddeIm: Disabled or not installed

Third-party SEF components: sh404sef: Installed (Version : 2.2.2.941) | ARTIO JoomSEF: Disabled or not installed | AceSEF: Disabled or not installed

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Enabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Disabled or not installed | My Kunena Forum Menu: Disabled or not installed | My Kunena Forum Posts: Disabled or not installed

Modules: Kunena Latest: Disabled or not installed | Kunena Stats: Disabled or not installed | Kunena Login: Disabled or not installed

Last edit: 6 years 6 months ago by KleinMeyl.

Please Log in or Create an account to join the conversation.

More
6 years 6 months ago #2 by Matias
This was not Kunena related issue, but I think I know the solution: you need to remove existing tables before restoring backup.

Please Log in or Create an account to join the conversation.

More
6 years 6 months ago #3 by KleinMeyl
I had created a new empty database, so this cannot be the problem

Please Log in or Create an account to join the conversation.

More
6 years 6 months ago #4 by Matias
Sorry, I missed this:

MySQL: MySQL query failed with error 1214 (The used table type doesn't support FULLTEXT indexes)

Looks like Agora only works with MyISAM engine, which isn't supported in MySQL 5.5 anymore. If you have older version of MySQL, you can fix this issue by changing default engine from InnoDB into MyISAM (in my.cfg). There should be docs on how to do that all over the internet.

Please Log in or Create an account to join the conversation.

More
6 years 6 months ago #5 by KleinMeyl
Ok, i'll check that. But I am wondering, AGORA isn't that the older version of Kunena ? Can't these tables be deleted ? Are the still used by Kunena ?

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
6 years 6 months ago - 6 years 6 months ago #6 by sozzled
Replied by sozzled on topic error create table agora_posts
Agora is a totally different product to Kunena. Agora was developed by a different team to Kunena. There are no xxx_agora_* tables used by Kunena, just like there are no xxx_kunena_* tables used by Agora. You can, if you want, install Agora as the same time as Kunena but they operate independently of one another.

If you have a problem with Agora, I would advise you to ask the people who wrote it; got to www.jvitals.com/support/support-forum/de...oard.html?view=board

Further, K 1.6.3 was retired a long time ago and we don't support it any more. I advise you to upgrade to K 1.7.2 as soon as possible. You should also update you version of Joomla, too.
Last edit: 6 years 6 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
6 years 6 months ago #7 by KleinMeyl
I have updated this site beginning 2011, I transferred the forum from AGora to Kunena...
At the moment I do not use Agora anymore, only Kunena.

If you say that Kunena uses nothing from the Agora, then I can delete these tables ! Thanks for the info!

You have a point concerning the update, however the budget here is not that high... I'm afraid an update every 2 years has to do. Also from joomla 1.5 to 1.7 is a migration... more time... more budget

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
6 years 6 months ago #8 by sozzled
Replied by sozzled on topic error create table agora_posts
(1) Yes, you can drop the Agora tables if you do not need them.

(2) Upgrading from K 1.6.3 to K 1.7.2 will probably take you about 2 minutes. It's free, it's easy to do. The point is, if you do not upgrade to K 1.7.2 we may not be able to help you in future. In the time since K 1.6.3 was released (nearly 1½ years ago) about 300 problems have been fixed and K 1.7.2 is more reliable and better to use.

(3) Updating from J! 1.5.22 to J! 1.5.26 is free and it is not the same as migrating from J! 1.5 to J! 2.5.

(4) The version of sh404SEF is also old, outdated and questionable in terms of its value. Chances are you don't need it anyway. Running websites with sh404sef can actually slow down the site's performance.

Please Log in or Create an account to join the conversation.

More
6 years 6 months ago #9 by KleinMeyl
Thank you for the advices! Indeed SH404SEF causes me a lot of troubles...
I'll follow you adives!

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.124 seconds