×
Kunena 5.1.6.1 Released - Security Release (09 Nov 2018)

The Kunena team has announce the arrival of Kunena 5.1.6 [K 5.1.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

K5.1.6.1 is a install update.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Solved 404/message not found when subject contains a slash

More
6 years 5 months ago #1 by kwally
I am running Kunena 1.7.2 on a Joomla 2.5.4 platform.
The Kunena and Joomla SEO-features are enabled. No other SEO plugin is used.
For some historical reasons the user reaches older messages over the address
component/option,com_kunena/Itemid,84/catid,$catid/func,view/id,xxxx

This works good and the message is displayed under an URL like
forum/category/xxxx-subject.html

But there is a problem, when the subject contains a slash. Example: Subject = "Kunena/Fireboard" results in
forum/category/xxxx-kunena/fireboard.html
which produces a 404/not found-error. If I change the URL manually into
forum/category/xxxx-kunena-fireboard.html
the correct message is displayed.

Maybe I can solve the problem by replacing all slashes in all subjects. But I hope there is a more elegant way (and it would be a lot of work).
Thanks
K.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
6 years 5 months ago #2 by sozzled

kwally wrote: I am running Kunena 1.7.2 on a Joomla 2.5.4 platform.
The Kunena and Joomla SEO-features are enabled. No other SEO plugin is used.
For some historical reasons the user reaches older messages over the address
component/option,com_kunena/Itemid,84/catid,$catid/func,view/id,xxxx

The URL form you're using does not correlate with the information you gave earlier.

As your post at www.kunena.org here shows, your subject title contains a slash and there is no HTTP 404 error as the result. Therefore, the only logical conclusion follows that the problem lies with your Joomla site setup.

We encourage people, before they post in the K 1.7 Support category to read the FAQs first and, in particular, to take note of the guide to posting questions if you want our help quickly. We should not have to continually remind people to look at the posting guide (printed at the top of this page) and ask for people to give us all the necessary information that may allow us to understand why some people have more problems using Kunena than others.

Thank you for reading this. Your assistance in providing us with a copy of your configuration report would be of great help.

Please Log in or Create an account to join the conversation.

More
6 years 5 months ago #3 by kwally
Subjects with a slash can be created and read as normal. I had no problem with this and everything works fine.
The problem appears only, when a user comes with this old URL (component/option,com_kunena...) and visit a subject with a slash.
"Somebody" replaced the slash in this post's subject by a minus to form the URL. And this does not happen on my site. I thought, this transformation is done by Kunena.

I read the FAQ and guidelines before I posted, I didn't find my problem in the FAQ and I think, I gave all information for a first analysis. I am sorry, when I missed some.

In the meantime, I found a way to replace quickly the slashes in the old posts. For me this workaround is good enough.
Thanks!

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
6 years 5 months ago - 6 years 5 months ago #4 by sozzled
*** Solution/workaround method unknown but assumed to have been satisfactorily resolved ***

We assume, from what has been written, that the solution does not involve Kunena. We are pleased that you found something that works for you. :)

*** Topic relocated to Miscellaneous, off-topic and general Joomla category category ***
Last edit: 6 years 5 months ago by sozzled.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.084 seconds