×
Blue Eagle 1.5.2 Released (Yesterday)

The Kunena team has announce the arrival of Kunena Blue Eagle 1.5.2 which is now available for download as a native Joomla extension for Kunena 5.1. This version addresses most of the issues that were discovered in K 1.5.1 and issues discovered during the development stages of K 1.5.2.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question [FIXED] Facing error "var siteurl="

More
6 years 8 months ago - 6 years 8 months ago #1 by kj2010
Hello my dear Kunena staff,

I use Kunena since a long time but recently i noticed a strange error.

Firstly i thought it is the joomla template but i tested it with other templates and it is the same. Actually i use Purity II

I will try to explain as good as i can and i hope you can help me out.

I use:
- Joomla 2.5.4
- Jomsocial 2.6
- Kunena Forum 1.7.2

When i open a topic in my forum for example with text like:
"text $0.0365" then i get the following message at the top of my site:



This line at the top does not appear when i add a free space between the $ and the number, like this:
"text $ 0.0365"

You can see it by yourself in this thread:
>>> www.ptcsociety.com/component/kunena/52-c...lk/997-test?Itemid=0


I deeply hope you can help me out here because i stuck totally and don't know why the forum is interpreting a dollar amount in this way.
I actually believe it must the forum because other templates have the same issue

Sincerely,
Martin
Attachments:
Last edit: 6 years 8 months ago by kj2010.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
6 years 8 months ago #2 by sozzled
Replied by sozzled on topic [FIXED] Facing error "var siteurl="
Yes, I see the message if you use the link that you gave in your message.

I do not see the error if you use the menu item to access your forum.

Please read the posting guide printed at the top of this page. We may be able to assist you better if you include the information asked for in the posting guide (see where the animated "hand" icon is pointing to).

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #3 by kj2010
Hello,
thanks for the reply.

I do not see the error if you use the menu item to access your forum.

That's correct.
This error appears only on the page to the correspondig thread.
Means: This error appears only on pages where $0.0365 or any other "dollar number" exists in combination with text.
This error is not visible on other pages on the site or forum.


Below my confidential information (configuration report).

No hurry! I have time.
I need to inform you as well that it can be that my site is not accessible within the next 72 hours because we're moving to a dedicated server.

Regards,
Martin

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Enabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 1600 seconds | Max execution memory: 1190M | Max file upload: 528M

Kunena menu details:
Warning: Spoiler! [ Click to expand ]

Joomla default template details : ja_purity_ii | author: JoomlArt.com | version: 2.5.0 | creationdate: February 2012

Kunena default template details : Example Template | author: Kunena Team | version: 1.7.2 | creationdate: 2012-01-31

Kunena version detailled: Installed version: 1.7.2 | Build: 5215 | Version name: Omega | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: AlphaUserPoints 1.7.2 | Jomsocial 2.6.0

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled | Kunena Search 1.7.2

Modules: Kunena Latest 1.7.1 | Kunena Stats 1.7.1 | Kunena Search 1.7.2

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
6 years 8 months ago - 6 years 8 months ago #4 by sozzled
Replied by sozzled on topic [FIXED] Facing error "var siteurl="
Thank you for your configuration report.

First of all this problem you are having is not caused by Kunena. I know that is a true statement because I tried the same text on this site here as well as on a test site of my own where I have J! 2.5.4 installed.

A similar case occurred a while ago (under different circumstances) here . I don't think we found the cause of the problem in that case although the finger of suspicion falls on either the probability that a content plugin or the webhosting provider may be responsible here.

There is one guaranteed way to verify that, in your case, you can have confidence in running Kunena on your webhost: read and apply my suggestion called When all else fails, try this . That's about the only helpful suggestion that I can make in your case.

I think that you will find my suggestion will work for you. Please let us know how you go.
Last edit: 6 years 8 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #5 by kj2010
...no, i have to thank you sozzled :)
Thanks for checking a bit deeper and for testing it. Much appraciated!

Before i tell you my solution...
You are totally right that many errors and issues are probably caused by plugins or 3rd party extensions. That's the reason why i check everything 3times, 30times, 300times after enabling a new plg.
But here in this case i never thought about to test special strings or characters like "$0.03" or "$ 0.03" or "text $0.03"
This would never end. What's about chinese or hebrew characters?
I hope you can follow what i mean. ;)

Well, your suggestion you gave is indeed the best way to locate an issue and to find out which plg/mod causes an error. No doubts.
But no offense, i took the other way. ;)

The last think i did was gZip/CSS optimisation with jFinalizer.
I disabled it, and ...Abracadabra! ...error gone!

So, this had indeed nothing to do with your Kunena (one of the best, widely used and well coded comps).
It's always the same: Things like SEF, SEO, gZip/CSS/JS optimisation "can" cause a lot of new issues while other things were fixed.

Ok, this has been fixed here. I have no problem to keep jFinalizer disabled. I can do everything manually by my own what this tool does, but it was a bit more comfortable to let it do the things.

Sorry, for the longer reply, i'm a bit talkative today :)

Happy easter weekend and thanks again!

Martin

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.141 seconds