×
Kunena 5.1.7 Released - Security Release (20 Nov 2018)

The Kunena team has announce the arrival of Kunena 5.1.7 [K 5.1.7] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Important Warning: Invalid argument supplied for foreach()....

  • Nihil
  • Topic Author
  • Visitor
6 years 10 months ago - 6 years 10 months ago #1 by Nihil
Warning: Invalid argument supplied for foreach() in /home/gotrus1/public_html/libraries/joomla/database/database/mysql.php on line 368

My users are seeing this error at the top of the page on the forum since i did the latest upgrade.

Any theories?

My google fu is failing me on this.

This message contains confidential information

Database collation check:

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 10M

Kunena menu details:
Warning: Spoiler! [ Click to expand ]

Joomla default template details : gored_ultra_lernvid.com-j1.6 | author: Juergen Koller | version: 1.0 | creationdate: Apr 2011

Kunena default template details : Aphotic II | author: snilloconator | version: 1.6.3 | creationdate: 2010-12-30

Kunena version detailled: Installed version: 1.7.2 | Build: 5215 | Version name: Omega | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: AlphaUserPoints 1.7.0 | UddeIm 2.5

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled | Kunena Discuss 1.7.1

Modules: None

Last edit: 6 years 10 months ago by . Reason: Reveal K 1.7 configuration report in message

Please Log in or Create an account to join the conversation.

  • Nihil
  • Topic Author
  • Visitor
6 years 10 months ago - 6 years 10 months ago #2 by Nihil
i found the file in question. It's the joomla database driver. i went to my site's database and ran: analyze, repair and optimize. So far that seems to have fixed it.

--

Nope, it's back. It appears intermittently at the top of threads. Very strange.
Last edit: 6 years 10 months ago by Nihil.

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago #3 by xillibit
Hello,

Are-you able to see all details for topics (threads) : subject, users... ?

Do you have tried with default Kunena template ?

Do you have thought to update AUP to 1.7.1 and UddeIm to 2.6 ?

I don't provide support by PM, because this can be useful for someone else.
The following user(s) said Thank You: Nihil

Please Log in or Create an account to join the conversation.

  • Nihil
  • Topic Author
  • Visitor
6 years 10 months ago #4 by Nihil
Yes.

No.

No. But i just upgraded both.

The error has not appeared for a while now. Seems to be a fluke.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.121 seconds