×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question SEO / SEF problem with Kunena

More
8 years 8 months ago - 8 years 8 months ago #1 by ottis
I have problem in my forum ( www.nettisairaala.net/forum ), kunena wont display links correcty.
For example:
www.nettisairaala.net/component/kunena/?func=showcat&catid=2
when it should be:
www.nettisairaala.net/forum/?func=showcat&catid=2

I have tried to enable/disable the SEO setting in kunena configuration.
I have cleared Joomla's cache.

The problem is related to url rewriting, but the problem is only with Kunena component.
I have web.config file in Jooma's directory.

My settings for Kunena are:
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 32M | Max file upload: 8M

This message contains confidential information

Joomla default template details : nettisairaala | author: O | version: 1.7.0 | creationdate: 25 November 2009

Kunena default template details : Nettisairaala | author: Kunena Team | version: 1.7.0 | creationdate: 2011-08-29

Kunena version detailled: Installed version: 1.7.1 | Build: 5162 | Version name: UnderUret | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: Kunena Latest 1.7.1

Last edit: 8 years 8 months ago by ottis.

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago #2 by 810
Hi
enable sef, on the kunena settings.

regards 810

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago #3 by ottis

810 wrote: Hi
enable sef, on the kunena settings.

regards 810


Hello

I did, but it didnt solve problem.
SEF in kunena settings is now enabled.

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago - 8 years 8 months ago #4 by 810
yes i see.

What kind off sef component do you use. Or are you using the joomla sef
Last edit: 8 years 8 months ago by 810.

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago #5 by ottis
I am using Joomla sef.

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago - 8 years 8 months ago #6 by 810
Ok try this:
1) delete kunenmenu
2) Delete Forum (mainmenu)
3) Clean trash manager
4) Go to kunena
5) click on create menu
6) Check if its good again
Last edit: 8 years 8 months ago by 810.

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago #7 by sozzled
This is not a Kunena issue. This is a Joomla issue.

Please read Search Engine Optimisation (SEO) in the Wiki. Also read the sticky topics in this category .

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago #8 by 810
Wiki is only for apache. Not for IIS.

He has no menu's. So i think thats the problem.

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago - 8 years 8 months ago #9 by sozzled
In the "further reading" section at the end of the Wiki article are items that help those who use IIS servers. :)

Even so, the issues are still the same. You need to set up the Joomla menu items properly so that SEO works. There is information in the FAQs page on how to setup the Kunena menu in a "standard" way.
Last edit: 8 years 8 months ago by sozzled.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.159 seconds