×
Kunena 5.2.8 released and Blue eagle 1.6.7 released (02 Jan 2022)

The Kunena team has announce the arrival of Kunena 5.2.8 [K 5.2.8] which is now available for download as a native Joomla extension for J! 3.10/3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of previous version of K5.2.

If you are using blue template you need to update to 1.6.7 version to ensure to have a compatible version with K5.2.8.

Important note: (07 Jan 2022) If you have created a Kunena custom.css, create a backup of it. Due to an error, this file will be deleted during an upgrade.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question SEO / SEF problem with Kunena

More
10 years 2 weeks ago - 10 years 2 weeks ago #1 by ottis
I have problem in my forum ( www.nettisairaala.net/forum ), kunena wont display links correcty.
For example:
www.nettisairaala.net/component/kunena/?func=showcat&catid=2
when it should be:
www.nettisairaala.net/forum/?func=showcat&catid=2

I have tried to enable/disable the SEO setting in kunena configuration.
I have cleared Joomla's cache.

The problem is related to url rewriting, but the problem is only with Kunena component.
I have web.config file in Jooma's directory.

My settings for Kunena are:
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 32M | Max file upload: 8M

This message contains confidential information

Joomla default template details : nettisairaala | author: O | version: 1.7.0 | creationdate: 25 November 2009

Kunena default template details : Nettisairaala | author: Kunena Team | version: 1.7.0 | creationdate: 2011-08-29

Kunena version detailled: Installed version: 1.7.1 | Build: 5162 | Version name: UnderUret | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: Kunena Latest 1.7.1

Last edit: 10 years 2 weeks ago by ottis.

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #2 by 810
Hi
enable sef, on the kunena settings.

regards 810

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #3 by ottis

810 wrote: Hi
enable sef, on the kunena settings.

regards 810


Hello

I did, but it didnt solve problem.
SEF in kunena settings is now enabled.

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago - 10 years 2 weeks ago #4 by 810
yes i see.

What kind off sef component do you use. Or are you using the joomla sef
Last edit: 10 years 2 weeks ago by 810.

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #5 by ottis
I am using Joomla sef.

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago - 10 years 2 weeks ago #6 by 810
Ok try this:
1) delete kunenmenu
2) Delete Forum (mainmenu)
3) Clean trash manager
4) Go to kunena
5) click on create menu
6) Check if its good again
Last edit: 10 years 2 weeks ago by 810.

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #7 by sozzled
This is not a Kunena issue. This is a Joomla issue.

Please read Search Engine Optimisation (SEO) in the Wiki. Also read the sticky topics in this category .

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #8 by 810
Wiki is only for apache. Not for IIS.

He has no menu's. So i think thats the problem.

Please Log in or Create an account to join the conversation.

More
10 years 1 week ago - 10 years 1 week ago #9 by sozzled
In the "further reading" section at the end of the Wiki article are items that help those who use IIS servers. :)

Even so, the issues are still the same. You need to set up the Joomla menu items properly so that SEO works. There is information in the FAQs page on how to setup the Kunena menu in a "standard" way.
Last edit: 10 years 1 week ago by sozzled.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.154 seconds