×
Kunena 5.1.7 Released - Security Release (20 Nov 2018)

The Kunena team has announce the arrival of Kunena 5.1.7 [K 5.1.7] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question Kunena menu and Joomla alias

More
7 years 3 weeks ago - 7 years 3 weeks ago #1 by Lysdexic
Hi,

I've tried to get my head around this and, (despite reading everything on this forum about it), I still can't figure out how to make my forum function (fully) from a joomla menu in the 'left' position.

So far, I have the forum activated from a menu item in the Joomla 'main menu'.

This opens the forum in the main body of the page and has the Kunena menu positioned in the 'Left' position.

All the Left position menu items work properly, and the forum remains within the main area.
However, if I select a topic from the main forum, it gets rid of the left menu and occupies the whole screen width.

I can't figure out how to fix this - it seems to be something to do with the alias parameter, but I'm too damn thick to work it out.

Could someone give me a step by step solution to this please?, (very small steps if you can).

Joomla 1.5.23
Kunena 1.7
Last edit: 7 years 3 weeks ago by Lysdexic. Reason: Forgot to add version info

Please Log in or Create an account to join the conversation.

More
7 years 3 weeks ago #2 by Matias
Replied by Matias on topic Kunena menu and Joomla alias
You need to enable your menu module in all menu items under Kunena Menu (or add them into your own).

Please Log in or Create an account to join the conversation.

More
7 years 3 weeks ago #3 by Lysdexic
Hi Matais,

Thanks for the quick reply.

I had already done what you have advised - no luck.

So, I decided to begin again. I removed the Kunena Menu, cleared the menu trash and then re-created the Kunena Menu from the component's control panel.

I then went into the module manager and selected the new Kunena menu.

I changed the position to 'Left' and highlighted all the menu links in the Kunena Menu and also the Forum link in my Main Menu, (as you advised).

I saved everything and went to the front end of the site.

Amazingly - everything works perfectly!

I've no idea what I did to screw it up on the previous attempts - but its working now and I'm a very happy bunny.

Thanks for the help B)

Lysdexic

Please Log in or Create an account to join the conversation.

More
7 years 3 weeks ago #4 by Matias
Replied by Matias on topic Kunena menu and Joomla alias
One small setting can mean a lot in Joomla (and elsewhere, too). But I'm glad that recreating menus worked for you.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.818 seconds