×
Kunena 5.1.7 Released - Security Release (20 Nov 2018)

The Kunena team has announce the arrival of Kunena 5.1.7 [K 5.1.7] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question [K1.7] [J1.5.23] Avatar & Attachment upload failed

More
7 years 1 month ago - 7 years 1 month ago #1 by mik0392
Hi,

I have just installed Kunena on my site, and im getting this error when I try and upload an avatar or attachment to the website using Kunena as my profile and avatar system.

Here is the error message when I try and upload the sample image that comes with Windows, as an attachment to a simple forum post.

Failed to upload file 'Winter.jpg': Image MIME type () is not allowed (jpg,jpeg,gif,png).

Your message has been successfully posted.


And the same for uploading an avatar

Failed to upload file 'Winter.jpg': Image MIME type () is not allowed (jpg,jpeg,gif,png).

Your profile has been saved.


I have checked File/Folder permissions on the upload directories and all are on 7-5-5, is this correct?


Here's my System Info

PHP Built on: Linux jumbuck.netports-servers.com.au 2.6.18-238.9.1.el5PAE #1 SMP Tue Apr 12 18:52:55 EDT 2011 i686
Database Version: 5.0.92-community
Database Collation: utf8_general_ci
PHP Version: 5.2.9
Web Server: Apache
Web Server to PHP interface: cgi
Joomla! Version: Joomla! 1.5.23 Stable [ senu takaa ama baji ] 04-March-2011 18:00 GMT
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.106 Safari/535.2

Thanks.

Edit;

I forgot to mention that I can upload the same image to other places in the site (image gallery), as well as attach it to posts using my old Ninjaboard forum.

It seems it is just Kunena giving me this error.
Last edit: 7 years 1 month ago by mik0392.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 1 month ago #2 by sozzled
You might find it helpful to read What information should I include when I ask for help (including how to post my configuration report)? and we might be able to get a bit further in helping you if we have that information. Thanks.

For information about file/folder permissions settings, see Securing Kunena .

Sounds to me like you've changed some standard configuration setting somewhere and that's what is preventing Kunena accepting certain MIME types.

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago - 7 years 1 month ago #3 by mik0392
Sorry, forgot the config report.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 64M | Max file upload: 64M

This message contains confidential information

Joomla default template details : rt_zephyr_j15 | author: RocketTheme, LLC | version: 1.5.2 | creationdate: November 16, 2010

Kunena default template details : nts_kdark | author: 9ThemeStore | version: 1.7.0 | creationdate: 2011-05-07

Kunena version detailled: Installed version: 1.7.0 | Build: 5135 | Version name: Tale | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: CommunityBuilder 1.4

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Enabled | System - Mootools12: Disabled

Modules: None


I used the default MIME types set my Kunena, which did not work. Then copied the ones in the Global config, which I knew worked, because Ninjaboard uses those MIME types when uploading attachments or avatars. and still did not work on Kunena.

Edit:

If I disable MIME check, I get this error message:

JFile::copy: Cannot find or read file: '/tmp/phpl2I33U'
Failed to upload file 'Winter.jpg': Could not move file into /home/xxxxxxxx/public_html/media/kunena/avatars/users/Winter.jpg.

Last edit: 7 years 1 month ago by mik0392.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 1 month ago #4 by sozzled
Thank you for your configuration report. Your Kunena configuration report does not show that you allow the MIMEtype "image/jpg".

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #5 by mik0392
Quite right. I put that back in the config, and I still could not upload.

I have tried png and gif, as well as other types of document file types for attachments aswell. None of them work.

I keep getting the MIME error, or this error when MIME check is disabled.

JFile::copy: Cannot find or read file: '/tmp/phpwxZ3j4'
Failed to upload file 'avatar64.png': Could not move file into /home/xxxx/public_html/media/kunena/avatars/users/avatar64.png.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 1 month ago #6 by sozzled
It seems like the permissions on your /tmp are not correct. When I wrote earlier that you should read Securing Kunena , those permissions should be applied to all folders and files in your site.

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #7 by mik0392
Hi Sozzled.

I can ensure you that all files and folders, especially tmp and media/kunena have the 755 permissions.

I am still unable to upload any files with these permissions.

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #8 by mik0392
I managed to get these errors to appear for a slight second, and got a printscreen. Hope this helps.


Attachments:

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
7 years 1 month ago - 7 years 1 month ago #9 by sozzled
Thanks for that information. A quick search of Google helps to understand the cause and possible ways to overcome the "open_basedir restriction in effect. File... is not within the allowed path(s)" warning message.

You've probably set the open_basedir directive somewhere. That restricts PHP access to certain directories. Check php.ini and your Apache config files (http.conf, .htaccess, etc). One possibility might be to replace any custom .htaccess file that you might have created with the standard Joomla version (see Search Engine Optimisation (SEO) for tips on how to do that.
Last edit: 7 years 1 month ago by sozzled.

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #10 by mik0392
Hi Sozzled.

Thanks for that.

I found this in my php.ini

open_basedir=/home/xxxxxxx/public_html


So I removed it and can now upload files and avatars without any issues.

Thanks.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.132 seconds