×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Question Cannot view topics

More
9 years 5 months ago #1 by oorzaak
Cannot view topics was created by oorzaak
Hi there,

I'm working on a site which features Kunena 1.5.11. This site was not built by me, I'm only adding the finishing touches. I know I should upgrade Kunena but at the moment I have an urgent issue which I would like to solve before undertaking any other actions.

I cannot view any topics anymore. This occurred after I was working in the back office to solve some other user requests. What I can view:
- the "latest" modules show the latest entries correctly;
- the forum index is shown correctly
- categories are shown correctly

It is just when clicking on a topic that the screen goes entirely blank. I.e. when in the url the parameter func=view occurs.

Hope someone can help me on this one?

Frits

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #2 by xillibit
Replied by xillibit on topic Re: Cannot view topics

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #3 by oorzaak
Replied by oorzaak on topic Re: Cannot view topics
Hi, thanks for your help. However, I'm still stuck:

I cannot view any error reports. When switched to Joomla error reports, I get these messages on screen. I get them on any page of the site, except when I click to view a topic page - which is the issue I'm dealing with. The screen then gets totally blank, no site and no messages at all.

Also the Apache error log doesn't show any entries that might be related to this problem - that is, I see no events of which the date/time corresponds with the moment of clicking on a topic page.

Then I tried to upgrade from 1.5.11 to 1.5.14. This doesn't work because I get this message:

XML Parsing Error at 3:84. Error 9: Invalid character

I re-downloaded the 1.5.14 package several times, in all .zip, .tar and .tar.gz variations. All of them give the same error.

Prior to upgrading I upgraded the Joomla core installation from 1.5.20 to 1.5.23. For some reason the 20 to 23 patch did not work either, due to a missing XML file. I ended up using the 22 to 23 patch. Could this have any influence on the upgrading process of Kunena?

Oh, as I'm testing all upgrades on a local (MAMP) copy of the site I gave it a try to upgrade to 1.6.3. This ended up in a real mess of error reports so I threw away this test.

I hope someone has a suggestion...

Cheers, Frits

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago - 9 years 5 months ago #4 by xillibit
Replied by xillibit on topic Re: Cannot view topics
What is the reason to still using k1.5 serie ?

The problem in xml file under k1.5.14 is described here : www.kunena.org/forum/134-k-15-installati...it=10&start=10#93581

To upgrade Joomla!, the patch package need to be uncompressed and copied manually on yout system, it will be very beautiful if you had just to use joomla extensions manager to install the joomla patch :)

I don't provide support by PM, because this can be useful for someone else.
Last edit: 9 years 5 months ago by xillibit.

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #5 by oorzaak
Replied by oorzaak on topic Re: Cannot view topics

xillibit wrote: What is the reason to still using k1.5 serie ?

I just thought it would be safer to make a small step at a time. Also, Kunena is integrated with JomSocial at some points, like user management. I can imagine a big upgrade could cause trouble with this connection.

xillibit wrote: The problem in xml file under k1.5.14 is described here : www.kunena.org/forum/134-k-15-installati...it=10&start=10#93581

I'll take a look at it right away!

xillibit wrote: To upgrade Joomla!, the patch package need to be uncompressed and copied manually on yout system, it will be very beautiful if you had just to use joomla extensions manager to install the joomla patch :)

I have my own (virtual) server which has Installatron on it, quite handy for upgrading about 20 sites at one time (that's the current number of sites on it) . This particular site however is not on my server so I find myself improvising bit.

Thanks again for your help,

Frits

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #6 by oorzaak
Replied by oorzaak on topic Re: Cannot view topics

xillibit wrote: The problem in xml file under k1.5.14 is described here : www.kunena.org/forum/134-k-15-installati...it=10&start=10#93581

It helped, I have k1.5.14 now running. Unfortunately it doesn't solve the blank page issue. Maybe I should try to rebuild the site locally and rather than copying it. And then import the database.

Frits

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #7 by xillibit
Replied by xillibit on topic Re: Cannot view topics

oorzaak wrote:

xillibit wrote: What is the reason to still using k1.5 serie ?

I just thought it would be safer to make a small step at a time. Also, Kunena is integrated with JomSocial at some points, like user management. I can imagine a big upgrade could cause trouble with this connection.

Frits

Jomsocial integration can be disabled and Kunena can manage himself the users

I advise you to upgrade to k1.6.3 because it should solve your issue

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #8 by oorzaak
Replied by oorzaak on topic Re: Cannot view topics

xillibit wrote: Jomsocial integration can be disabled and Kunena can manage himself the users

Ok but the people who set up the site must have had a reason to integrate them. Can I re-establish the integration after upgrading both Kunena and JomSocial? The point is, I do have experience with Joomla in general but not that much with these two components.

Frits

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #9 by xillibit
Replied by xillibit on topic Re: Cannot view topics
yes, after upgrade you can re-establish integration if you want

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #10 by oorzaak
Replied by oorzaak on topic Re: Cannot view topics
Thanks. I did some testing on a local copy of the site, and I installed k1.6.3. I got this message:

Fatal error: Cannot redeclare class smile in /Applications/MAMP/htdocs/test/components/com_kunena/template/default/smile.class.php on line 31


I assume this is due to the fact that I need a k1.6.3 template?

Frits

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.138 seconds