×
Kunena 5.1.14 Released - Security release (13 Aug 2019)

The Kunena team is proud to announce the arrival of Kunena 5.1.14 [K5.1.14] which is now available for download as a native Joomla extension for Joomla 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.14. This update fixed 1 security issue.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Question Problems with Siteground template

More
9 years 5 months ago - 9 years 5 months ago #1 by Pescador
Hi all

I'm having a problem with my template from siteground, because it's not displaying the kunena forum with the whole width. It's too short, like if it were columns on the side.

I've already disabled the left and right columns, but it's the same. For what I've read, the problem is my joomla template that only works with two or three columns...

Can anyone help me?

My site is here .

Thanks
Last edit: 9 years 5 months ago by sozzled. Reason: Changed subject to improve search relevance

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #2 by rich
Hello Pescador,

please look this wiki doc

How I can get the full width for Kunena Forum in my site?

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago - 9 years 5 months ago #3 by sozzled
What rich has written and what's contained in the Wiki article are correct ... to a point. However, in most cases that appear on these forums, the problems occur because of a restriction in the Joomla template. Further, this approach doesn't work if your site uses collapsible forum positions (see How can I have Kunena Forum in Full width ).

The bottom line is that Siteground templates look good but they're a lot more complicated to fix that other templates. Only recently I tried to help a user with a Siteground template-related problem (see Kunena forum width not full ) but he discovered that he could not use the fix for other reasons.

After considering the weight of evidence against Siteground , I am inclined to now think that fixing these problems takes more effort that it's worth and it's probably better to use another Joomla template provider.
Last edit: 9 years 5 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #4 by Cerberus
joomlabear seem to be the best in my experience easy to use and easy to edit if u wish :)

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #5 by jplamp
I'm using a SiteGround template and really didn't want to change it, as it is a good design for my needs. I've already tweaked it quite a bit, but didn't realize this problem until I installed Kunena on the site today. I figured out a way around it. I created a copy of the template ("Relax1", a 3-column template) and changed the templateDetails.xml file accordingly. Then I changed the template.css file from
div#maincolumn_full {
	float: left;
	width: 720px;
	margin: 0 0px 6px 0;
	/*padding: 10px 0 0 10px;*/
}

to
div#maincolumn_full {
	float: left;
	width: 100%;
	margin: 0 0px 6px 0;
	/*padding: 10px 0 0 10px;*/
}

I installed my new template and assigned it only to the Kunena menu item.

As long as you have nothing published in the Left or Right positions on that page, it seems to work fine.

This may not be the best solution to the problem, but it is working for me, so I thought I would pass it along. Other SiteGround templates might be able to be edited in a similar manner.

Kunena 4.0.11, Joomla 3.5.1, CB 2.0.14, DOCman 2.1.5, uddeIM 3.8

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #6 by Pescador
jplamp wrote:

I'm using a SiteGround template and really didn't want to change it, as it is a good design for my needs. I've already tweaked it quite a bit, but didn't realize this problem until I installed Kunena on the site today. I figured out a way around it. I created a copy of the template ("Relax1", a 3-column template) and changed the templateDetails.xml file accordingly. Then I changed the template.css file from

div#maincolumn_full {
	float: left;
	width: 720px;
	margin: 0 0px 6px 0;
	/*padding: 10px 0 0 10px;*/
}

to
div#maincolumn_full {
	float: left;
	width: 100%;
	margin: 0 0px 6px 0;
	/*padding: 10px 0 0 10px;*/
}

I installed my new template and assigned it only to the Kunena menu item.

As long as you have nothing published in the Left or Right positions on that page, it seems to work fine.

This may not be the best solution to the problem, but it is working for me, so I thought I would pass it along. Other SiteGround templates might be able to be edited in a similar manner.


Hi

That's my problem too. After a lots of tweaking, I found out that could not have the forum in full width, or else everything would act the same.

I'll try your solution or else I'll have to change the template.

Thanks for the reply!

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago #7 by Rup
Hi,

I am also using Siteground templates but done changes there of font and Site background Page..

So I think may be my issue is not related to Siteground Templates but with any template and Kunena.

I have set body class in .css file as

body {

font-family:Arial, Helvetica, sans-serif;
line-height: 1.3em;
margin: 0px;
padding: 0;
font-size: 12px;
background: #D6CE8F url('images/Background.jpg') no-repeat;
background-size: 100%;
align:left;
overflow-x: hidden

}

If I assign this template with my site it is showing me Background image on all the Pages , when I click on menus, But not for Kunena forum. I have also linked Kunena forum with Menu as "index.php?option=com_kunena"

Can any body please throw lite on this..

Thanks a lot.

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago - 9 years 4 months ago #8 by sozzled
Rup: I have just one question to ask you. Aside from the fact that you are using a Siteground template on your website, in what way is your problem related to the topic of this discussion that started by Pescador?

We have encountered many problems - dozens of problems - involving Siteground templates. It's difficult to classify one single issue but most of them have to do with Siteground's "collapsible module locations" (or lack of them) that restrict the allowable width for user's installations of Kunena. This is what was at the heart of Pescador's question (and what was at the centre of this discussion topic).

Your question is the first I've seen asking for help about some "background image". Perhaps your question deserves an entirely separate discussion topic? :S

While we look forward to your response, it might help you to read Before you ask for help with template issues ... ;)
Last edit: 9 years 4 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago #9 by sozzled
Rup has created a new discussion topic for his question. This topic is closed.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.091 seconds