×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Question 1.5.14 upgrade issue

More
8 years 8 months ago #11 by kmilos
Replied by kmilos on topic 1.5.14 upgrade issue
Ping?

The missing encoding declaration impacts both K1.6 and K2.0 as well.

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago #12 by xillibit
Replied by xillibit on topic 1.5.14 upgrade issue

kmilos wrote: @Scottux, @810
Yep, editing only manifest.xml is not enough (at least not after the build is done.)

For a long term solution maybe adding

encoding="utf-8"

to the /trunk/1.5/administrator/components/com_kunena/install/kunena.install.upgrade.xml template would be best?

Yes, this a good solution

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
8 years 7 months ago - 8 years 7 months ago #13 by kmilos
Replied by kmilos on topic 1.5.14 upgrade issue
Just saw another user running into this problem.

It's been weeks, and no commits to 1.5, 1.6 nor 2.0 in SVN, and no comments to the bug report on Forge.

Is there a problem with this patch being applied?

I understand resources are limited and devs are busy, but this is how things get forgotten and fall through the cracks. :(
Last edit: 8 years 7 months ago by kmilos.

Please Log in or Create an account to join the conversation.

More
8 years 7 months ago #14 by xillibit
Replied by xillibit on topic 1.5.14 upgrade issue
The issue isn't in /trunk/1.5/administrator/components/com_kunena/install/kunena.install.upgrade.xml but in \administrator\components\com_kunena\manifest.xml and this file has already encoding="utf-8"

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
8 years 7 months ago #15 by kmilos
Replied by kmilos on topic 1.5.14 upgrade issue
I beg to differ.

As mentioned in the earlier post in this thread, changes to manifest.xml alone were not enough, because the install package build script creates kunena.install.upgrade.xml using the checked in template the same way it does manifest.xml. If I understand correctly from kunena.build.xml:
<filter token="kunenaversionname" value="${xml.versionname}" />
<copy file="${project_dir}/administrator/components/com_kunena/manifest.xml" todir="${tmp_dir}" overwrite="true" filtering="true" />
<copy file="${project_dir}/administrator/components/com_kunena/install/kunena.install.upgrade.xml" todir="${tmp_dir}/install" overwrite="true" filtering="true" />


This why the problematic unicode character in ${xml.versionname} appeared ok in manifest.xml and not in kunena.install.upgrade.xml

Because the template kunena.install.upgrade.xml has no encoding it presumably gets processed as latin-1 and that's where the problem comes from (it didn't hit before because there were no unicode characters used in version names). There is potential this will hit again in all versions: 1.5, 1.6, and 2.0.

Please Log in or Create an account to join the conversation.

More
8 years 7 months ago #16 by dfirsching
Replied by dfirsching on topic 1.5.14 upgrade issue
Thanks you guys for putting these tips in here but it really would help to have the install fixed.

I already learned I can't use 1.6 without solving some template issues so I need to stay with 1.5 for the immediate term. It's cruddy for us all to have 1.5.14 not install either.

Please Log in or Create an account to join the conversation.

More
8 years 7 months ago #17 by sozzled
Replied by sozzled on topic 1.5.14 upgrade issue
G'day, dfirsching, and welcome to Kunena.

I sympathise with the problems that some people have in moving to K 1.6 however I have to say that those problems are never going to disappear if people remain with K 1.5 either. There is really only one solution for people who continue to use the excuse "I can't use 1.6 without solving some template issues". The answer is to solve those "template issues" or whatever other issues that people might have that prevent using K 1.6.

K 1.5 exists only as a temporary mechanism to allow people to run a web based forum while they sort out their other site problems (in much the same way as Joomla 1.5 provides "legacy mode" to ease people's problems when they continue to use J! 1.0 software). At some future time K 1.5 will cease to exist as a supported product and users will have to resolve for themselves any issues they might encounter (in exactly the same way as people have had to resolve J! 1.0 extension issues in J! 1.5 or J! 1.5 issues if they want to move to J! 1.6).

We understand that there are problems with the K 1.5.14 installation procedure; this is unfortunate. It's also unfortunate that K 1.5.15 has not yet been made public, too, however I have no control over the version release process.

My advice is for you (and anyone else in your situation) to progress the upgrade to K 1.6.3 anyway. :)

Please Log in or Create an account to join the conversation.

More
8 years 6 months ago #18 by kdpickett
Replied by kdpickett on topic 1.5.14 upgrade issue
This is an FYI: The comments above for changing "Comunità" to "Comunita" are true, but there are a few places this has to be changed. Here is a list of files that you should look for at:

I ran grep from the top of the extracted archive:

This email address is being protected from spambots. You need JavaScript enabled to view it. [~/dloads/com_kunenav1.5.14]# grep -rin comunit *
CHANGELOG.php:37:^ [#24700] Update version info to 1.5.14 (comunit�)
install/kunena.install.upgrade.xml:3: <install version="1.5.14" versiondate="2011-01-31" build="1907" versionname="Comunit� (Italian for: Community)">
install/kunena.install.upgrade.xml:348: <version version="1.5.14" versiondate="2011-01-31" build="1907" versionname="Comunita (Italian for: Community)">
lib/kunena.defines.php:17:define ('KUNENA_VERSION_NAME', 'Comunit� (Italian for: Community)');
manifest.xml:5: <versionname>Comunit� (Italian for: Community)</versionname>


The little question-mark icon is the problem and should be replaced with 'a'.
If you open the file up in a plain text editor (in my case, Vim), you will see it displayed as:
Comunit<88>

Anyway, that's what worked for me in upgrading from 1.5.11 to 1.5.14.

Hope that helps someone.
The following user(s) said Thank You: robytotem

Please Log in or Create an account to join the conversation.

More
8 years 1 month ago - 8 years 1 month ago #19 by robytotem
Replied by robytotem on topic 1.5.14 upgrade issue

kdpickett wrote: This is an FYI: The comments above for changing "Comunità" to "Comunita" are true, but there are a few places this has to be changed. Here is a list of files that you should look for at:

I ran grep from the top of the extracted archive:

This email address is being protected from spambots. You need JavaScript enabled to view it. [~/dloads/com_kunenav1.5.14]# grep -rin comunit *
CHANGELOG.php:37:^ [#24700] Update version info to 1.5.14 (comunit�)
install/kunena.install.upgrade.xml:3: <install version="1.5.14" versiondate="2011-01-31" build="1907" versionname="Comunit� (Italian for: Community)">
install/kunena.install.upgrade.xml:348: <version version="1.5.14" versiondate="2011-01-31" build="1907" versionname="Comunita (Italian for: Community)">
lib/kunena.defines.php:17:define ('KUNENA_VERSION_NAME', 'Comunit� (Italian for: Community)');
manifest.xml:5: <versionname>Comunit� (Italian for: Community)</versionname>


The little question-mark icon is the problem and should be replaced with 'a'.
If you open the file up in a plain text editor (in my case, Vim), you will see it displayed as:
Comunit<88>

Anyway, that's what worked for me in upgrading from 1.5.11 to 1.5.14.

Hope that helps someone.


i friend...i make this modification but i see (from 1.5.13 to 1.5.14):

ERROR: Could not find a Joomla XML file in this package.

why?

:(
Last edit: 8 years 1 month ago by robytotem.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.089 seconds