×
K5.1.1 is released (10 Jun 2018)

The Kunena team is pleased to announce Kunena 5.1.1 [K 5.1.1].
Please read the blog post for information:

× This is not a support forum for sh404SEF or its related products. For sh404SEF support you should visit sh404SEF .

The information given in this category is intended to guide users who want to use sh404SEF with Kunena and, mostly, was written by Kunena users. The information here is not necessarily accurate, up-to-date nor is it intended to replace the support given by the developers of sh404SEF.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Solved All links on my forum page take me to the forum page!

More
3 years 11 months ago #1 by Nbryant
I have got rather confused with my menu system and now every link on the forum home page takes you to the same page. It was fine until I somehow lost my tabs (index, my topics etc)and when I tried to get them back I messed up the links. It is currently setup with the forum as the homepage so that it shows, but I want the home page as the home page (suprise suprise!) This is the site ultrarunningcommunity.com/
Here's my config report :
This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 660 seconds | Max execution memory: 512M | Max file upload: 360M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : protostar | author: Kyle Ledbetter | version: 1.0 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.5 | creationdate: 2014-03-09

Kunena version detailed: Kunena 3.0.5 | 2014-03-09 [ Invecchiato ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: CommunityBuilder 1.9.1 | UddeIM 3.4

Third-party SEF components: sh404sef 4.4.0.1725

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
3 years 11 months ago #2 by Nbryant
I've just noticed that this is in the sh404SEF section. Not where I intended it to go! Apologies for that.

Please Log in or Create an account to join the conversation.

More
3 years 11 months ago #3 by sozzled
I moved this topic to the sh404SEF category.

If people have problems with Joomla routing, and they are using sh404SEF, then this is the appropriate category for those questions. If we can establish beyond all doubt that sh404SEF is responsible for your problems then I will be happy to move this topic back to the "general questions" category.

In the meantime, I am not sure as to the cause of your routing problems.

You have a peculiarity with your Joomla menu but I don't know if this is the reason. You could try using a standard Kunena menu instead of the one you're using to see if this helps.

The other obvious issue is sh404SEF which, as we know, causes problems for Kunena.

So, while you continue to use sh404SEF, I'm guessing that this is the real reason for the problem ... but I could be wrong. FYI, I do not use sh404SEF.
The following user(s) said Thank You: Nbryant

Please Log in or Create an account to join the conversation.

More
3 years 11 months ago #4 by Nbryant
14337Hi sozzled,
Thanks for the response. I am new to this and on a very steep learning curve so please excuse the slowness.
I have now removed the aweful sh404sef and it is all working again! Thanks for the tip.
Now to work out why Google is not indexing the majority of my pages...

Please Log in or Create an account to join the conversation.

More
3 years 1 week ago #5 by ssula
You have a peculiarity with your Joomla menu but I don't know if this is the reason. You could try using a standard Kunena menu instead of the one you're using to see if this helps.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.097 seconds