×
Kunena is Joomla 3.8 compatible (20 Sep 2017)

Kunena 5.0.11 is compatible with the release of Joomla 3.8.
There are no know issues with the current version on Joomla 3.8. We advice to update if your other 3rt extensions are also compatible with the latest version.

× This is not a support forum for Community Builder or its related products. For Community Builder support you should visit Joomlapolis .

The information given in this category is intended to guide users who want to use Community Builder with Kunena and, mostly, was written by Kunena users. The information here is not necessarily accurate, up-to-date nor is it intended to replace the support given by the developers of Community Builder.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Solved No registration link

More
3 years 1 month ago #1 by Shimei
Shimei created the topic: No registration link
Hi,

I have no registration link displaying in Kunena forum. I am not aware of any changes other than upgrading to Kunena 3.0.6 from 3.0.5. I was looking to see whether any correlation could exist between Community Builder and Kunena but couldn't find anything except for really old Kunena versions.

Here is my configuration report and forum: www.reformedchristianity.org/forum


This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 2M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : yoo_catalyst | author: YOOtheme | version: 1.0.7 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.6 | creationdate: 2014-07-28

Kunena version detailed: Kunena 3.0.6 | 2014-07-28 [ Tala ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: CommunityBuilder 1.9.1 | UddeIM 3.4

Third-party SEF components: None

Plugins: Search - Kunena Search 3.0.1 | Content - Kunena Discuss 3.0.1 | JomSocial - My Kunena Forum Menu 2.0.3 | JomSocial - My Kunena Forum Posts 2.0.3 | JomSocial - Kunena Groups 2.0.3

Modules: Kunena Latest 3.0.1 | Kunena Login 3.0.1

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago - 3 years 1 month ago #2 by sozzled
sozzled replied the topic: No registration link
It's possible that this may be a problem with integrating K 3.0.6 and Community Builder.

I don't use CB these days. I have several websites where I am using K 3.0.6 and the registration link appears OK.

The registration link will not appear (on Kunena without CB) if you have have disabled registration in Joomla. To disable registration in Joomla you go to Users » User Manager » Options » Allow User Registration = No

This setting stops the registration link appearing in the Kunena profile box at the top of the forum.

I remember reading a long time ago that this is what Joomlapolis recommends you should do. I may have remembered it wrong but I think that's what I read when I last used CB and Kunena (which was about three years ago), so this may not be right.

My suggestion is to check your Joomla "user manager" settings first. Then check the CB documentation to see what Joomlapolis recommends. If something has changed in K 3.0.6 then this is a matter to be worked out between the Joomlapolis and Kunena developers.
Last Edit: 3 years 1 month ago by sozzled.

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago - 3 years 1 month ago #3 by Shimei
Shimei replied the topic: No registration link
Hello Sozzled,

I have checked Joomla! registrations, and it is enabled. I went through the community builder plugins and checked to make sure login is enabled ect... as is reflected in the configuration report.

I came across this, however, in the 3.0.6 release read me:

#2389: Registration link not showing when integrating with Community Builder Thanks: c-schmitz


I suspect some changes were made, and this has had a negative impact, at least regarding my setup.

I'll await further assistance, as I found this because I noticed that no new members have signed up. Amazing how much that little create account / registration link does for the forum!

Thanks for your effort thus far!

Edit: I disabled integration plugin between Kunena and Community Builder and the Create Account link appears. I have it enabled at this time in case someone wants to check the site.
Last Edit: 3 years 1 month ago by Shimei.

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #4 by xillibit
xillibit replied the topic: No registration link
There are extras checks added on this one : github.com/Kunena/Kunena-Forum/commit/3f...6272ee9ce36b10ae327f

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #5 by rich
rich replied the topic: No registration link
Which login do you want use?
If you want Joomla Login, then disable the CB login
Kunena - Community Builder Enabled: access=1 login=0 activity=1 avatar=1 profile=1 private=1

If you want CB login:
Kunena - Community Builder Enabled: access=1 login=1 activity=1 avatar=1 profile=1 private=1
Then go to "Community Builder > Configuration > Registration" and set "Allow User Registration = yes, independently of global site setting".
The following user(s) said Thank You: Shimei

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #6 by Shimei
Shimei replied the topic: No registration link
Hello Rich,

That worked!!!

I disabled registrations in Joomla! user options. Then went to "Community Builder > Configuration > Registration" and set "Allow User Registration = yes, independently of global site setting".

The link is back,

I thank you sir for the support by way of a small donation made last night in advance.

Enjoy!
The following user(s) said Thank You: sozzled

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #7 by sozzled
sozzled replied the topic: No registration link
Yes, that's the answer!

Community Builder » Configuration » Registration » Allow User Registration = Yes, independently of global site setting

I knew that I remembered seeing something like that in the CB configuration settings when I last used CB some years ago! :cheer:

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #8 by Matias
Matias replied the topic: No registration link
I can confirm that we added a small fix for CB installation which changes the registration check from Joomla one to CB one, because of that is what they recommend to be used.

No, I'm not reading my private messages. Please use forum to get support and email for private matters.
Reviews on the Joomla Extension Directory are always appreciated.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.458 seconds