×
Kunena 5.1.13 Released (21 Jul 2019)

The Kunena team has announce the arrival of Kunena 5.1.13 [K 5.1.13] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× This is not a support forum for JomSocial or its related products. For JomSocial support you should visit JomSocial .

The information given in this category is intended to guide users who want to use JomSocial with Kunena and, mostly, was written by Kunena users. The information here is not necessarily accurate, up-to-date nor is it intended to replace the support given by the developers of JomSocial.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question JomSocial Integration Plugin gets wrong values from activity_stream_limit

More
1 month 1 day ago - 1 month 1 day ago #1 by kulturnilpferd
Hey there,
cant get a Configuration Report due broken link:
www.kunena.org/docs/*_Commonly-asked_(an...uration_report.29.3F
but this is just the first issue:
I love your plugin and it's well designed. But I have the bug that all text of the kunena forum was postet on the stream without a limit.
I have looked in your programming and have found the bug:
In activity.php of your Jomsocual Plugin at line 108 you stream the content with:
$content = KunenaHtmlParser::parseBBCode($message->message, $parent, $this->params->get('activity_stream_limit', 0));

The bug is in:
$this->params->get('activity_stream_limit', 0)

it gets a NIL value so all of the text in kunea was postet is getting it to the activity stream.
I have hardcoded that with:
$content = KunenaHtmlParser::parseBBCode($message->message, 300);
to get it to a limit of 300 charters.
I know this is a totally shitty bugfix so maybe you may look into it and get the right value from jomsocial.

Greetings
Kulturnilpferd
Last edit: 1 month 1 day ago by kulturnilpferd.

Please Log in or Create an account to join the conversation.

More
1 month 20 hours ago #2 by 810
Hi, thank you for the report, we will fix this on the next release.

Please Log in or Create an account to join the conversation.

More
1 month 20 hours ago #3 by 810
Is there a global option to set it on Jomsocial? where can i find the option.

Please Log in or Create an account to join the conversation.

More
1 month 17 hours ago #4 by kulturnilpferd
Didn't find that option also.
I think the best way to debug is to inspect the element in the jomsocial backend (Configuration > Layout > Display Settings > Activity Content Length)
(i have tested it without the _ doesn't work ^^)
or if you didn't find it maybe search direct on a clean joomla and jomsocial installation for the mysql settings entry. Didn't have the time for that but that's the way I would do it, maybe it could help you.
If you found it please tell me how you do it, I'm verry interested <3

Please Log in or Create an account to join the conversation.

More
4 weeks 1 day ago #5 by 810
I have fixed it on the next version, there is now a option on the kunena - community plugin.

Looks like it was removed during the development on earlier stage.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.075 seconds