×
Blue Eagle (1.5.0) for K5.1 is released (20 Jul 2018)

Please update the Kunena Blue Eagle to 1.5.0 if you use Kunena 5.1.
We made several bug fixes and improvements. Also Blue Eagle has now all the features from Crypsis.
Download: www.kunena.org/download/templates/category/blue-eagle-5

× This is not a support forum for JomSocial or its related products. For JomSocial support you should visit JomSocial .

The information given in this category is intended to guide users who want to use JomSocial with Kunena and, mostly, was written by Kunena users. The information here is not necessarily accurate, up-to-date nor is it intended to replace the support given by the developers of JomSocial.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Jomsocial "guest male avatar" points to the wrong directory path (but femaie avatar path is correct)

More
2 years 3 months ago - 2 years 3 months ago #1 by Rik Brown
I'm using Kunena 4.0.10 with JomSocial 4.1.7 under Joomla 3.5.1.

I have a problem in displaying JomSocial's default male guest avatar within the Kunena forums.

The default female guest avatar displays fine by pointing to:
/components/com_community/assets/user-Female.png

The default male guest avatar does not display because its PATH is WRONG pointing to:
/home/www/html/subs/travel/components/com_community/assets/user-Male.png
(that path doesn't exist)

I don't know why the paths can be different. As mentioned, the "female" path is correct. But shouldn't the PATH should be the same for both avatars?

Does anyone know where the "male" path is stored? If it in a database table or template, I can easy change that. But I haven't had any luck finding it so far.

Any ideas?

Thanks. -- Rik

PS: The configuration report link is generating an error message.
Last edit: 2 years 3 months ago by Rik Brown. Reason: Add PS:

Please Log in or Create an account to join the conversation.

More
2 years 3 months ago #2 by 810
plugins/kunena/kunena_community/avatar.php line +- 67


whats the error on the report
The following user(s) said Thank You: Rik Brown

Please Log in or Create an account to join the conversation.

More
2 years 3 months ago #3 by Rik Brown

810 wrote: plugins/kunena/kunena_community/avatar.php line +- 67


Thanks for the lead. I checked out the avatar.php file but I don't see anything that differentiates between male and female avatars. Those must be passed parameters specific to the user that are set before applying those parameters to the avatar.php file.

Would you know where the directory paths are set for each gender?

whats the error on the report


Sorry, the error I mentioned refers to the Kunena.org configuration report link at the top of this page which, when clicked on, generates an error message on the Kunena.org site indicating: "Woops. Looks like this page doesn’t exist."

Thanks. -- Rik

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago - 1 year 8 months ago #4 by Rik Brown
I guess that this deserves a bump after 6 months. Anyone know?

I edited the plugins/kunena/community/avatar.php file indicated above by "810" as follows:

WAS: $avatar = str_replace(JUri::root(true), '', COMMUNITY_PATH_ASSETS) . "user-Male.png";
NOW: $avatar = "https://www.[domain].com/en/components/com_community/assets/user-Male.png";

The above works. But does anyone know how to fix this other than editing the avatar.php as I did above.

Thanks. -- Rik

PS: The report function is working now ....

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 300 seconds | Max execution memory: 1512M | Max file upload: 300M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : Socialize | author: JomSocial | version: 2.0 | creationdate: Mar 12 2015

Kunena default template details : Crypsisb3 | author: Kunena Team | version: 5.0.3 | creationdate: 2016-10-23

Kunena version detailed: Kunena 5.0.3 | 2016-10-23 [ Dibatag ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: Jomsocial 4.2.5

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 5.0.1

Last edit: 1 year 8 months ago by Rik Brown. Reason: Path correction

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #5 by 810
the male user, is only for guest users. not to show the female/male gender.

You see the avatar from jomsocial. If no account on jomsocial, like guest post. Then a user avatar is showed. It isn't be invented to how it as gender avatar.
The following user(s) said Thank You: Rik Brown

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago - 1 year 8 months ago #6 by Rik Brown
@810 - Thank you for your reply.

810 wrote: the male user, is only for guest users. not to show the female/male gender.

You see the avatar from jomsocial. If no account on jomsocial, like guest post. Then a user avatar is showed. It isn't be invented to how it as gender avatar.


I understand that and have no problem with what gender the avatar is.

My problem is that the path to the guest avatar is not valid and therefore the male avatar is not displaying at all.

Therefore, I had to hard code the url into the avatar.php file. Essentially, it is trying to use the absolute server path instead of the relative server path to create the correct url:

avatar.php absolute path: /home/www/html/subs/travel/en/plugins/kunena/community/
relative path -> (Joomla home)/plugins/kunena/community/

Any idea where to fix that (i.e. correct the server path to a relative server path) outside of editing the avatar.php file?

Thanks again. -- Rik
Last edit: 1 year 8 months ago by Rik Brown.

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #7 by 810
no, you need to edit that file. We don't have any subscription to jomsocial, so we couldn't check the plugin anymore, I have tried to contact the team, about getting a version from them, but I haven't got any reply on it.

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #8 by Rik Brown
Understood. I'll take it over to JomSocial.com and see if they can get to work on this.
Thanks again. -- Rik

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #9 by kirblam
Line 67 in plugins/kunena/community/avatar.php needs to be
$avatar = str_replace(JPATH_SITE, '', COMMUNITY_PATH_ASSETS) . "user-Male.png";
For some reason, JUri::base(true) and JUri::root(true) fail to come back with the document root in that code. I didn't look too closely at it since I could tell what it was *trying* to do. Evidently COMMUNITY_PATH_ASSETS (which is the Jomsocial constant) sometimes includes the document root which doesn't do any good when trying to generate an URL. That str_replace was simply failing to nuke the docroot from the path.
I don't know if JPATH_SITE is deprecated by now but that works in Joomla 3.6.5. I didn't try it in 3.7.x.
Just documenting this in case someone bumps into this specific error. I see that this is pretty old but I just had to fix this now.
Thanks
K
PS - I'm hoping that Jomsocial sent the Kunena team a valid subscription by now...

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.155 seconds