×
Kunena 5.2.6 released and Blue eagle 1.6.6 released (25 Jul 2021)

The Kunena team has announce the arrival of Kunena 5.2.6 [K 5.2.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.6

Question How to switch languages?

More
9 years 7 months ago #1 by ccvortex
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 10M

Kunena menu details:
Warning: Spoiler!

Joomla default template details : rhuk_milkyway | author: Andy Miller | version: 1.0.2 | creationdate: 11/20/06

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.2 | creationdate: 2012-01-31

Kunena version detailled: Installed version: 1.7.2 | Build: 5215 | Version name: Omega | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: Kunena Latest 1.7.1


I am at a loss as to how to switch the forums to Chinese. I have created directories named zh-CN on the web server in the following paths:
administrator/components/com_kunena/language/
and
components/com_kunena/language
I then uploaded the files found in the following rar's I found here on this website:
com_kunena_v1.7.1_zh-CN.admin_2011-11-17.zip
and
com_kunena_v1.7.1_zh-CN.site_2011-11-17.zip

I also uploaded the basic Chinese language pack for Joomla itself.

When I go to the Joomla control panel and set the default language to Chinese the forums stay in English, and I can't find anything in the forum prefs that say change language, etc.

What am I missing here?

Thanks in advance

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #2 by xillibit
Hello,

Try to put the languages files in /administrator/languages/zh-CN/ and in /languages/zh-CN/

You can enable language debug and debug mode in Joomla! configuration panel to see which language file is loaded.

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #3 by ccvortex
Thanks xillibit that worked like a charm.

One question though: is it possible to translate the forum names/categories themselves? or do they have to be one language only? Joomfish doesn't recognize the categories as translatable items.

If they have to be in one language only, where in the code can I change the 80 character limit to forum/category names?

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.311 seconds