×
Kunena 5.1.10 Released - Security release (03 Mar 2019)

The Kunena team has announce the arrival of Kunena 5.1.10 [K 5.1.10] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a security release.

Solved Variable name displayed instead of value

More
2 weeks 4 days ago - 2 weeks 4 days ago #1 by autobahn
I have just updated from V5.1.10 to V5.1.10.1 on both my local test site and my live site.

Everything is fine on my local test site:
Joomla 3.9.3
CB 2.4.1
PHP 7.2.9

But on my live site:
Joomla 3.9.3
CB 2.4.1
PHP 7.0.33

variable names from the en-GB.com_kunena.templates.ini file are being displayed instead of the value when I display the list of topics in a category. E.g.

"COM_KUNENA_GEN_HITS" instead of "Views"
"COM_KUNENA_GEN_REPLIES" instead of "Replies"
"COM_KUNENA_GEN_LAST_POST" instead of "Last Post"
"COM_KUNENA_VIEW_COMMON_FOOTER_TIME " instead of "Time to create page: n seconds"

I have compared the local and live copies of en-GB.com_kunena.templates.ini and they are identical. I have copied the live file to my local test site and there are no problems.

Does anyone have any idea why this might be happening? The only real difference between the two sites is the PHP version, but according to the Kunena Requirements both versions of PHP are within spec.

This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 90 seconds | Max execution memory: 128M | Max file upload: 32M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : abs2016 | author: Angie Radtke | version: 3.1.0 | creationdate: 25 November 2009

Kunena default template details : Crypsis | author: Kunena Team | version: 5.1.10.1 | creationdate: 2019-03-04

Kunena template params:

Warning: Spoiler! [ Click to expand ]

Kunena version detailed: Kunena 5.1.10.1 | 2019-03-04 [ Janus ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: CommunityBuilder 2.4.1

Third-party SEF components: None

Plugins: None

Modules: None

Last edit: 2 weeks 4 days ago by autobahn. Reason: Adding configuration report plus more info

Please Log in or Create an account to join the conversation.

More
2 weeks 3 days ago #2 by rich
Please try to install the Kunena language package.
If you install Kunena, the path for the English language are:
/administrator/components/com_kunena/language/en-GB/
and
/components/com_kunena/language/en-GB/

But if you install the language package extra, the files will saved in the folders:
/administrator/language/en-GB/
and
/language/en-GB/

Maybe it help.
The following user(s) said Thank You: autobahn

Please Log in or Create an account to join the conversation.

More
2 weeks 3 days ago #3 by autobahn
Thank you for your suggestion. We only have en-GB installed but I re-installed the language pack anyway, just in case. Unfortunatelt it made no difference, so my next step will be to see if moving to PHP 7.2 will sort it out.

Thanks for trying :)

Please Log in or Create an account to join the conversation.

More
2 weeks 2 days ago #4 by autobahn
It might help other people, if they encounter this problem, to know that I solved it by upgrading to PHP to 7.1.26. There are reason why we can't go to 7.2 yet, so this is a good interim solution that works :)

Please Log in or Create an account to join the conversation.

More
2 weeks 2 days ago - 2 weeks 2 days ago #5 by andycoe1960
I am having the same problem but this solution hasn't worked for me. It started when I upgraded to the latest version. I posted on this forum with the report and a screen shot as the site suggests but my posting has been deleted after a couple of days for some reason with no explanation. I have only recently moved to this forum solution having previously used WebWiz for the last 13 years. It has taken some convincing to get my users to accept the change but this bug isn't helping my argument with them.
I attach a screen shot to hopefully confirm that I am talking about the same issue.
Attachments:
Last edit: 2 weeks 2 days ago by andycoe1960. Reason: 2 x images

Please Log in or Create an account to join the conversation.

More
2 weeks 2 days ago #6 by autobahn
It certainly looks like the same problem as I had. The only other idea I had was that it could be a template incompatibility. Although we have a bespoke template for Joomla!, I've set Kunena up to open in a new window using the Protostar template for the Kunena Menu and the Kunena Crypsis Menu for the forums. Just an idea.
The following user(s) said Thank You: andycoe1960

Please Log in or Create an account to join the conversation.

More
2 weeks 2 days ago #7 by rich
@andycoe1960

No one has deleted your post. I've the topic only moved in the correct category for Blue Eagle. www.kunena.org/forum/blue-eagle-5
Users who bought the template, get automatically access to this category. If does not work, then send a mail an [email protected]*kunena.org please (address without star).
The following user(s) said Thank You: andycoe1960

Please Log in or Create an account to join the conversation.

More
2 weeks 1 day ago #8 by xillibit
Hello,

If you enable debug language in Joomla! setting, do-you see that the file en-GB.com_kunena.templates.ini is right loaded ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
5 days 10 hours ago #9 by rich
This bug is already fixed.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.126 seconds