×
Kunena 5.1.13 Released (21 Jul 2019)

The Kunena team has announce the arrival of Kunena 5.1.13 [K 5.1.13] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Question Kunena 1.0.11 and Internet Explorer 8 Width Problem

More
10 years 2 weeks ago #1 by wvrapscene
Hello

If you view my kunena forums with Internet Explorer 8, the width is to large! If you choose Compatibility View in IE8, everything looks great and width is fixed.

I'm tryin to fix this in the CSS so users with IE8 do not have to click compatibility view for the forums to display correctly.

I've read this post:

www.kunena.com/forum/137-solved-or-prior...e8?limit=10&start=10

...but it didnt help the IE8 width problem!

I use Joomla 1.0.15 and Kunena 1.0.11

My site is wvrapscene.com/main if you want to see the problem!

Thanks,
WVRapScene

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago - 10 years 2 weeks ago #2 by Lintzy
Hello, please enter this code at the end of the kunena.forum.css of your template:

/* Fix for Internet Explorer 6*/
#Kunena *html div.msgtext, #Kunena div.msgsignature  {
width:520px;
overflow:hidden!important;
word-wrap: break-word;
}
/*Fix for Internet Explorer 8*/
#Kunena div.msgtext, #Kunena div.msgsignature  {
width:/*\**/520px\9;
overflow:/*\**/hidden!important\9;
word-wrap:/*\**/break-word\9;
}

You can fit the value 520px. Try this code, trust me :)
Last edit: 10 years 2 weeks ago by Lintzy.

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #3 by wvrapscene
thanks for the reply!

I put that code at the end of my kunena.forum.css file, but it still didnt fix it.

I changed kunena templates and it works great with the new template that Im using now!

Again, thanks for the help!
WVRapScene.com

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago - 10 years 2 weeks ago #4 by Lintzy
Hi, did you insert the code above, it is not the same code like in the thread you linked to.

I downloaded your website (part of it) and tested the code with IE8 it works. Please match the code above, with the code you inserts, in the past it had happened, that backslashes were lost. Don't insert the code over Kunena backend / Css, but download the kunena.forum.css, open it with notepad++ or something similiar, save and upload per FTP.

Or if you have inserted it, let me look again.

And yes in default_ex is the code "word-wrap:break-word;" inserted, in the most cases this is enough to work in the most joomla templates and if not you must tell the KN template to take only a fixed width (for IE8 and IE6).

Your KN template does not have both CSS instructions.
Last edit: 10 years 2 weeks ago by Lintzy.

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago - 10 years 2 weeks ago #5 by wvrapscene
Hey Lintzy!

I did add the code to the end of my css file and it works great on IE 8!

I've been switching templates like crazy trying to find one I like... I found some templates didnt need that code, and some do!

Thank you,
WVRapScene

************************************************************

I spoke to soon.... lol

It works when viewing the topic...

When you REPLY to the topic, the width is messed up and to wide again!

I'm guessing the topic history (at the bottom of Post a New Message Form) is causing this problem.

************************************************************

How can I fix the width when someone replies to a topic?
Last edit: 10 years 2 weeks ago by wvrapscene. Reason: Still doesnt work...

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #6 by Lintzy
Hi,

don't see any issues.

wvrapscene.com/main/component/option,com...ew/catid,4/id,54/#57

Test reply of me, no errors, no messed up.


Or am I looking at the wrong place? Please give me a direct url where the problem exists.

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #7 by wvrapscene
The direct link is:
wvrapscene.com/main/component/option,com.../catid,4/replyto,57/

I just cleared temp files and cache on IE8, and tried again... the width is still messed up when you reply to a topic.

I'm using Internet Explorer 8.0.6001.18702

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago - 10 years 2 weeks ago #8 by Lintzy
Ok, now I see the messed up windows. I'll look, if I am able to find a solution.
Last edit: 10 years 2 weeks ago by Lintzy.

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago - 10 years 2 weeks ago #9 by wvrapscene
ok

thank you soo much!
Last edit: 10 years 2 weeks ago by wvrapscene.

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #10 by Lintzy
Sorry, no solution found. But it is sure the fb_review_table.

A hotfix would be to hide the history with:
#Kunena table.fb_review_table  {
display:none;
}

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.104 seconds