×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

Question Smart search produce wrong url - error 404 component was´t found

More
2 years 3 months ago #1 by 4max
Smart search on my site produce this url:
mysite/component/kunena/krmeni-psu/5-obezita/7
which produce 404 error - page not found (component wasn´t found)

If I select the same post in the forum I get this url:
mysite/forum/krmeni-psu/5-obezita/7

So, forum funcions correctly, however, all smart search results that point to forum post results with the same error.
It seems that for unknown reason the /forum/ in the url is replaced with /component/kunena/

In the smart search the forum post are indexed like this:
index.php?option=com_kunena&view=topic&catid=5&id=11&mesid=48

What could be wrong? Please help.

Report configuration
This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 32M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : iReview3 | author: ClickFWD LLC | version: 3.7.2 | creationdate: June 2018

Kunena default template details : Crypsisb3 | author: Kunena Team | version: 5.1.1 | creationdate: 2018-06-10

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.1.1 | 2018-06-10 [ Belinda ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: Search - Kunena Search 5.1.0

Modules: Kunena Latest 5.1.0

Please Log in or Create an account to join the conversation.

More
5 months 3 weeks ago #2 by inspry
Did anybody ever find a solution to this?

We are having the same issue.

We are using the latest Kunena, Joomla and no SEO plugin that may be conflicting.

Smart Search is assigned on a menu item.

If I enable direct component access, it works fine, but that is not ideal since that exposes all those URLs to users and search engines.

Report attached -

Attachment not found



Thanks for any help or assistance

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.223 seconds