Kunena 6.3.2 released

The Kunena team has announce the arrival of Kunena 6.3.2 [K 6.3.2] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3
Note: Please go to the Kunena Dashboard after an upgrade so that the Kunena database tables are also updated.

Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Merged K3.0 installation fails with message "Warning: Invalid argument supplied for foreach() in ../administrator/components/com_kunena/install/schema.php on line 296"

More
11 years 3 weeks ago #1 by davidepalio
Hi, tried to install K3.0.0 package on Joomla 3.1.1.
I got this output:
Warning: DOMDocument::load() [domdocument.load]: I/O warning : failed to load external entity "/home/dpalio/elettrosmogsicilia.org/administrator/KPATH_ADMIN/install/install.xml" in /home/dpalio/elettrosmogsicilia.org/administrator/components/com_kunena/install/schema.php on line 206

Warning: Invalid argument supplied for foreach() in /home/dpalio/elettrosmogsicilia.org/administrator/components/com_kunena/install/schema.php on line 296

Fatal error: Class 'KunenaRoute' not found in /home/dpalio/elettrosmogsicilia.org/administrator/components/com_kunena/install/sql/install/php/sampledata.php on line 147
When I pressed "details" I got just one row:
Preparare l'installazione ... OK
(I have the italian language installed)

When I opened the Component Menu, I could see Kunena listed among the components.
When I pressed Forum tools, I could see the installation bar progressing, taking up a few seconds (is that a normal behaviour).
Here follows the configuration report.

My question is: based on the configuration report below, is it safe to ignore the installation error and go ahead all the same? Or, is it safer to wait for a newer and more stable version? Can you please shed some light?
in other words: is the reported error really a fatal error? Any way to fix it?
Thank you.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 90M | Max file upload: 7M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : protostar | author: Kyle Ledbetter | version: 1.0 | creationdate: Unknown

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 3.0.0 | creationdate: 2013-05-15

Kunena version detailed: Kunena 3.0.0 | 2013-05-15 [ Wanga ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
11 years 3 weeks ago #2 by xillibit
Hello,

The path in error message is weird : /home/dpalio/elettrosmogsicilia.org/administrator/KPATH_ADMIN/install/install.xml

So, do you have able to access to Kunena backend ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
11 years 3 weeks ago #3 by davidepalio
Hello xillibit,
I agree it is weird: I do not know much PHP, however looks to me like the variable KPATH_ADMIN has not been properly resolved/expanded.

I can access the Kunena backend. As I reported, the first time I tried to access it, I got a completion progress bar that took a few seconds to become entirely green, I do not know whether this is the typical behavior or a direct consequence of the earlier fatal error. I subsequently could access all the 11 submenu entries of Kunena in Component Manager menu.

Based on the sampledata.php content and the reported error at line 147, what can you advise to me? Do you think it is relatively safe to continue using Kunena or I shall de-install it and fix something in the installation procedure before I start over again, or even wait for a future Kunena version?

Thank you.

Please Log in or Create an account to join the conversation.

More
11 years 3 weeks ago #4 by xillibit
If you can access to all functions with no issues, so don't worry

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago - 10 years 11 months ago #5 by trench
The installation failed with the following error:

Warning: Invalid argument supplied for foreach() in/home/sitr/public_html/administrator/components/com_kunena/install/schema.phpon line 296

Fatal error: Class 'KunenaRoute' not found in/home/sitr/public_html/administrator/components/com_kunena/install/sql/install/php/sampledata.phpon line 147


What can I do? :(

Use: Joomla 2.5.13 + PHP 5.3.26 + MySQL 5.1.70
Last edit: 10 years 11 months ago by trench.

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago #6 by trench
I tried a second installation and now the component is installed correctly. :)
What is sucess in the first installation?

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago #7 by ctiteuf
Replied by ctiteuf on topic installation problem
Hello,

I have tried to install the kunena 3 on a local server but I have an error message


Warning: DOMDocument::load(): I/O warning : failed to load external entity "file:///C:/xampp/htdocs/lierneux/administrator/KPATH_ADMIN/install/install.xml" in C:\xampp\htdocs\lierneux\administrator\components\com_kunena\install\schema.php on line 206

Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\lierneux\administrator\components\com_kunena\install\schema.php on line 296

Fatal error: Class 'KunenaRoute' not found in C:\xampp\htdocs\lierneux\administrator\components\com_kunena\install\sql\install\php\sampledata.php on line 147

can anyone help me solve this problem ?
Thank you very much

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago #8 by Mortti

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago #9 by sozzled
Replied by sozzled on topic installation problem
*** Topics merged ***

G'day, ctileuf, and welcome to Kunena.

See information posted in this topic.

Please note our general policy regarding Support for PC-hosted websites (e.g. WAMP, XAMPP)

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago #10 by topwebs
Installation fails with errors:

[06-Aug-2013 16:14:44 America/Chicago] PHP Warning: Invalid argument supplied for foreach() in /home/lifechur/public_html/administrator/components/com_kunena/install/schema.php on line 296
[06-Aug-2013 16:14:44 America/Chicago] PHP Fatal error: Class 'KunenaRoute' not found in /home/lifechur/public_html/administrator/components/com_kunena/install/sql/install/php/sampledata.php on line 147

Nothing in the Kunena Administration menu works. Says Installing Kunena, please wait...
Sorry, installation failed on fatal error! Multiple reinstallations give same problem.

PHP Built On Linux host.topwebsnetwork.com 2.6.32-042stab076.8 #1 SMP Tue May 14 20:38:14 MSK 2013 i686
Database Version 5.1.70-cll
Database Collation utf8_general_ci
PHP Version 5.3.24
Web Server Apache
WebServer to PHP Interface cgi-fcgi
Joomla! Version Joomla! 2.5.14 Stable [ Ember ] 01-August-2013 14:00 GMT

Please Log in or Create an account to join the conversation.

Time to create page: 0.483 seconds