×
Kunena 5.2.6 released and Blue eagle 1.6.6 released (25 Jul 2021)

The Kunena team has announce the arrival of Kunena 5.2.6 [K 5.2.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.6

× The error code HTTP 500 Internal Server Error is a general-purpose message this indicates a general error in a web application. Please note that there is no general solution for this general error. You should first read HTTP 500 Internal Server Error before posting in this category.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Fatal error: Access to undeclared static property: JLoader::$classes in ../libraries/loader.php on line 195

More
8 years 3 months ago #1 by Oscar2
Yes, another error 500 topic, apologies...

I read a lot about this but really cant figure it out. After upgrading from the latest 2 version to 3.1 I get an error 500, but only on the forum homepage / index. All else is working perfectly?!

The error:
Fatal error: Access to undeclared static property: JLoader::$classes in /home/bonsai7/public_html/testsite/libraries/loader.php on line 195


I reset the menu, disabled most of my other plugins, but the error persists. Only when I disable SEF for Kunena (from the JoomSEF extensions) did it work. I use the latest JoomSEF version...


Hope the fact that I only get it on the homepage of the forum rings a bell to someone, so I can solve this issue.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #2 by Oscar2
PS:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 45 seconds | Max execution memory: 384M | Max file upload: 256M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : general_commerce | author: Shape5.com | version: 1.0 | creationdate: Unknown

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 3.0.1 | creationdate: 2013-06-29

Kunena version detailed: Kunena 3.0.1 | 2013-06-29 [ Noordwijkerhout ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: UddeIM 3.0

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 3.0.1

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #3 by xillibit
Hello,

This is more a Joomla! issue and by looking the error message the issue is located in Joomla!, do-you have reported the issue on forum.joomla.org ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #4 by Oscar2
No, but since all else is working fine and these errors only appear after updating to the new Kunena I figured I had to ask here.

Before turning to Joomla (and probably hearing there that I should ask at Kunena..) could you help me at least in what direction I have to look to solve this? I am really stuck...

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #5 by xillibit
Try to disable kunena latest to see if the problem still happens, i don't know what is exactly causing this

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #6 by sozzled

Before turning to Joomla (and probably hearing there that I should ask at Kunena) ...

I strongly doubt that because the problem involves SEF URLs and Kunena URLs have always been "search engine-friendly" depending on how you setup search engine optimisation within Joomla. In your case, you have chosen to do that using Artio JoomSEF. That's your choice. You should also be aware that, as far as we know, Artio JoomSEF is not compatible with K 3.0.1 . Perhaps the situation has changed but no member of the community has informed us that they've successfully tested K 3.0.1 with Artio JoomSEF.

Perhaps you might like to ask the developers of Artio JoomSEF whether their "latest version" works with K 3.0.1? :dry:

... could you help me at least in what direction I have to look to solve this? I am really stuck.

Apart from using Artio JoomSEF, the only other thing that leaps out from your configuration is the Shape5.com site template that you are using which was probably designed for an older version of Joomla (perhaps when you were using J! 1.5.21).

There are two things you should investigate first and, after that, you can ask your question on the Joomla forum and I am quietly confident that they will say much the same as what I just wrote.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.208 seconds