Kunena 6.3.3 released

The Kunena team has announce the arrival of Kunena 6.3.3 [K 6.3.3] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3
Note: Please go to the Kunena Dashboard after an upgrade so that the Kunena database tables are also updated.

Question Incomplete Subscription URL in email

More
15 years 1 month ago #1 by pashley
When users receive an email to a topic they have subscribed to, the URL referencing the topic is incomplete. Here's an example from an email:

You can administer your subscriptions by following the 'My Profile' link on the Forum home page after you have logged in on the site. From your profile you can also unsubscribe from the topic.
URL: /forum?func=view&catid=20&id=39#48

See how the URL is incomplete? I'm guessing that it should be a complete, clickable URL so a user can jump right to that thread?

How do I fix that?

Please Log in or Create an account to join the conversation.

More
15 years 1 month ago #2 by xillibit
Hello,

do you have the right path for the variable $live_site in the file /joomla/configuration.php ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
15 years 1 month ago #3 by pashley
Ok, this is the cofiguration.php file found on the top root of Joomla, right? There was nothing there, so I put it in, refresehed the forum, and got an email, but it still wasn't a complete URL....any other ideas? :)

Please Log in or Create an account to join the conversation.

More
15 years 1 month ago #4 by pashley
Anyone else have any ideas? PLEASE?!!!

Please Log in or Create an account to join the conversation.

More
15 years 1 month ago #5 by Matias
There is still something wrong in your Joomla installation. We are using URL given by Joomla SEF function.

Unfortunately I have not seen anything like this before, so I cannot give any suggestions of why URLs do not work.

Which Joomla version do you have installed?

Please Log in or Create an account to join the conversation.

More
15 years 1 month ago - 15 years 1 month ago #6 by sozzled
... and while we're at it, which version of Kunena is pashley using?

However, yes, there is something very wrong with pashley's Joomla installation gauging from the response:

Ok, this is the cofiguration.php file found on the top root of Joomla, right? There was nothing there, so I put it in, refreshed the forum, and got an email, but it still wasn't a complete URL

What do you mean "there was nothing there" ... and "I put it in"? What did you "put in" - I think that's what Matias means by his earlier question.

Here's an edited version of my Joomla configuration.php file for you to compare (I have "--edited out--" some values for obvious reasons):
Code:
<?php class JConfig { var $offline = '0'; var $editor = 'tinymce'; var $list_limit = '20'; var $helpurl = 'http://help.joomla.org'; var $debug = '0'; var $debug_lang = '0'; var $sef = '1'; var $sef_rewrite = '1'; var $sef_suffix = '0'; var $feed_limit = '10'; var $feed_email = 'author'; var $secret = '--edited out--'; var $gzip = '1'; var $error_reporting = '-1'; var $xmlrpc_server = '0'; var $log_path = '--edited out--'; var $tmp_path = '--edited out--'; var $live_site = ''; var $force_ssl = '0'; var $offset = '10'; var $caching = '0'; var $cachetime = '15'; var $cache_handler = 'file'; var $memcache_settings = array(); var $ftp_enable = '1'; var $ftp_host = '127.0.0.1'; var $ftp_port = '21'; var $ftp_user = ''; var $ftp_pass = ''; var $ftp_root = ''; var $dbtype = 'mysql'; var $host = 'localhost'; var $user = '--edited out--'; var $db = '--edited out--'; var $dbprefix = 'jos_'; var $mailer = 'mail'; var $mailfrom = '--edited out--'; var $fromname = '--edited out--'; var $sendmail = '/usr/sbin/sendmail'; var $smtpauth = '0'; var $smtpuser = ''; var $smtppass = ''; var $smtphost = 'localhost'; var $MetaAuthor = '1'; var $MetaTitle = '1'; var $lifetime = '15'; var $session_handler = 'database'; var $password = '--edited out--'; var $sitename = '--edited out--'; var $MetaDesc = 'Joomla! - the dynamic portal engine and content management system'; var $MetaKeys = 'joomla, Joomla'; var $offline_message = 'This site is down for maintenance. Please check back again soon.'; } ?>
As you can see, the variable $live_site is, by default, set to an empty text string.
Last edit: 15 years 1 month ago by sozzled.

Please Log in or Create an account to join the conversation.

More
15 years 1 month ago #7 by pashley
My Configuration.php is the same, except I had live_site filled in with the URL of my site. I put that back no null, as you have. I did notice the permissions on the file were 444 - is that correct?

Please Log in or Create an account to join the conversation.

More
15 years 1 month ago #8 by pashley
Anyone?!

Please Log in or Create an account to join the conversation.

More
15 years 1 month ago #9 by Matias
I have no idea why you're having issues with SEF. Could you look at html source code? Do you have relative urls in there, too?

Please Log in or Create an account to join the conversation.

More
15 years 1 month ago #10 by pashley
I'm not sure which HTML you are referring to...for the template, or somewhere in the Joomla directory? I'm not a software guy, sorry...

Also I am using version 1.5.1b

Please Log in or Create an account to join the conversation.

Time to create page: 0.423 seconds