×
Blue Eagle (1.5.0) for K5.1 is released (20 Jul 2018)

Please update the Kunena Blue Eagle to 1.5.0 if you use Kunena 5.1.
We made several bug fixes and improvements. Also Blue Eagle has now all the features from Crypsis.
Download: www.kunena.org/download/templates/category/blue-eagle-5

× This section is for questions directly related to the procedure for installing Kunena for the first time or upgrading from an older version of Kunena.

Use this category:
  • to ask how to install or upgrade; or
  • if you encountered problems during the installation or upgrade procedure.

Use a different category to ask questions about problems that you may be having after you successfully installed or upgraded the currently supported version. If you are unsure what is the current supported version of Kunena, please go to the download page.

Question Search friendly URL break topics' listing

More
2 weeks 5 days ago #1 by rogoghaje
Setting
Search Engine Friendly URLs to [YES]
both in Joomla > Global Configuration > Site > SEO Settings and in Kunena > Configuration > SEO
breaks listing of the topic within a category.

With SEF URLs off some topics are listed. With SEF URLs on no topic is listed screenshots.firefox.com/1kKQv3fZ0I4zI8YB/ctenarsky-klub.cz
https://[mysite]/index.php/forum/besedy-pro-rok-2018

How should I properly set up SEF URLs settings, please?

Please Log in or Create an account to join the conversation.

More
2 weeks 5 days ago #2 by 810
Please add kunena report.

Please Log in or Create an account to join the conversation.

More
2 weeks 5 days ago #3 by rogoghaje
This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 60 seconds | Max execution memory: 128M | Max file upload: 16M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : protostar | author: Kyle Ledbetter | version: 1.0 | creationdate: 4/30/2012

Kunena default template details : Crypsis | author: Kunena Team | version: 5.1.2 | creationdate: 2018-07-15

Kunena template params:

Warning: Spoiler! [ Click to expand ]

Kunena version detailed: Kunena 5.1.2 | 2018-07-15 [ Charon ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: Content - Kunena Discuss 5.1.1

Modules: None

Please Log in or Create an account to join the conversation.

More
2 weeks 5 days ago #4 by 810
The propper way to setup sef.


1) Rename htaccess.txt to .htaccess on your root
2) Go to backend - system configuration
3) Search Engine Friendly URLs = Yes, Use URL Rewriting = Yes, Add Suffix to URL = No, Unicode Aliases = yes
4) go to kunena configuration
5) Enable the kunena sef option.

Then everything should work.

Please Log in or Create an account to join the conversation.

More
2 weeks 2 days ago - 2 weeks 2 days ago #5 by rogoghaje
Thank you for the suggestion. I have set up items 1 to 5. Here is a screenshot of the Kunena SEF settings screenshots.firefox.com/QwSfPsAteyfTwzag/ctenarsky-klub.cz
and Global settings: screenshots.firefox.com/BRhyEIRoMHfgD1dD/ctenarsky-klub.cz

The Kunena forum (or other: Recent topics) is not accessible on https://[mysite]/forum This is a link offered by the native Kunena module.

Edit: https://[mysite]/index.php/forum/ is accessible. The link has been manually altered. It is not listed anywhere. After loading the forum main page. The links are again not accessible.

both [mysite]/index.php/component/kunena/besedy-pro-rok-2018
and [mysite]/component/kunena/besedy-pro-rok-2018
are leading to 404 error.

The link with index.php shows the 404 error page generated by the hosting server. The link without the index.php shows the 404 error page generated by Joomla (it is Joomla style page)
Last edit: 2 weeks 2 days ago by rogoghaje.

Please Log in or Create an account to join the conversation.

More
2 weeks 1 day ago #6 by 810
maybe the .htaccess file is wrong? Could you extract the full joomla package on your root, and try to edit the file again.

Please Log in or Create an account to join the conversation.

More
2 weeks 18 hours ago - 2 weeks 18 hours ago #7 by rogoghaje
I do not understand your suggestion. Is .htaccess something I could post here and one could possibly find a glitch in it?

Note: Since my last post, when I changed .htaccess.txt to .htaccess, a new .htaccess.txt has been created. It is identical with the renamed .htaccess
Last edit: 2 weeks 18 hours ago by rogoghaje.

Please Log in or Create an account to join the conversation.

More
2 weeks 18 hours ago #8 by rogoghaje
Hi,

my fault: the htaccess.txt has been renamed to htaccess only. Today I added the dot and it is named .htaccess. The forum links works as expected, e.g.:

https://[mysite]/forum/besedy-pro-rok-2018

I think that the SEF settings is working OK.

Only that the topics are not shown or listed: screenshots.firefox.com/sEZ6V8jGMYYKbc7J/ctenarsky-klub.cz Only the number of topics is shown. Some old links to topics won't work either, e.g. https://[mysite]/forum/besedy-pro-rok-2016/25-2016-07-04-AW Shall I open a new thread with this question?

Please Log in or Create an account to join the conversation.

More
2 weeks 18 hours ago #9 by rogoghaje
Oh, and I had to leave
Direct Component Access [YES]
although, it is not advisable. Otherwise the forum categories won't open.

with Direct Component Access [YES]
https://[mysite]/forum/besedy-pro-rok-2018 (loading OK)

with Direct Component Access [NO]
https://[mysite]/component/kunena/besedy-pro-rok-2018 (404 component not found)

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.138 seconds