×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

× Themen, die in diesen Bereich verschoben wurden, gelten allgemein als beendet. Falls es dazu noch zusätzliche Fragen gibt, können diese zwar noch gestellt werden, aber diese alten Themen sollten auf keinen Fall wieder auferstehen, um neue Probleme zu erörtern.
Eröffnet dazu bitte ein eigenes neues Thema.

Important Fehlermeldung seit Update von JS Community ---gelöst---

More
8 years 5 months ago - 8 years 5 months ago #1 by NinjaTeufel
hallo Kunena Gemeinde,
ich nutze auf meiner Seite Joomla 2.5.3 mit JS Community (Jomsocial) 2.6 und Kunena 1.7.2

Nachdem ich JS Community von Version 2.4.3 auf 2.6 upgedatet habe tritt bei mir eine Fehlermeldung auf. Immer wenn ich in JS eine Gruppendiskussion schreibe und speichere und danach auf die Startseite zurückkeheren will kommt folgender Fehler:

Fatal error: Call to a member function authorisedLevels() on a non-object in /home/---mein Verzeichnis---/--Verzeichnis Webseite---/administrator/components/com_kunena/libraries/integration/joomla16/access.php on line 57

Weiße Seite mit dieser Fehlermeldung.

Offensichtlich hat es irgendwas mit dem Zusammenspiel von Kunena und JS zu tun. Selbst das Kunena Update auf 1.7.2 brachte keine Änderung

die im Fehler angegebene Programmzeile lautet so:

$accesslevels = (array) $user->authorisedLevels();

kennt irgendjemand den Fehler oder hatte ihn auch. Wäre cool wenn jemand ne Lösung hätte

Vorab schonmal Danke für euere Hilfe
Last edit: 8 years 5 months ago by NinjaTeufel.

Please Log in or Create an account to join the conversation.

More
8 years 5 months ago #2 by rich
Servus Ninja Teufel,

versuche bitte, ob dieser Code bei dir den Fehler beseitigt (Beitrag #12).
www.kunena.org/forum/169-K-16-and-K-17-S...57?limit=10&start=10

Please Log in or Create an account to join the conversation.

More
8 years 5 months ago - 8 years 5 months ago #3 by NinjaTeufel
so hab den Code dort eingefügt.
Bringt keine Änderung. Sobald ich in JS eine Gruppendisccussion schreibe und speichere, bin ich so wie es aussieht plötzlich ausgelogged.

Wenn ich dann auf die Startseite will taucht der fehler wieder auf.
Last edit: 8 years 5 months ago by NinjaTeufel.

Please Log in or Create an account to join the conversation.

More
8 years 5 months ago #4 by rich
Schade, diese Lösung ist nämlich im JomSocial Forum auch gepostet worden. Frag bitte mal bei deinem Anbieter nach, es könnte auch an einer falschen Konfiguration am Server liegen.

Please Log in or Create an account to join the conversation.

More
8 years 5 months ago #5 by NinjaTeufel
hmmm aber es hat doch die ganze Zeit funktioniert.

Der Fehler kam erst nach dem JS Update auf 2.6

Am Server wurde nichts geändert.

Please Log in or Create an account to join the conversation.

More
8 years 5 months ago - 8 years 5 months ago #6 by rich
Mach bitte mal ein Update auf Joomla 2.5.4. Es wurden über 150 Fehler behoben. Vielleicht hilft es.
Last edit: 8 years 5 months ago by rich.

Please Log in or Create an account to join the conversation.

More
8 years 5 months ago #7 by NinjaTeufel
Update auf 2.5.4 gemacht ....keine Änderung.

Offenbar wir beim speichern einer JS Discussion die Session beendet. Direkt nach dem speichern bin ich ausgelogged. Klicke ich nen anderen Link an kommt kein Fehler.(ausgelogged stehen nur noch 3-4 Links zur Verfügung) Nur beim klick auf Startseite tritt der fehler auf.

Please Log in or Create an account to join the conversation.

More
8 years 5 months ago - 8 years 5 months ago #8 by NinjaTeufel
meine Serverkonfig sieht so aus:

PHP erstellt für Linux server.joom4host.com 2.6.18-028stab092.1-ent #1 SMP Wed Jul 20 21:43:15 MSD 2011 i686

Datenbankversion 5.1.61

Datenbankzeichensatz utf8_general_ci

PHP-Version 5.2.17

Webserver Apache/2.2.19 (Unix) mod_ssl/2.2.19 OpenSSL/0.9.8e-fips-rhel5 DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635

PHP-Interface für den Webserver cgi

Joomla!-Version Joomla! 2.5.4 Stable [ Ember ] 2-April-2012 14:00 GMT

Joomla!-Plattform-Version Joomla Platform 11.4.0 Stable [ Brian Kernighan ] 03-Jan-2012 00:00 GMT
Last edit: 8 years 5 months ago by NinjaTeufel.

Please Log in or Create an account to join the conversation.

More
8 years 5 months ago #9 by NinjaTeufel
Fehler hat sich durch Umzug auf einen anderen Server von selbst gelöst.
Kann nur vermuten das es an der php Version gelegen hat.

Der neue Server läuft unter php Version: 5.3.10

Trotzdem Danke für euere Tipps
The following user(s) said Thank You: rich

Please Log in or Create an account to join the conversation.

More
8 years 5 months ago #10 by rich
Danke für deine Rückmeldung!

Frag bitte mal bei deinem Anbieter nach, es könnte auch an einer falschen Konfiguration am Server liegen.

Deshalb meinte ich, dass du mal nachfragen sollst.
Kunea läuft zwar noch mit der minimalen Anforderung php 5.2.3+ aber es wird sowieso php 5.3.0+ empfohlen.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.141 seconds