×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

× Les sujets sont déplacés dans ce domaine ne sont fermés parce qu'ils se rapportent à des versions non prises en charge de Kunena.

Important Problême de détection de la version PHP lors de l'installation

More
11 years 1 month ago #1 by Adelkan
Bonjour,

Lors de l'installation j'obtiens le message d'erreur suivant qui stipule que la version de PHP est trop ancienne.

I N S T A L L : F A I L E D - Minimum Version Requirements not satisfied

php version: 4.4.4-8+etch6 (Required >= 5.0.3)
mysql version: 5.0.32-Debian_7etch10-log (Required > 4.1.19)

Mais lorsque je vérifie auprès de mon hébergeur j'ai bien la version minimale :

MySQL

* Serveur: mysql10 via TCP/IP
* Version du serveur: 5.0.32-Debian_7etch10-log
* Version du protocole: 10
* Utilisateur: This email address is being protected from spambots. You need JavaScript enabled to view it.
* Jeu de caractères pour MySQL: UTF-8 Unicode (utf8)

Serveur web

* Apache/2.2.3 (Debian) PHP/5.2.0-8+etch15
* Version du client MySQL: 5.0.32
* Extension PHP: mysqli

phpMyAdmin

* Version: 3.1.0-rc1

C'est incompréhensible pourriez vous m'aider !

Merci d'avance !

Yann

PS : www.mogchokrinpocheasso.fr

Please Log in or Create an account to join the conversation.

More
11 years 4 weeks ago - 11 years 4 weeks ago #2 by xillibit
Bonjour,

Quelle version de Kunena essayez-vous d'installer ?

Je ne sais pas du tout pourquoi il y a une mauvaise lecture des versions de Php et MySQL.

En supprimant, la condition qui vérifie les versions de Php ET MySQL cela peut marcher, il faut modifier le fichier install/kunena.install.php et à la ligne 75 vous remplacez ceci :
if (version_compare(phpversion(), KUNENA_MIN_PHP, ">=") && version_compare($mysqlversion, KUNENA_MIN_MYSQL, ">"))

par ceci :
if(1)

I don't provide support by PM, because this can be useful for someone else.
Last edit: 11 years 4 weeks ago by xillibit.

Please Log in or Create an account to join the conversation.

More
11 years 4 weeks ago #3 by Adelkan
xillibit wrote:

Bonjour,

Quelle version de Kunena essayez-vous d'installer ?

Il s'agit de Kunena 1.5.4 native stable 12 Juillet 2009 20h30

Je ne sais pas du tout pourquoi il y a une mauvaise lecture des versions de Php et MySQL.

En supprimant, la condition qui vérifie les versions de Php ET MySQL cela peut marcher, il faut modifier le fichier install/kunena.install.php et à la ligne 75 vous remplacez ceci :

if (version_compare(phpversion(), KUNENA_MIN_PHP, ">=") && version_compare($mysqlversion, KUNENA_MIN_MYSQL, ">"))

par ceci :
if(1)


L'installation s'est bien déroulée (même s'il n'y à toujours pas la version de PHP requise) :

I N S T A L L : Successful

php version: 4.4.4-8+etch6 (Required >= 5.0.3)
mysql version: 5.0.32-Debian_7etch10-log (Required > 4.1.19)

Mais lorsque je choisi le composant j'ai le message d'erreur suivant :

Parse error: syntax error, unexpected T_CLASS in /users/user8884/sites/mogchokrinpocheasso.fr/components/com_kunena/lib/kunena.config.class.php on line 65

Merci de votre aide :)

Please Log in or Create an account to join the conversation.

More
11 years 4 weeks ago #4 by xillibit
Pour résoudre ce souci, il est nécessaire que tu passe à PHP5, je ne sais pas si ton hébergeur le permet, c'est vraiment dommage que PHP5 ne soit pas mis par défaut chez tous les hébergeur.

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
11 years 4 weeks ago #5 by Adelkan
Pourtant sur phpmyadmin de mon hébergeur il est bien indiqué que la base est en version 5 :

Serveur web

* Apache/2.2.3 (Debian) PHP/5.2.0-8+etch15
* Version du client MySQL: 5.0.32
* Extension PHP: mysqli

Mais si y'a pas de solution tant pis et merci de votre aide !

Please Log in or Create an account to join the conversation.

More
11 years 4 weeks ago #6 by xillibit
Dans le phpinfo, il t'indique aussi PHP 5.2.0 ? Pour accéder au phpinfo : dans l'administration de joomla -> aide -> infos système -> informations php

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
11 years 4 weeks ago #7 by Adelkan
Effectivement dans info système il est indiqué :

Version de PHP: 4.4.4-8+etch6

J'attends la réponse de mon hébergeur Oxyd pour savoir s'ils peuvent effectuer une mise à jour !

Merci pour tout !

Please Log in or Create an account to join the conversation.

More
11 years 3 weeks ago #8 by Adelkan
Bon le problème est résolu pour passer à la version 5 de PHP et sur les conseils du support d'Oxyd, j'ai créé un fichier .htaccess placé dans le répertoire racine du site avec la ligne suivante :

AddHandler x-httpd-php5 .php

J'ai ensuite pu installer Kunena sans aucune difficulté !

Merci !!!

:)

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.125 seconds